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The information in this document is current as of October, 2000. The information is subject to 
change without notice.  For actual design-in, refer to the latest publications of NEC's data sheets or 
data books, etc., for the most up-to-date specifications of NEC semiconductor products.  Not all 
products and/or types are available in every country.  Please check with an NEC sales representative 
for availability and additional information.
No part of this document may be copied or reproduced in any form or by any means without prior       
written consent of NEC.  NEC assumes no responsibility for any errors that may appear in this document.
NEC does not assume any liability for infringement of patents, copyrights or other intellectual property rights of 
third parties by or arising from the use of NEC semiconductor products listed in this document or any other 
liability arising from the use of such products.  No license, express, implied or otherwise, is granted under any 
patents, copyrights or other intellectual property rights of NEC or others.
Descriptions of circuits, software and other related information in this document are provided for illustrative 
purposes in semiconductor product operation and application examples. The incorporation of these 
circuits, software and information in the design of customer's equipment shall be done under the full 
responsibility of customer. NEC assumes no responsibility for any losses incurred by customers or third 
parties arising from the use of these circuits, software and information.
While NEC endeavours to enhance the quality, reliability and safety of NEC semiconductor products, customers 
agree and acknowledge that the possibility of defects thereof cannot be eliminated entirely.  To minimize 
risks of damage to property or injury (including death) to persons arising from defects in NEC 
semiconductor products, customers must incorporate sufficient safety measures in their design, such as 
redundancy, fire-containment, and anti-failure features.
NEC semiconductor products are classified into the following three quality grades:
"Standard", "Special" and "Specific".  The "Specific" quality grade applies only to semiconductor products 
developed based on a customer-designated "quality assurance program" for a specific application.  The 
recommended applications of a semiconductor product depend on its quality grade, as indicated below.  
Customers must check the quality grade of each semiconductor product before using it in a particular 
application.
 "Standard": Computers, office equipment, communications equipment, test and measurement equipment, audio

and visual equipment, home electronic appliances, machine tools, personal electronic equipment
and industrial robots

"Special": Transportation equipment (automobiles, trains, ships, etc.), traffic control systems, anti-disaster
systems, anti-crime systems, safety equipment and medical equipment (not specifically designed
for life support)

"Specific": Aircraft, aerospace equipment, submersible repeaters, nuclear reactor control systems, life
support systems and medical equipment for life support, etc.

The quality grade of NEC semiconductor products is "Standard" unless otherwise expressly specified in NEC's 
data sheets or data books, etc.  If customers wish to use NEC semiconductor products in applications not 
intended by NEC, they must contact an NEC sales representative in advance to determine NEC's willingness 
to support a given application.
(Note)
(1) "NEC" as used in this statement means NEC Corporation and also includes its majority-owned subsidiaries.
(2) "NEC semiconductor products" means any semiconductor product developed or manufactured by or for

NEC (as defined above).

•

•

•

•

•

•
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Regional Information

Some information contained in this document may vary from country to country.  Before using any NEC
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representatives and distributors.  They will verify: 

•  Device availability

•  Ordering information

•  Product release schedule

•  Availability of related technical literature

•  Development environment specifications (for example, specifications for third-party tools and
   components, host computers, power plugs, AC supply voltages, and so forth)

•  Network requirements

In addition, trademarks, registered trademarks, export restrictions, and other legal issues may also vary
from country to country.
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INTRODUCTION

Readers This manual is intended for user engineers who design and develop application

systems of the 78K/0 and 78K/0S Series.

Purpose This manual is intended to give users an understanding of the functions of the

ID78K0-NS and ID78K0S-NS shown in the organization below.

Organization This manual consists of the following chapters:

• General

• Installation

• Starting and exiting

• Functions of ID78K0-NS and ID78K0S-NS

• Association with project manager

• Window reference

How to read this manual It is assumed that the readers of this manual have general knowledge of electrical

engineering, logic circuits, microcontrollers, C language, and assemblers.

For users who are using this manual as the ID78K0S-NS user’s manual

→ Unless there are differences in functionality, the ID78K0-NS is described as the

representative product in this manual. Substitute ID78K0S-NS for ID78K0-NS when

necessary.

To understand the hardware functions of the 78K/0 and 78K/0S Series

→ Refer to the Hardware User’s Manual  for each product.

To understand the instruction functions of the 78K/0 Series

→ Refer to the 78K/0 Series User's Manual Instructions .

To understand the instruction functions of the 78K/0S Series

→ Refer to the 78K/0S Series User's Manual Instructions .
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Conventions Data significance: Higher digits on the left and lower digits on the right

Note : Footnote for item marked with Note  in the text

Caution : Information requiring paticular attention

Remark : Supplementary information

Numerical representation: Binary… ×××× or ××××B

Decimal… ××××
Hexadecimal…××××H

Prefixes indicating power of 2 (address space, memory capacity):

K (kilo): 210 = 1,024

M (mega): 220 = 1,0242

Key descriptions: The key descriptions in this manual are explained in

terms of the PC-9821 series keyboard.  When using a

keyboard whose key descriptions differ from the above,

use the keys in accordance with the descriptions in

APPENDIX D  KEY FUNCTION LIST .
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Related Documents The documents related to this manual are listed below.

The related documents indicated in this publication may include preliminary versions.

However, preliminary versions are not marked as such.

Documents related to development tools (user’s manuals) (78K/0 Series)

Document Name Document No.

IE-78K0-NS (In-circuit emulator for 78K/0 Series) U13731E

IE-78K0-NS-A (In-circuit emulator for 78K/0 Series) U14889E

IE-78K0-NS-PA (Peripheral I/O board for 78K/0 Series) To be prepared

Operation U14297ECC78K0 (C compiler)

Language U14298E

Operation U14445E

Language U14446E

RA78K0 (Assembler package)

Structured Assembly Language U11789E

SM78K0S, SM78K0 (Ver. 2.10 or later) (System

simulator)

Operation Windows™ Based To be prepared

ID78K0-NS, ID78K0S-NS (Ver. 2.20 or later)

(Integrated debugger)

Operation Windows Based This manual

ID78K0-NS (Integrated debugger) Reference Windows Based U12900E

Reference Windows Based U11539EID78K0 (Integrated debugger)

Guide Windows Based U11649E

Fundamentals U11537E78K/0 Series Real-Time OS

Installation U11536E

MX78K0 (78K/0 Series OS) Fundamental U12257E

Project Manager Ver. 3.12 or later (Windows Based) U14610E

Documents related to development tools (user’s manuals) (78K/0S Series)

Document Name Document No.

IE-78K0S-NS (In-circuit emulator for 78K/0S Series) U13549E

IE-78K0S-NS-A (In-circuit emulator for 78K/0S Series) To be prepared

Operation U11816ECC78K0S (C compiler)

Language U11817E

Operation U11622E

Language U11599E

RA78K0S (Assembler package)

Structured Assembly Language U11623E

SM78K0S, SM78K0 (Ver. 2.10 or later) (System

simulator)

Operation Windows™ Based U14611E

ID78K0-NS, ID78K0S-NS (Ver. 2.20 or later)

(Integrated debugger)

Operation Windows Based This manual

ID78K0S-NS (Integrated debugger) Reference Windows Based U12901E

MX78K0S (78K/0S Series OS) Fundamental U12938E

Project Manager Ver. 3.12 or later (Windows Based) U14610E
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CHAPTER  1    GENERAL

1.1  Overview

The 78K/0 Series integrated debugger ID78K0-NS (hereafter referred to as “ID78K0-NS”) and the 78K/0S Series

integrated debugger ID78K0S-NS (hereafter referred to as “ID78K0S-NS”) are software tools, developed for NEC’s

78K/0 and 78K/0S Series of 8-bit microcontrollers for embedded control applications, to debug the user programs

efficiently.

The ID78K0-NS and ID78K0S-NS feature an easy-to-understand GUI (graphical user interface) on a host machine

using Windows as the operating system.

Moreover, the commands that are frequently used can be input using the mouse, providing an environment with

excellent operability.

1.2  Features

The features of the ID78K0-NS and ID78K0S-NS are as follows.

(1) GUI function

The ID78K0-NS and ID78K0S-NS run in a Windows environment and their debugging operations can be

controlled with a mouse.  Buttons and menus are displayed in each window, and other related information can be

selected from the displayed information.

(2) Debugging at source level

Referencing/setting variables and structures, displaying programs, and setting breakpoints can be efficiently

performed at source text level by manipulating function names and line numbers.

(3) Debugging at instruction level

Referencing/setting symbols and register values, displaying programs, and setting breakpoints can be efficiently

performed at instruction level by manipulating labels and addresses.

(4) Use of in-circuit emulator

Breakpoints can be set and user programs can be traced by using the detailed event setting functions of an in-

circuit emulator.

(5) Monitor function (automatic display updating function while execution is stopped)

When execution of the user program is stopped, the values displayed in the window are automatically updated.

(6) Saving/restoring debugging environment

The debugging environment can be saved in a file.  The saved environment can be restored, and debugging can

be resumed from where the debugging environment was saved.

(7) Function expansion by TIP (Tool Interface Protocol)

By linking up with a task debugger (RD), system performance analyzer (AZ), etc., it is possible to vastly improve

the debugging efficiency of applications that use a real-time OS (RX).
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1.3  System Configuration

The ID78K0-NS and ID78K0S-NS offer a comfortable debugging environment for user programs and target boards

developed for the 78K/0 and 78K/0S Series by connecting the host machine and the in-circuit emulator via a

dedicated parallel interface board.

Figure 1-1 shows an example of the system configuration of the ID78K0-NS and ID78K0S-NS.

Figure 1-1.  ID78K0-NS and ID78K0S-NS System Configuration Example

Device File

Host machine

Interface board

In-circuit emulator

Target system

 ID78K0-NS,
ID78K0S-NS

Device driver
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1.4  Operating Environment

To use the ID78K0-NS and ID78K0S-NS, the following hardware and software environments are necessary.

1.4.1  Hardware environment

(1) Host machine

• PC-9821 series

• PC98-NX series

• IBM PC/ATTM or compatibles

CPU: PentiumTM 100 MHz or more (120 MHz or more is recommended)

Memory: RAM:  32 MB or more (64 MB or more is recommended)

(2) In-circuit emulator

•••• For ID78K0-NS •••• For ID78K0S-NS

• IE-78K0-NS • IE-78K0S-NS

• IE-78K0-NS-A • IE-78K0S-NS-A

(3) In-circuit emulator optional board

•••• For ID78K0-NS •••• For ID78K0S-NS

<1> Emulation board • IE-789xxx-NS-EM1

• IE-780xxx-NS-EM1

• IE-780xxx-NS-EM4

• IE-78K0-NS-P0x

<2> Performance board (78K/0 Series only)

• IE-78K0-NS-PA

Caution These optional boards are used in combination with the in-circuit emulator.

(4) Interface board

• IE-70000-98-IF-C (PC-9821 series)

• IE-70000-PC-IF-C (IBM PC/AT or compatibles)

• IE-70000-CD-IF-A

• IE-70000-PCI-IF(-A)

1.4.2  Software environment

(1) OS

Windows 95, Windows 98, Windows 2000, Windows NTTM4.0 (Service Pack 3)

(2) Device file

Device file of target file to be used

(3) Device driver

Device driver for interface board (included with this product)
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1.5  Note for Debugging at Source Level

When debugging at the source level, add an option (-g option) that creates debugging information after the source

files have been compiled.  If this is not done, debugging cannot be performed at the source level.
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CHAPTER  2    INSTALLATION

Prior to using the ID78K0-NS (ID78K0S-NS), it is necessary to install the ID78K0-NS (ID78K0S-NS), a device file,

and a device driver.

This chapter explains how to install/uninstall the ID78K0-NS (ID78K0S-NS).

2.1 Device Driv er

Install the device driver according to the “README_E.TXTNote” in the 3.5-inch floppy disk “NEC IE-PC Driver V1.0”

or CD-ROM directory “Driver”.

Note When using Windows 98 or Windows 2000, follow the same procedure as when using Windows 95.

2.2 Device File

To install the device file, use the “Device file installer” included with this product. Use of this dedicated installer

enables installation of the device file in the Win32 environment.

Since the installer “SETUP.EXE” in the device file product disk is for the Win16 environment, it registers the device

file information “NECDEV.INI”. However, because this product supports the Win32 environment, the device file

information must be registered in the registry. It is therefore essential to use the “Device file installer”.

An outline of the installation procedure is described below.

<1> Start up the “Device file installer”. When newly installing the device file, click the  Install  button on the display

following startup and specify the installation information file “NECSETUP.INI” from the device file product

disk.

<2> If the device file is registered in “NECDEV.INI” and needs to be moved to the Win32 environment, specify

“NECDEV.INI” from the DFINST “source selection”. Following the specification, select the type displayed in

the “Source” list and click the  Move  button. (Note that the FPGA data file (G0XXX.78K) will not be moved

automatically and therefore should be copied manually.)

<3> To uninstall the device file, select the type displayed in the DFINST “registry” list, select “Delete files”, and

click the  Uninstall  button.
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2.3 Installation of ID78K0-NS/ID78K0S-NS

2.3.1 Precautions for installation

<1> Prior to installation, create a backup of the system disks. The computer may need to be restarted after

installation, so exit all other applications currently being used.

<2> Do not install the ID78K0-NS (ID78K0S-NS) in a directory in which a version of the ID78K0-NS (ID78K0S-

NS) earlier than V2.01 is installed. Since products of an earlier version than V2.01 support Win16, addition

of an ID78K0-NS (ID78K0S-NS) supporting Win32 in the same directory may cause the device to

malfunction.

<3> If reinstalling the ID78K0-NS (ID78K0S-NS), be sure to uninstall it first. If the ID78K0-NS (ID78K0S-NS) has

not been uninstalled and is reinstalled in a directory that is different to the one the ID78K0-NS (ID78K0S-

NS) was originally installed in, uninstallation of the originally installed ID78K0-NS (ID78K0S-NS) may

become impossible.

<4> Do not install the ID78K0-NS (ID78K0S-NS) in a directory with blank spaces. Related tools, such as the

Project Manager, that are to be installed in the same directory as the ID78K0-NS (ID78K0S-NS) may not

operate correctly, depending on their version.

<5> The file below created following installation is the file used for uninstallation, and therefore should not be

deleted (it is assumed that the installation destination is C:\nectools32).

C:\nectools32\SETUP\*.*

<6> “comctl32.dll4.72 installation” (40comupd.exe) is registered in the program folder in which the ID78K0-NS

(ID78K0S-NS) is installed. This file is used to update the comctl32.dll file used in the ID78K0-NS (ID78K0S-

NS). If an application error occurs while in use or problems such as a dialog box not displaying data

correctly are experienced, install comctl32.dll using “comctl32.dll4.72 installation”. If Windows 98, Windows

2000, or Microsoft Internet Explorer 3.0 or later is installed, installation of comctl32.dll is unnecessary.
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2.3.2 Installation procedure

The following describes the method of installing the ID78K0-NS (ID78K0S-NS). Here, the installation procedure is

explained with “C:\Windows” as the directory in which Windows is installed and “E” as the floppy disk drive.

<1> Turn on power to the host machine (PC-9821 or IBM PC/AT) and start up Windows.

<2> <When 3.5-inch floppy disk used as supply medium>

Insert system disk #1 of the ID78K0-NS (ID78K0S-NS) in the floppy disk drive (E drive) and start the

installer “setup.exe”.

<When CD-ROM used as supply medium>

Insert the CD-ROM in the CD-ROM drive. The installer will automatically start.

If the installer does not start automatically, start from the directory “DISK1/setup.exe”.

<3> The setup program is activated following setup initialization. Click  .

Installation can be terminated by clicking the  button.
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<4> When installing the ID78K0-NS (ID78K0S-NS), click  after reading and accepting the terms of

the software license agreement. Clicking  will abort installation. Click  to

display the previous screen.

<5> Select the items to be installed and the destination drive or directory. Clear the check mark from the

components that are not to be installed. The default destination drive or directory is C:\nectools32.

Bearing in mind relationships with other NEC tools, installation using the default directory is recommended.

If there is a problem with the drive or directory, click  and make appropriate modifications.

After setting each item, click .

To abort installation, click . Click  to display the previous screen.
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<6> If newly installing an ID78K0-NS (ID78K0S-NS) or if previously installed ID78K0-NS (ID78K0S-NS) has

already been uninstalled, follow the procedure from <7>.

(1) If there is an ID78K0-NS (ID78K0S-NS) preinstalled in the directory specified by <5>, the following message

is displayed.
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Click  and the following dialog box appears.

Click  to uninstall the ID78K0-NS (ID78K0S-NS).

If  is selected, uninstallation will not be executed and the procedure shifts to <7>.

(2) If the ID78K0-NS (ID78K0S-NS) is installed in a directory other than a directory specified by <5>, the

following message is displayed.

Note that the execution shifts to <7> by clicking , in which case the uninstaller will not be

activated.
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<7> Specify the name of the folder in which the ID78K0-NS (ID78K0S-NS) icon is to be registered. The default

folder name is “NEC Tools32”. After specifying the folder name, click . To abort installation,

click . Click  to display the previous screen.

<8> Final confirmation of installation start is made. Check the settings made in <4> to <7>. If there are no

changes to these settings, click . If changes are necessary, click .

If there are any problems, click  and abort installation.
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<9> Start copying files.

<When 3.5-inch floppy disk used as supply medium>

The change-of-system-disk message (Setup Needs the Next Disk) dialog box will open, so after changing the

disk, click . This operation is repeated until the insertion of system disk #5.

The Change-of-system-disk message will appear during copying.

<When CD-ROM used as supply medium>

The Change-of-system-disk message will not be displayed. The contents of directory DISK1 to DISK5 are

automatically copied.

The installation status is displayed.

<10> If an NEC development tool environment for Win16 (default directory: \nectools) does not exist in the host

machine used, move to procedure <11>.

If a development tool for Win16 exists in the host machine, the following dialog box appears. Click

 to move the device file used in the development tool environment for Win16 to the

development tool environment for Win32 (this product). If  is selected, execute the device

file installer “DFINST.EXE” following the installation of the ID78K0-NS (ID78K0S-NS) to shift the device file.

The ID78K0-NS (ID78K0S-NS) will not operate normally unless the device file is moved.
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<11> After the files have been copied, the Setup Complete dialog box will open, so click .

Installation of the ID78K0-NS (ID78K0S-NS) is now complete.

<12> The ID78K0-NS (ID78K0S-NS) icon will be registered in the folder specified in procedure <7>.
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2.4  Uninstalling ID78K0-NS/ID78K0S-NS

This section explains how to uninstall the ID78K0-NS/ID78K0S-NS, using “C:\WINDOWS” as the directory in which

Windows is installed.

<1> Turn on power to the host machine (PC-9821 or IBM PC/AT) and start up Windows.

<2> Activate “Add/Remove Programs” from the control panel.

<3> Select “NEC ID78K0-NS 78K/0 Integrated Debugger V2.xx” (“NEC ID78K0S-NS 78K/0S Integrated

Debugger V2.xx” for the ID78K0S-NS) from the list displayed in “Install/Uninstall” and click

.
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<4> The Confirm File Deletion dialog box will be displayed next, so click .

File deletion starts.

<5> The dialog box below will appear during deletion, so click  (if  is selected and

the files are not deleted here, the latest “TIPAD78K0A.DLL” will be overwritten when the ID78K0-NS or

ID78K0S-NS is reinstalled).
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<6> The program will be deleted.  When the message “Uninstall completed” appears, click .

Uninstallation of ID78K0-NS (ID78K0S-NS) is now complete.
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CHAPTER  3    STARTING  AND  EXITING

This chapter explains how to start and exit the ID78K0-NS or ID78K0S-NS.

3.1  Starting

The start method is as follows:

<1> Turn on power to the in-circuit emulator and target system.

<2> Start Windows on the PC.

<3> Double-click the shortcut icon of the ID78K0-NS (ID78K0S-NS) on the desktop to start up the ID78K0-NS

(ID78K0S-NS) (See Figure 3-1).  The Configuration dialog box will be displayed (See Figure 3-2).

Figure 3-1.  ID78K0-NS (ID78K0S-NS) Icon

Figure 3-2.  Configuration Dialog Box on Starting
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<4> Operating environment parameters for the ID78K0-NS (ID78K0S-NS) are set in this dialog box (refer to

CHAPTER 6  WINDOW REFERENCE).  After setting the parameters, click the  button in the

dialog box.

<5> The main window will then be opened (See Figure 3-3) and the ID78K0-NS (ID78K0S-NS) can be operated.

Debugging operations are all carried out from this window.

Figure 3-3.  Main Window

Caution Problems such as dialog boxes not displaying data correctly are sometimes experienced

when the ID78K0-NS (ID78K0S-NS) is started up, or if an application error occurs while in

use.  One cause of such problems may be that an old version of comctl32.dll, which comes

with Windows 95, is being used.  If this is the case, it will be necessary to update

comctl32.dll using the comctl32.dll 4.72 Installer (40comupd.exe) included with this

product.

Note that if Windows 98 or Microsoft Internet Explorer 3.X or 4.X has been installed, this

update is unnecessary.

Figure 3-4.  comctl32.dll 4.72 Installer

(1) Toolbar

(3) Status display area

(2) Window display area
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3.2  Exiting

The exit method is as follows:

<1> In the main window, select [File] → [Exit].

→ The following Exit Debugger dialog box will be displayed.

Figure 3-5.  Exit Debugger Dialog Box

<2> To save the current debugging environment in the project file, check the check box “� Save Project file”.

<3> Click the  button.

If the check box is checked in <2>, the Save As dialog box is opened, the current debugging environment is

saved in the project file, all the windows are closed, and then the ID78K0-NS (ID78K0S-NS) is exited.

If the check box is not checked, all the windows are closed and then the ID78K0-NS (ID78K0S-NS) is

exited.
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[MEMO]
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CHAPTER  4    FUNCTIONS  OF  ID78K0-NS  AND  ID78K0S-NS

This chapter explains the basic functions and processing conventions of the ID78K0-NS and ID78K0S-NS.

4.1  Mapping Function

4.1.1  Mapping function of ID78K0-NS

The following seven types of mapping functions are available.

These mapping functions are set in the Configuration dialog box (Refer to CHAPTER 6  WINDOW REFERENCE).

(1) Internal ROM
The memory area specified as internal ROM is equivalent to the internal ROM of the target device.
If the target device writes data to the memory area, a write protect break occurs.

(2) Internal RAM
The memory area specified as internal RAM is equivalent to the internal RAM of the target device.
In this case, the target device accesses the memory in the in-circuit emulator.

(3) User area mapping (Target)
The memory area specified for user area mappingNote is an area that accesses the memory on the target system.
In this case, the target device accesses the memory on the target system.

Note These memory areas can be set in address areas other than the internal ROM and internal RAM areas.

(4) Emulation ROM
The memory area specified as emulation ROMNote is equivalent to the ROM connected to the target device.

Note These memory areas can be set in address areas other than the internal ROM and internal RAM areas.

(5) Emulation RAM
The memory area specified as emulation RAMNote is equivalent to the RAM connected to the target device.
In this case, the target device accesses the memory in the in-circuit emulator.

Note These memory areas can be set in address areas other than the internal ROM and internal RAM areas.

(6) I/O protect area (I/O Protect)

The I/O protect area can be set in the area specified as Target.  This area is displayed in the same manner as an

unmapped area on the Memory window (the symbol ?? is displayed).  If this area is mapped with this attribute, it

can no longer be read or written easily, protecting it from erroneous access from the Memory window.

To read or write a value of the area mapped with this attribute, register in the SFR window or Watch window

(Refer to CHAPTER 6  WINDOW REFERENCE).

(7) Stack area

The area used as a stack area can be set as the stack area.  Setting the stack area enables deletion of a “stack

overflow error” when data has overflowed from the stack area during program execution.
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4.1.2  Mapping functions of ID78K0S-NS

For the ID78K0S-NS, the following type of mapping function is available.

This mapping function is set in the Configuration dialog box (Refer to CHAPTER 6  WINDOW REFERENCE).

 (1) Stack area

The area used as a stack can be set as the stack area. Setting the stack area enables detection of a “stack

overflow error” when data has overflowed from the stack area during program execution.

4.2  Emulation Execution Functions

The emulation execution functions start the execution of the user program and the operation of the tracer and

timer by the emulation CPU.

These functions are classified as follows by the execution mode of the user program.

4.2.1  Real-time execution function

Real-time execution can be performed by the following commands.

• Go command (  button)

• Start command (no button)

• Go & Go command (no button)

• Come command (no button)

• Restart command (no button)

• Return Out command (  button)

(1) Go command (  button)
This command executes the user program starting from the address indicated by the current PC register.
Execution of the user program is stopped when a specified break event condition is satisfied.
Each analyzer gets ready to operate when the user program is executed, and is executed or stopped
depending on whether each event condition (trace event condition, timer event condition, etc.) is satisfied or
not.

(2) Start command
This command executes the user program starting from a specified address.  Execution of the user program
is stopped when a specified break event condition is satisfied.

(3) Go & Go command
This command executes the user program starting from the address indicated by the current PC register.
Execution of the user program is stopped once if a specified break event condition is satisfied.  The contents
of each window are updated, and the user program is then executed again starting from the address where it
stopped.  These operations are repeated until the user issues a Stop command.

(4) Come command
This command executes the user program starting from the address indicated by the current PC register to
the address selected in the line/address display area on the Source window or Assemble window (Refer to
CHAPTER 6  WINDOW REFERENCE), and then a break occurs.
While the user program is being executed by this command, the break event currently set does not occur.
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(5) Restart command
This command resets the emulation CPU and then executes the user program starting from address 0.
This operation is the same as when the Go command is executed following reset of the emulation CPU prior
to user program execution.

(6) Return Out command (  button)
This command executes until execution returns to the calling function.
This command may not operate properly with assembler functions, etc.

4.2.2  Non real-time execution function
Non real-time execution can be performed by using the following commands.

• Step In command (  button)

• Return Out command (  button)

• Next Over command (  button)

• Slowmotion command (no button)

(1) Step In command (  button)
The operation performed by this command differs as follows depending on the debugging mode.

(a) “Source level” mode
One line of the source text is executed starting from the current PC register value, and the contents of
each window are updated.

(b) “Instruction level” mode
One instruction is executed starting from the current PC register value, and the contents of each window
are updated.

(2) Next Over command (  button)
The operation of this command differs depending on the debugging mode.

(a) Source level
Next step execution is performed for one line of the source text from the current PC register value and
the contents of each window are updated.

(b) Instruction level
Next step execution is performed for one instruction from the current PC register value and the contents
of each window are updated.

(3) Slowmotion command
This command executes one line in the “source level” mode, or one instruction in the “instruction level”
mode, starting from the address indicated by the current PC register.  The contents of each window are
updated each time this command is executed.  These operations are repeated until the user issues a Stop
command.
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4.3  Event Function

An event is a “specific status of the target system” during the execution of the user program, for example “address

0x1000 fetched” and “data written to address 0x1000” showing the specific status of the target system during

debugging.

The ID78K0-NS and ID78K0S-NS use these events as action triggers for break, trace, timer measurement,

snapshot, and DMM functions.  An event function sets, deletes, or references the “specific status of the target

system” that triggers an action (debug action) as an “event condition”.

4.3.1  Using event function

To use an action that is triggered by an event in accordance with the user’s debugging aims, the event conditions

shown in Table 4-1 must be set.

Table 4-1.  Relationship Between Event Conditions and Setting Dialog Box

Event Condition Setting Dialog Box Function

Break event condition Break dialog box Condition to execute user program or stop operation of tracer and

timer

Trace event condition Trace dialog box Start/end condition when execution process of user program is saved

in trace memory

Timer event condition Timer dialog box Start/end condition when execution time of user program is

measured

Snap event condition Snap Shot dialog box Trigger condition for executing snapshot

DMM event condition DMM dialog box Condition to write arbitrary data to specified address when a

specified event is established during execution of user program

These event conditions are set by using an “event condition” or “event link condition” alone or in combination.

To use the event function of the ID78K0-NS and ID78K0S-NS, therefore, the necessary “event condition” and

“event link condition” are first created, and then the event conditions shown in Table 4-1 are set by using these

conditions.
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4.3.2  Event conditions

How to create each event condition is explained next.

(1) Creating event conditions
An “event condition” is set in the Event dialog box (Refer to CHAPTER 6  WINDOW REFERENCE).  An address
condition, status condition, data condition, external sense data condition, and access size condition are set in
this dialog box.  A name is given to the combination of these conditions for registration.  The maximum number of
event conditions that can be registered in the Event dialog box is 256.  The maximum number of event conditions
that can be simultaneously used for each event condition is 28 (16 execution events and 12 access events) for
the IE-78K0-NS + IE-78K0S-NS-PA, IE-78K0-NS-A, and IE-78K0S-NS and 12 (8 execution events and 4 access
events) for IE-78K0-NS and IE-78K0S-NS.
Table 4-2 lists the contents of each condition that can be set in the Event dialog box.

Table 4-2.  Each Condition That Can Be Set in Event Dialog Box

Condition Contents

Address condition Uses a specified address or address range as an event.  A mask value cannot be set for the

specified address.

Status condition Uses a status for an address condition as an event.  The status is selected from the following.

ExecutionNote: Execution of instruction

Before Execution: Execution of instruction (Break before execution)

Read: Reading memory

Write: Writing memory

R/W: Reading/writing memory

External Trigger1: External trigger (1 bit)

External Trigger2: External trigger (ID78K0-NS:  8 bits)

(ID-78K0S-NS: 16 bits)

Data condition Uses the data detected by a status condition as an event.  A mask value can be set for the

data.

External sense data condition Uses the data of the external probe signal as an event.  A mask value can be set for an

external sense data condition.

Note If Execution is selected as the status condition, the address mask, data, data mask, and access size

conditions are invalid.
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(2) Event condition type
Event conditions are classified into the three event types shown in the table below.  These event types are
automatically determined by selecting the desired status condition when creating an event condition.
Table 4-3 lists the event condition types.

Table 4-3.  Event Condition Types

Event Type Status Function

Execution event Execution

Before Execution

External Trigger1

External Trigger2

Event condition is satisfied when user program begins

execution of instruction at specified address and when data

is input to external sense clip at that time.

Up to 18 event conditions of this type can be used for each

event condition.

Access event Program Read

Program Write

Program R/W

When the user program accesses specified memory, up to

12 event conditions of this type can be used for each event

condition.

(3) Creating event link condition
An “event link condition” is a condition under which a sequential rule is applied to the respective events to treat
the events as a single event.  An event link condition is created in the Event Link dialog box (Refer to CHAPTER
6  WINDOW REFERENCE).  By arranging the event conditions first registered in the Event dialog box in random
order in the Event Link dialog box, these event conditions can be registered under one name as single event link
condition.  The registered event link condition can be used to set various event conditions in the same manner as
event conditions.
The maximum number of event link conditions that can be set in the Event Link dialog box is 256.  However, the
number of event link conditions that can be simultaneously used for each event condition is 3.

(4) Displaying setting status of event condition
All the registered event conditions and event link conditions are managed or displayed in the Event Manager
(Refer to CHAPTER 6  WINDOW REFERENCE).  The setting status of all the event conditions created by using
the event conditions or event link condition are also managed or displayed in the Event Manager.
In the Event Manager (Refer to CHAPTER 6  WINDOW REFERENCE), a mark indicating the type of each event
condition, and an icon indicating an event name specified for registration are displayed.

(5) Setting each event condition
The event conditions shown in Table 4-1 are created in each setting dialog box.  Each event condition is created
by dragging the event condition registered in the Event Manager, or the icon of an event link condition, to the
condition item in each setting dialog box.

A created event condition is “set” by clicking the function button  Set  or  OK  in the setting dialog box, or by

clicking the mark of the event icon in the Event Manager and display it in red.  By setting a created event
condition, a debug action occurs as an event condition.
For all the event conditions it is possible to “register” up to 256 conditions, but the number of conditions that can
be “set” differs depending on each event condition.
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4.4  Break Functions

The break functions stop the execution of the user program and the operation of the tracer and timer by the

emulation CPU.

The following six types of break functions are available.

• Event detection break
• Break by Come function
• Software break
• Break on satisfaction of condition during step execution
• Forced break
• Fail-safe break

When the Come, Step In, Return Out, or Next Over command of the emulation execution functions is executed,

event detection break and detection of software break are not performed.

Each break function is explained below.

(1) Event detection break
An event detection break is a function to stop the execution of the user program by detecting a set break event
condition.  This function is used to stop a user program executed by the Go, Go & Go, and Restart commands.
When the Go & Go command has been executed, the contents of each window are updated and the user
program is then executed again after an event detection break has been implemented.  Set break events as
follows:

• Set a break event in the Source window or Assemble window as an execution event.
• Set a break event in the Break dialog box (refer to CHAPTER 6  WINDOW REFERENCE).

(2) Break by Come function
The break by Come function is a function to stop a user program executed by the Come command by detecting
an address specified in the Source window or Assemble window.  After user program execution has been
stopped, the breakpoint by Come function is eliminated.
While the user program is being executed using this function, the currently set break event does not occur.

(3) Software break
A software break is a function to stop a user program executed by the Go, Go & Go, or Restart command, by
detecting a specified address.
While event detection breaks use one hardware resource for one event condition, a software break can set a
breakpoint to two or more addresses.

(4) Break on satisfaction of condition during step execution
This is a function to stop the execution of the user program when the end condition of each command (Step In,
Next Over, Return Out, or Slowmotion) is satisfied.
Because one instruction at a time is executed, stopped, and condition checked, the processing time of this
function is slower than that of real-time execution.
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(5) Forced break
A forced break is a function to forcibly stop the execution of the user program.  This function is valid for all the
program execution commands.  A forced break is implemented by the following command.

• Stop command
Forcibly stops the execution of the user program.

(6) Fail-safe break
A fail-safe break is a function to forcibly stop the user program when there has been an execution prohibiting the
user program from accessing the memory and registers.
The following three types of fail-safe break functions are available.

(a) Non-map break
This break occurs if an attempt is made to access non-mapping area.

(b) Write-protect break
This break occurs if an attempt is made to write to memory that must not be written to, such as ROM.

(c) SFR illegal access break
This break occurs if an attempt is made to access an SFR illegally.

If a fail-safe break occurs, the chances are the user program has a problem or the set environment of the
ID78K0-NS or ID78K0S-NS is wrong.

Caution A non-map break may occur if the user program is written in the vicinity of the boundary
between the mapping area and non-mapping area. This non-map break occurs in the following
case.

[Maximum address value of mapping area −−−− 5] ≤≤≤≤ [Program address]
≤≤≤≤ [Maximum address value of mapping area]
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4.5  Trace Function

The trace function is to save the history of the data indicating the execution process of the user program in the

trace memory.  The trace data saved in the trace memory can be displayed on the Trace View window (refer to

CHAPTER 6  WINDOW REFERENCE).

The functions related to the trace operation and trace are explained below.

4.5.1  Operation of trace

The trace memory of the ID78K0-NS and ID78K0S-NS is a ring buffer with a capacity of 8,192 frames.  If a trace

exceeding 8,192 frames is executed, therefore, the newest trace data is overwritten to the oldest frame.

The operation of the tracer differs as follows depending on the execution mode of the user program.

(1) Operation during real-time execution
The operation of the tracer differs depending on the specified trace mode.

Trace Mode Operation of Tracer

All trace Starts trace when real-time execution of program is specified, and ends trace

when break occurs

Conditional trace Starts/ends trace when condition set on Trace dialog box is satisfied (if break

occurs before that, however, trace is immediately stopped)

(2) Operation during Step In execution
The tracer operates each time one step is executed, and the trace data of one step is consecutively added to
the trace memory.

(3) Operation during Next Over execution
The operation of the tracer is the same as in Step In execution.
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4.5.2  Trace condition setting function

The setting function of a trace condition is as follows.

(1) Setting of trace mode
The following two trace modes can be set.

Trace Mode Trace Contents

All trace Unconditionally traces all execution processes of user program (default)

Conditional trace Traces only specified zone

These trace modes are set by selecting [Run] from the main window (refer to CHAPTER 6  WINDOW
REFERENCE) followed by [Uncond. Trace ON]/[Cond. Trace ON].
To stop the tracer function, select [Run] from the main window, followed by [Tracer Stop] (this is valid only
when [Ignore Break Point] under [Run] in the main window has been checked).

(2) Setting trace event condition
A trace event condition is a condition under which trace execution is started/ended if the conditional trace is
selected as the trace mode.
The trace event condition can be set on the Trace dialog box (refer to CHAPTER 6  WINDOW
REFERENCE).  Up to 256 trace event conditions can be registered, of which only one can be set.
The following two modes can be selected for the conditional trace.

(a) Section trace
In this mode, trace is started when a specified trace start condition is satisfied, and ends when a
specified trace end condition is satisfied.  As a start/end condition, an event condition or event link
condition is used.

(b) Qualify trace

In this mode, trace is executed only when a specified address is executed or accessed.  An event

condition is used as the event trigger.
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4.5.3  Trace result display function

The result of a trace can be checked in the Trace View window (refer to CHAPTER 6  WINDOW REFERENCE).

The Trace View window displays each frame of the trace contents of the following items shown in Table 4-4.

Table 4-4.  Trace Data Display Contents

Displayed Item Contents

Frame Frame number of trace memory indicating time sequence

Time Execution time of each frame

Address Fetch address

Data Fetch data

Status Fetch status

Address Access address

Data Access data

Status Access status

Ext Probe Input data of external sense clip

DisAsm Disassemble result

Displayed Item and Contents can be selected by opening the Trace Data Select dialog box under [View] →
[Select…] in the main window.
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4.6  Coverage Measurement Function

The coverage measurement function is for registering a status for each address when the user program is

executed.  The ID78K0-NS and ID78K0S-NS have a coverage memory of 64 KB and can measure any 64 KB space.

Coverage measurement can be performed by selecting [Option] → [Coverage ON] in the main window, and the

measurements are recorded in the coverage memory when a program is executed.

The result of coverage can be checked in the Coverage window.  The coverage efficiency can be displayed in the

Coverage-Efficiency View dialog box.

4.7  Snapshot Function

The snapshot function is used to preserve the contents of register memory in the course of user program

execution and the contents of the SFRs in the trace memory as snap data.

A trigger that executes this snapshot is specified by a snap event condition.  The snap event condition is set in the

Snap Shot dialog box.  When the snap event condition set in this dialog box is satisfied, the following data can be

collected as snap data.

• Register values (program registers and system registers)
• SFR values
• Memory contents

One snap event condition can be specified to collect snap data up to 16 times.
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4.8  Load/Save Functions

The load/save functions are for loading load modules and symbol information, and loading/saving data and

debugging environments.

The ID78K0-NS (ID78K0S-NS) individually loads/saves each file.  The following two types of files are

loaded/saved.

• Display files: Files recording the screen information when they are saved.  By loading these files, the
reference file is opened in the Source window.

• Information files: Files recording various set data and debugging environments as the internal information of
the ID78K0-NS or ID78K0S-NS.

4.8.1  Display files

Table 4-5 lists the display files handled by the ID78K0-NS and ID78K0S-NS.

Table 4-5.  Display Files Handled by ID78K0-NS and ID78K0S-NS

File Name (Extension) Outline Operation Window

Variable display file (.WCH) Shows variable information in Watch window

Assemble display file (.DIS) Shows assemble information in Assemble window

Memory display file (.MEM) Shows memory information in Memory window

Register display file (.REG) Shows register information in Register window

Stack trace display file (.STK) Shows stack trace information in Stack window

SFR display file (.SFR) Shows SFR information in SFR window

Local variable display file (.LOC) Shows local variable information in Local Variable
window

Trace display file (.TVW) Shows trace information in Trace View window

Coverage display file (.COV) Shows coverage information in Coverage window

Source display file (.SVW) Shows text information in Source window

View File Load dialog box,
View File Save dialog box

4.8.2  Information files

Table 4-6 lists the information files handled by the ID78K0-NS and ID78K0S-NS.

Table 4-6.  Information Files Handled by ID78K0-NS and ID78K0S-NS

File Name (Extension) Outline Operation Window

Object file (.HEX) Stores object code of user program Download dialog box
Upload dialog box

Load module file (.LNK, .LMF, .D2B) Stores object code of user program, symbol, and
source information

Download dialog box

Project file (.PRJ) Stores debugging environment Project File Load dialog box
Project File Save dialog box

Binary file (.BIN) Stores data of binary format Download dialog box
Upload dialog box

Event set file (.EVN) Stores event set information of Event Manager View File Load dialog box
View File Save dialog box

Coverage result file (.CVB) Stores coverage result Download dialog box
Upload dialog box

The project file sets window/dialog box display information, size, and display area when it is loaded to restore the

previous debugging environment (the status when the project file was saved).
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4.9  Register Manipulation Functions

The register manipulation functions are for displaying or changing the contents of the 78K/0 Series and 78K/0S

Series microprocessors’ program registers (PC and rp0 through rp3), system registers (SP and PSW), and SFRs.

These functions can be used in the Register window or SFR window (refer to CHAPTER 6  WINDOW REFERENCE).

4.10  Memory Manipulation Functions

The memory manipulation functions are for displaying or changing the contents of the memory by using

mnemonic, hexadecimal, and ASCII codes.  These functions can be used in the Memory window or Assemble

window (refer to CHAPTER 6  WINDOW REFERENCE).

4.11  Time Measurement Function

The time measurement function is for measuring the total execution time from the start of execution of the user

program to the end, and the execution time in a certain zone of the user program by using timer event.  This function

can be used in the Timer dialog box (refer to CHAPTER 6  WINDOW REFERENCE).

Caution The number of usable timers is 1.

4.12  Real-Time RAM Sampling Function

The real-time RAM sampling function reads the memory contents in real time and updates the displayed contents

when a variable allocated to any 1 KB in internal RAM area, whose contents can be read even during execution of

the user program, is displayed (Variable window) or the memory contents are displayed (Memory window).

The sampling time for real-time RAM sampling can be set in units of 1 ms in the Extended Option dialog box (refer

to CHAPTER 6  WINDOW REFERENCE).
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CHAPTER  5    ASSOCIATION  WITH  PROJECT  MANAGER

This chapter explains the procedure and notes on using the functions associated with the Project Manager (PM

hereafter).  The ID78K0-NS and ID78K0S-NS can automatically perform a sequence of tasks such as creating a

program, compiling, debugging, and correcting the program, in association with the PM.

To debug a load module file created in the PM at the source level, confirm that the item [Option] → [Debug] is

checked for building.

Caution When a load module file is created by using an MS-DOS TM prompt, the functions of the ID78K0-

NS (ID78K0S-NS) associated with the PM cannot be used.

5.1  Debugger Registration in PM Project

Either of the debuggers for ID78K0-NS/SM78K0 (ID78K0S-NS/SM78K0S) can be specified for each project in the

PM.

The selection procedure is explained below.

5.1.1  Debugger selection

The procedure for selecting the debugger is as follows.

<1> Select [Project] → [New] in the PM to create a new project for the PM.  Alternatively, read an existing PM

project by selecting [Project] → [Open…].

→ For details of the setting items, refer to the PM online help or user’s manual.

<2> Select [Option] → [Select Debugger…] from the PM menu bar.

→ This opens the Select Debugger Type dialog box.  Figure 5-1 shows the Select Debugger Type dialog

box.

Figure 5-1.  Select Debugger Type Dialog Box (PM)



CHAPTER  5    ASSOCIATION  WITH  PROJECT  MANAGER

User’s Manual  U14910EJ1V0UM0054

<3> Either click “78K/0 System Debugger” (“78K/0S System Debugger” for the ID78K0S-NS) by mouse from the

debugger list, or specify the execution file name IDK032A.EXE (with path) (IDK0S32A.EXE (with path) for

the ID78K0S-NS) for the debugger file name.

<4> Click OK.

→ ID78K0-NS (ID78K0S-NS) will now be registered as the project debugger of the open PM.

The ID78K0-NS (ID78K0S-NS) icon will also be displayed on the PM toolbar.

5.2  Starting Up ID78K0-NS/ID78K0S-NS from PM

One of the following three methods can be used to start up the ID78K0-NS/ID78K0S-NS from the PM.

(1) Click the ID78K0-NS (ID78K0S-NS) startup button on the PM toolbar.

(2) Select [Build] →  [Debug] from the PM menu bar.

(3) Select [Build] → [Build and Debug] from the PM menu bar.  Alternatively, click the batch-processing button on

the PM toolbar (however, the ID78K0-NS (ID78K0S-NS) will start up only if Build has finished normally).

5.2.1  Reproducing debug environment

By following the procedure shown below, it is possible to reproduce the debug environment of the previous time the

ID78K0-NS (ID78K0S-NS) was started up from the PM.

<1> Create a new project fileNote with the PM (eg: aaa.prj)

Note Use the project file to save and reference the environment data for the debugger (ID78K0-NS and

ID78K0S-NS) and the PM.  The project file extension when dealing with the debugger and PM is prj.

Refer to the online help or user’s manual of each product regarding the data that is saved and

reproduced using a project file.

<2> Start up the ID78K0-NS (ID78K0S-NS) from the PM.  Because the project file is new, set items other than

the device classification in the Configuration dialog box, in the same way as when starting up the ID78K0-

NS (ID78K0S-NS) individually.

<3> Debug the target device with the ID78K0-NS (ID78K0S-NS).

<4> When the ID78K0-NS (ID78K0S-NS) has finished debugging, check [Save project file] in the Exit Debugger

dialog box and exit the ID78K0-NS (ID78K0S-NS).

→ The debug environment at the completion of ID78K0-NS (ID78K0S-NS) debugging is saved to the aaa.prj

file (the debug environment can also be saved to the aaa.prj file at times other than the completion of

ID78K0-NS (ID78K0S-NS) debugging).

<5> When the ID78K0-NS (ID78K0S-NS) is next started up after the aaa.prj file is read by the PM, the debug

environment saved in <4> above is automatically reproduced.

→ The project file currently being used by the PM (aaa.prj) is automatically read when the ID78K0-NS

(ID78K0S-NS) is started up.
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5.3  Correction and Auto Load of Source File

If a bug is found as a result of debugging using the ID78K0-NS (ID78K0S-NS), source file editing, compiling, and

re-downloading can be automatically executed using the following procedure while the ID78K0-NS (ID78K0S-NS)

remains activated.

Caution If [Option] →→→→ [Project Manager Options...] is selected in the PM, and if an editor other than the

standard editor is selected, this processing cannot be performed.

<1> Read the source file to be corrected with the ID78K0-NS (ID78K0S-NS) in the Source window.  With the

Source window displayed at the foremost position, select [File] →[Open…] on the main window to specify

the corresponding file (if the corresponding file has already been displayed in the Source window, activate

the window).

→ The corresponding file is displayed in the Source window.

<2> Select [Edit] → [Edit Source] in the ID78K0-NS (ID78K0S-NS) main window.

→ The corresponding source file is automatically read to the standard editor and opened.

<3> Correct the source file in the editor.

<4> Select [File] → [Save] in the editor and save the file.

<5> Select [File] → [Exit idea-L] in the editor to terminate the editor.

→ As a result, the PM automatically executes compiling, assembling, and linking in accordance with the

settings of the project.  When these operations have been completed normally, the created load module

file is automatically downloaded to the ID78K0-NS (ID78K0S-NS).

Cautions 1. When the load module file is automatically downloaded, CPU reset is not executed.

2. The debug window, which was opened when the editor was called, and all event

settings are restored.  However, if the previously used lines and symbols have been

deleted because of source file correction, an error message is displayed, and an event

using the deleted symbol cannot be used.
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[MEMO]
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CHAPTER  6    WINDOW  REFERENCE

This chapter explains in detail the functions of the windows and dialog boxes of the ID78K0-NS and ID78K0S-NS.

For the configuration and details of the types of the windows and dialog boxes, refer to APPENDIX B

TERMINOLOGY.

6.1  Window List

Table 6-1 lists the windows of the ID78K0-NS and ID78K0S-NS debuggers.

Table 6-1.  Windows of ID78K0-NS and ID78K0S-NS Debuggers (1/2)

Window Name Outline Page

Main window This window is displayed first when the debugger is started.

It controls execution of the user program.  In addition, various windows are opened

from this window.

p.60

Configuration dialog box Sets/displays the debugger environment p.86

Bank Set dialog box Sets the memory banks p.91

Mask Option dialog box Sets the mask options p.95

Extended Option dialog box Sets/displays each extended option p.97

Debugger Option dialog box Sets/displays each option p.101

Font dialog box Sets the type and size of the display font in the Source window p.109

Project File Load dialog box Reads debugging environment p.112

Project File Save dialog box Saves the debugging environment p.115

View File Load dialog box Reads the display files of each window and the source text and event setting files p.119

View File Save dialog box Saves the display files of the current window and the event setting files p.122

Download dialog box Downloads the object files, binary files, and coverage results p.128

Upload dialog box Saves the memory or coverage contents to a file p.132

Browse dialog box Selects the files to be set in the Debugger Option and Source Search dialog boxes p.135

Source Move dialog box Specifies the files to be displayed in the Source window and the display start

position

p.137

Address Move dialog box Specifies the display start address for the Memory, Assemble, and Coverage

windows

p.140

Trace Move dialog box Specifies the display start position for the Trace View window p.143

Symbol To Address dialog box Displays the addresses and symbol values of variables and functions p.146

Source window Displays source files and text files p.149

Source Search dialog box Searches a character string in a source file p.162

Assemble window Displays the disassemble text and executes on-line assemble p.165

Assemble Search dialog box Searches the contents of the Assemble window p.176

Memory window Displays/changes the memory contents p.179

Memory Search dialog box Searches the contents of the Memory window p.184

Memory Fill dialog box Initializes the memory contents by specified data p.187
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Table 6-1. Windows of ID78K0-NS and ID78K0S-NS Debuggers (2/2)

Window Name Outline Page

Memory Copy dialog box Copies the memory contents p.189

Memory Compare dialog box Compares the memory contents p.191

Memory Compare Result dialog
box

Displays the result of comparison of memory contents p.193

Watch window Displays/changes variables p.195

Quick Watch dialog box Displays/changes variable values temporarily p.200

Add Watch dialog box Registers variables to be displayed in the Watch window p.204

Register window Displays/changes register (program register, system register) contents p.207

SFR window Displays/changes contents of SFR p.211

SFR Select dialog box Selects SFRs and I/O ports to be displayed in the SFR window p.215

Add I/O Port dialog box Registers I/O ports to be displayed in the SFR window p.218

Local Variable window Displays/changes local variable in current function p.221

Stack window Displays/changes the stack contents of the current user program p.223

Trace View window Displays the trace results p.227

Trace Search dialog box Searches the trace data p.236

Trace Data Select dialog box Selects items to be displayed in the Trace View window p.244

Coverage window Displays the coverage results p.247

Coverage Search dialog box Searches the coverage results p.252

Coverage Clear dialog box Clears the coverage results p.256

Coverage-Condition Setting
dialog box

Sets the coverage efficiency of the measurement range p.258

Coverage-Efficiency View dialog
box

Displays the coverage results in terms of efficiency p.261

Event Manager Displays, switches enable/disable, or deletes each event p.264

Software Break Manager Displays, switches enable/disable, or deletes a software break p.273

Event dialog box Registers/displays an event condition p.276

Event Link dialog box Registers/displays an event link condition p.288

Break dialog box Registers/sets/displays a break event condition p.296

Trace dialog box Registers/sets/displays a trace event condition p.303

Snap Shot dialog box Registers/sets/displays a snap event condition p.313

Timer dialog box Displays the result of execution time measurement and registers/sets/displays
timer event conditions

p.327

Timer Result dialog box Displays the results of the executed measurement p.337

DMM dialog box Sets dynamic memory modification p.339

Pass Count dialog box Sets the pass count p.345

Delay Count dialog box Sets the delay count p.347

Reset Debugger dialog box Initializes the ID78K0-NS, ID78K0S-NS, and target CPU and symbol information p.349

About dialog box Displays the version of the ID78K0-NS, ID78K0S-NS p.351

Exit Debugger dialog box Terminates the ID78K0-NS, ID78K0S-NS p.352

Error/Warning dialog box Displays an error/warning message p.354
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6.2  Explanation of Windows

This section explains each window using the format shown below.

Window Name

The window name is indicated in this frame.

General

Briefly explains the window.

Opening method

Explains how to open the window.

Window

Shows the screen image of the window configuration.

Function

Explains each function of the window.

Function buttons

Explains the operations of the function buttons in the window.

Menu bar

Enumerates the menus pulled down from the menu bar, and explains the function of each menu.

Caution

Explains points of caution to be noted.
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Main Window

General

This window is automatically opened after the ID78K0-NS/ID78K0S-NS is started and initialization is complete.  It

remains displayed until the ID78K0-NS/ID78K0S-NS is terminated.  Various windows are opened and manipulated

from this window.  Execution of the user program is also controlled in this window.  Execution of the user program can

be controlled in three modes: source mode, instruction mode, and automatic mode.

• Source mode

Debugging is performed at the source level.

• Instruction mode

Debugging is performed at the instruction level.

• Automatic mode

Switches automatically between the source mode and instruction mode.

This window is in the source mode (other than mixed display mode) or the instruction mode when the Source

window is active and in the instruction mode when the Assemble window is active.  When neither window is

active, this window is in the source mode.

When starting the ID78K0-NS/ID78K0S-NS, the automatic mode is assumed.

Window

Figure 6-1.  Main Window

(1) Toolbar

(2) Window display area

(3) Status display area
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Function

The main window consists of the following areas.

• Menu bar

• Toolbar

• Window display area

• Status display area

The function of each area is explained below.

(1) Toolbar

The toolbar consists of buttons that can execute frequently used commands with a single click.  Each button

is graphically displayed and easy to understand.  This button group can be switched between “Graphics-only

buttons” and “Graphics + Text buttons” by the Debugger Option dialog box.  The function of each button can

also be executed using the menu bar in this window.  This toolbar is not shown when it is specified not to be

displayed by selecting [Option] → [Tool Bar] from the menu bar of this window.

Figure 6-2.  Toolbar

Graphics-only toolbar

An explanation of each button is given below.

This button stops execution of the user program.

The same function as [Run] → [Stop] on the menu bar.

This button runs the user program after the emulation CPU is reset.

The same function as [Run] → [Restart] on the menu bar.

This button runs the user program without resetting the emulation CPU.

The same function as [Run] → [Go] on the menu bar.

This button executes the program in real-time until execution returns to the calling function.

The same function as [Run] → [Return Out] on the menu bar.

This button is used for step execution.

By clicking this button successively, the program is executed by as many steps as the number

of times this button is clicked.  Step execution is performed in line units in the source mode,

and in instruction units in the instruction mode.

The same function as [Run] → [Step In] on the menu bar.

Graphics + text toolbar
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This button executes the next step (i.e. executes the program, regarding the function/call

statement as one step.).

By clicking this button successively, next step execution is performed as many times as the

number of times this button is clicked.  Next step execution is performed in line units in the

source mode, and in instruction units in the instruction mode.

The same function as [Run] → [Next Over] on the menu bar.

This button resets the emulation CPU.

The same function as [Run] → [CPU Reset] on the menu bar.

This button opens the View File Load dialog box.

The same function as [File] → [Open…] on the menu bar.

This button opens the Download dialog box.

The same function as [File] → [Download…] on the menu bar.

This button opens the Project File Load dialog box.

The same function as [File] → [Project] → [Open…] on the menu bar.

This button opens the Source window and displays the contents of the source text.

The same function as [Browse] → [Source Text] on the menu bar.

This button opens the Assemble window, where the user program is disassembled and

displayed.

The same function as [Browse] → [Assemble] on the menu bar.

This button opens the Memory window and displays the memory contents.

The same function as [Browse] → [Memory] on the menu bar.

This button opens the Watch window and displays the watch contents.

The same function as [Browse] → [Watch] on the menu bar.

This button opens the Register window and displays the contents of the registers.

The same function as [Browse] → [Register] on the menu bar.

This button opens the SFR window and displays the contents of the SFRs.

The same function as [Browse] → [SFR] on the menu bar.

This button opens the Local Variable window and displays the local variable contents.

The same function as [Browse] → [Local Variable] on the menu bar.

This button opens the Stack window and displays the contents of the stack.

The same function as [Browse] → [Stack Trace] on the menu bar.
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This button opens the Trace View window and displays the result of a trace.

The same function as [Browse] → [Trace] on the menu bar.

This button opens the Coverage window and displays the coverage measurement resultsNote.

The same function as [Browse] → [Coverage] on the menu bar.

This button opens the Event Manager.

The same function as [Event] → [Event Manager] on the menu bar.

This button opens the Event dialog box and registers or sets events.

The same function as [Event] → [Event...] on the menu bar.

This button opens the Break dialog box and registers, sets, or displays break events.

The same function as [Event] → [Break…] on the menu bar.

This button opens the Trace dialog box and registers, sets, or displays trace events.

The same function as [Event] → [Trace…] on the menu bar.

This button opens the Timer dialog box, registers, sets, or displays timer events, and displays

the result of timer measurement.

The same function as [Event] → [Timer…] on the menu bar.

Note   Valid only when the performance board is mounted.

(a) Tool hint function

If the mouse cursor is pointed at any of the buttons on the toolbar, a tool hint pops up after a few

seconds.

Figure 6-3.  Example of Tool Hint

(b) Moving the toolbar

By dragging toolbar with the mouse, it can be moved to any desired position within or outside the main

window.
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(2) Window display area

This area displays various debug windows.

The displayed window can be changed in size or registered as an icon in this area.  The list of the windows

displayed in this area is as follows.

•  Source window •  Local variable window

•  Assemble window •  Stack window

•  Watch window •  Trace View window

•  Memory window •  Coverage window

•  Register window •  Event Manager

•  SFR window

(3) Status display area

Figure 6-4.  Status Bar

This area displays the status of the debugger and in-circuit emulator.

<1> Program name  $ Source name # Line No.

Program name: Displays the program file name indicated by the PC value.

Source name: Displays the source file name indicated by the PC value.

Line No.: Displays the line number indicated by the PC value.

<2> Function name: Displays the function name indicated by the PC value.

<3> PC value: Displays the current PC value.

<4> CPU status: Displays the status of the CPU (target device) (not displayed in the ID78K0-NS).

<5> IE status: Displays the status of the in-circuit emulator (RUN, BREAK mode).

Displays the character “|” as a delimiter if there are multiple states.

<6> Break cause: Displays the cause of the break.

<7> STEP mode: Displays the step execution mode.

<8> Key input mode: Displays the key input mode.

<1> <2> <3> <4> <5> <6> <7> <8>
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The types of IE and CPU statuses are shown below.

Table 6-2.  IE Status Display Contents

Status Indication Meaning

RUN Currently running a user program.

STEP Currently executing a step.

TRC Currently operating a trace.

TIM Currently operating a timer.

COV Currently operating coverage.

BREAK Break

Table 6-3.  CPU Status Display Contents

Status Indication Meaning

STANDBY In standby mode

H-STOP In hardware stop mode

POW OFF Power is not supplied to the target system

The causes of a break are as follows.

Table 6-4.  Display Contents of Break Cause

Displayed Cause Meaning

Manual Break Forcible break

Temporary Break Temporary break

Event Break Break by event

Software Break Break by software break event

Non Map Break Access in non-map area

Write Protect Write access to write-protected area

SFR Illegal Illegal access to SFR

Stack Overflow Break by stack overflow

The types of STEP modes are shown below.

Table 6-5.  STEP Modes

STEP Mode Meaning

SRC STEP execution is in the source mode.  This is displayed
when [Option] → [Source Mode] in the menu bar is selected.

INST STEP execution is in the instruction mode.  This is displayed
when [Option] → [Instruction Mode] in the menu bar is
selected.

AUTO STEP execution is in the automatic mode.  This is displayed
when [Option] → [Auto Mode] on the menu bar is selected.

The types of key input modes are shown below.
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Table 6-6.  Key Input Modes

Key Input Mode Meaning

INS Displayed when key input is in the insert mode.

OVR Displayed when key input is in the overwrite mode.

(a) Menu explanation display function

While selecting a menu item on the menu bar with the mouse, a simple explanation of the highlighted

item in the menu is displayed on the left end of the status bar.  Also, when the mouse cursor is pointed at

any of the buttons on the toolbar, a menu explanation corresponding to that button is displayed.

Figure 6-5.  Example of Menu Explanation Display
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Menu bar

(1) File

Figure 6-6.  File Menu Bar

[Open…] This loads the display file or a source file or text file.

Opens the View File Load dialog box.

Operation differs depending on the file type selected in the dialog box.

When it is a source file in which symbol information is read:

Files are displayed in the Source window.

When it is an event setting file (.EVN):

The Event Manager is opened and the

event is set.

When it is a source file in which symbol information is not read, or a display file:

Files are displayed in the Source window

as text format files.

[Save As…] Saves the displayed contents of the current window in a file under another

name.

Opens the View File Save dialog box.

[Close] Closes the current window.

[Download…] Downloads the program.

Opens the Download dialog box.

[Upload…] Uploads the program.

Opens the Upload dialog box.
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[Project >] Operates a project file.

[Open…] Opens a project file.

Opens the Project File Load dialog box.

[Save] Overwrites the current status to the project file.

The file to be overwritten is the project file that is currently being read in the

debugger.

[Save As…] Saves the current status in a project file.

Opens the Project File Save dialog box.

[Debugger Reset…] Resets the target CPU, symbols, and debugger.

Opens the Reset Debugger dialog box.

[Exit] Terminates the debugger.  Opens the Exit Debugger dialog box.

[Open File] Displays a list of the downloaded files.

If a file name is selected, that file is downloaded again.

(2) Edit

Figure 6-7.  Edit Menu Bar

[Cut] Cuts the selected character string and places it in the clipboard buffer.

[Copy] Copies the selected character string to the clipboard buffer.

[Paste] Pastes the contents of the clipboard buffer at the text cursor position.

[Write in] Writes corrections to the target.

[Restore] Cancels the correction.

[Memory >] Manipulates the memory contents.

[Fill...] Initializes the memory contents.

Opens the Memory Fill dialog box.
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[Copy...] Copies values from memory to memory.

Opens the Memory Copy dialog box.

[Compare...] Compares values between memories.

Opens the Memory Compare dialog box.

[Edit Source] When the Project Manager is operating, opens the source file displayed in an

active Source window by using the editor specified by the Project Manager.
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(3) View

The display menu consists of a common part, in which the menu items are common to all windows and a

dependent part, in which the menu items differ according to the active window.

An explanation of each dependent part is given in (b) to (k).

Figure 6-8.  View Menu Bar

Note   The Coverage window is valid only when the IE-78K0-NS-PA is installed in the IE-78K0-NS or the IE-78K0-NS-

A/IE-78K0S-NS-A is used.

Note

Note
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(a) Common part

[Search…] Performs a search.  Opens the search dialog box according to the current

window.  Performs the same operation as the  Search  button.

[Move…] Moves the display position.  Opens the Source Move dialog box, Address

Move dialog box or Trace Move dialog box corresponding to the current

window.

[Quick Watch…] Displays the contents of the specified data temporarily.  Opens the Quick

Watch dialog box.

[Add Watch…] Adds the specified data to the Watch window.  Opens the Add Watch dialog

box.

[View Watch] Adds the selected data to the Watch window.  In the case of a symbol, it adds

it in accordance with the settings in the Debugger Option dialog box.

[Delete Watch] Deletes the selected watch point from the Watch window.  This menu is active

only when variables are specified in the Watch window.

[Symbol…] Displays the address of the specified variable or function and the value of the

specified symbol.  Opens the Symbol To Address dialog box.

(b) Source window dependent part

[Event?] Displays the cursor position line or the address’s event information.  If an event

is set, it opens the Event dialog box.

[Mix] Switches between mixed display and no mixed display for the assemble

display.

No check mark (“ ”): No mixed display (default).

Check mark (“√”): Mixed display.

(c) Assemble window dependent part

[Event?] Displays event information for the cursor position address.  If an event is set, it

opens the Event dialog box.

(d) Memory window dependent part

[Bin] Displays the current window in binary.

[Oct] Displays the current window in octal.

[Dec] Displays the current window in decimal.

[Hex] Displays the current window in hexadecimal (default).
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[Nibble] Displays data in 4-bit units.

[Byte] Displays data in 8-bit units (default).

[Word] Displays data in 16-bit units.

[Double Word] Displays data in 32-bit units.

[Ascii] Turns ON/OFF display of ASCII characters.

No check mark (“ ”): Not displayed.

Check mark (“√”): Displayed (default).

(e) Watch window dependent part

[Bin] The selected item is displayed in binary.

[Oct] The selected item is displayed in octal.

[Dec] The selected item is displayed in decimal.

[Hex] The selected item is displayed in hexadecimal.

[String] The selected item is displayed as a character string.

[Proper] The selected item is displayed as the standard value for each variable.  In the

case of symbols, they are displayed in accordance with the settings in the

Debugger Option dialog box (default).

[Byte] The selected item is displayed in 8-bit units.

[Word] The selected item is displayed in 16-bit units.

[Double Word] The selected item is displayed in 32-bit units.

[Adaptive] The selected item is displayed as standard values for each variable.  In the

case of C language symbols, only this item is valid.  In the case of assembler

symbols, they are displayed in accordance with the settings in the Debugger

Option dialog box.

[Up] The selected data is moved 1 line up.

[Down] The selected data is moved 1 line down.

[Compulsion Read] The data in the SFRs, where reading is prohibited because the values will

change if they are read, the I/O ports added in the Add I/O Port dialog box, and

the I/O protected areas is subjected to compulsory reading.
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(f) Register window dependent part

[Bin] Displayed in binary.

[Oct] Displayed in octal.

[Dec] Displayed in decimal.

[Hex] Displayed in hexadecimal (default).

[Absolute Name] Displays register names as absolute names.

[Function Name] Displays register names as function names (default).

(g) SFR window dependent part

[Bin] Displayed in binary.

[Oct] Displayed in octal.

[Dec] Displayed in decimal.

[Hex] Displayed in hexadecimal (default).

[Sort By Name] Displayed in alphabetical order.

[Sort By Address] Displayed in address order (default).

[UnSort] Not sorted.

[Attribute] Selects whether to display or not to display the Attribute field.

No check mark (“ ”): Not displayed.

Check mark (“√”): Displayed (default).

[Pick Up] Only the SFR selected in the SFR Select dialog box is displayed.

No check mark (“ ”): All are displayed (default).

Check mark (“√”): The selected register only is displayed.

[Select…] Opens the SFR Select dialog box.

[Compulsion Read] The data in the SFRs, where reading is prohibited because the values will

change if they are read, the I/O ports added in the Add I/O Port dialog box, and

the I/O protected areas is subjected to compulsory reading.
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(h) Local Variable window dependent part, Stack window dependent part

[Bin] Displayed in binary.

[Oct] Displayed in octal.

[Dec] Displayed in decimal.

[Hex] Displayed in hexadecimal.

[String] Displayed as a character string.

[Proper] Displayed as the standard value for each variable (default).

(i) Trace View window dependent part

[Select…] Selects the content of the display.

Opens the Trace Data Select dialog box.

[Pick Up >] Performs pick up display settings.

[Off] Pick up display is not performed (default).

[Search] Picks up the frames which match the search conditions and displays them.

[Snap] Picks up snap frames and displays them.

[BRM1] Picks up the first M1 fetch frame after a program branch and displays it (BRM1

cannot be set in this version).

[Mix] Switches between mixed display or no mixed display of sources.

No check mark (“ ”): No mixed display (default).

Check mark (“√”): Mixed display.

[Window

Synchronize >]

This links together the Trace View window and Source window, Assemble

window, Memory window and Coverage window.

[Source Text] Selects whether the Source window will be linked or not linked.

No check mark (“ ”): Not linked (default).

Check mark (“√”): Linked.

[Assemble] Selects whether the Assemble window will be linked or not linked.

No check mark (“ ”): Not linked (default).

Check mark (“√”): Linked.

[Memory] Selects whether the Memory window will be linked or not linked.

No check mark (“ ”): Not linked (default).

Check mark (“√”): Linked.
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[Coverage] Note Selects whether the Coverage window will be linked or not linked.

No check mark (“ ”): Not linked (default).

Check mark (“√”): Linked.

(j) Coverage window dependent part Note

[1 Byte] Displays in 1-byte units (default).

[64 Bytes] Displays in 64-byte units (default).

(k) Event Manager dependent part

[Select All Event] Selects all the events entered in the Event Manager.

[Delete Event] Deletes the selected event.

[Sort By Name] Displays the icons sorted by event name.

[Sort By Kind] Displays the icons sorted by event kind.

[UnSort] Icons are not sorted (default).

[Detail] Displays details.

[Overview] Displays a list.

Note  The Coverage window is displayed only when the IE-78K0-NS-PA is installed in the IE-78K0-NS or the IE-

78K0-NS-A/IE-78K0S-NS-A is used.
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(4) Option

Figure 6-9.  Option Menu Bar

[Tool Bar] Selects whether the toolbar is displayed or not.

No check mark (“ ”): Not displayed.

Check mark (“√”): Displayed (default).

[Status Bar] Selects whether the status bar is displayed or not.

No check mark (“ ”): Not displayed.

Check mark (“√”): Displayed (default).

[Button] Selects whether the function buttons on each window are displayed or not.

No check mark (“ ”): Not displayed.

Check mark (“√”): Displayed (default).

[Source Mode] Performs step execution at the source level (line units).

[Instruction Mode] Performs step execution at the instruction level (instruction units).

[Auto Mode] Switches automatically between source level step execution and instruction

level step execution, and executes step execution (default).

When the Source window is active, source level step execution (except in the

mixed display mode) or instruction level step execution (in the mixed display

mode) is performed, and when the Assemble window is active, instruction level

step execution is performed.

When neither window is active, source level step execution is performed.

[Configuration…] Sets the environment.

Opens the Configuration dialog box.
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[Mask Option...] Specifies the mask option for the device and sets the mode of each pin.

Opens the Mask Option dialog box.

[Extended Option…] Sets the extended functions.

Opens the Extended Option dialog box.

[Debugger Option…] Sets the debugger.

Opens the Debugger Option dialog box.

[Add I/O Port…] Adds a user-defined I/O port.

Opens the Add I/O Port dialog box.

[Trace Clear] Note Clears the trace data.

Displays the Trace View window if it is active.

[Coverage >] Note Opens the coverage-measurement related dialog boxes.

[Clear…] Note Initializes the coverage measurement results.

Opens the Coverage-Clear dialog box.

[Condition…] Note Sets the coverage efficiency measurement conditions.

Opens the Coverage-Condition Setting dialog box.

[Efficiency…] Note Displays the coverage efficiency results.

Opens the Coverage-Efficiency View dialog box.

[Coverage ON] Note Selects whether coverage measurement is turned on or off.

During emulation, this setting cannot be changed.

No check mark (“ ”): Coverage measurement is not performed.

Check mark (“√”): Coverage measurement is performed (default).

[Timer ON] Note Selects whether the timer measurement is turned on or off.

During emulation, this setting cannot be changed.

No Check Mark (“ ”): Timer measurement is not performed.

Check Mark (“√”): Timer measurement is performed (default).

Note that Run-Break event timer measurement cannot be stopped.

Note   These functions are valid only when the IE-78K0-NS-PA is installed in the IE-78K0-NS or the IE-78K0-NS-

A/IE-78K0S-NS-A is used.
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(5) Run

Figure 6-10.  Run Menu Bar

[Restart] Executes the program after resetting the emulation CPU.

Performs the same operation as the  button.

[Stop] Forcibly stops execution of the program.  Performs the same operation as the

 button.

[Go] Executes the program without resetting the CPU.  Performs the same

operation as the  button.

[Return Out] Executes the program in real time until execution returns to the calling function.

Performs the same operation as the  button.

[Step In] Performs step execution.  Performs the same operation as the  button.  In

the source mode, the program is executed in line units, and in the instruction

mode, it is executed in instruction units.

[Next Over] Performs next step execution.  Performs the same operation as the 

button.  Executes the program, regarding a function or subroutine statement as

1 step.  In the source mode, the program is executed in line units, and in the

instruction mode, it is executed in instruction units.

[Start From Here] Executes the program from the cursor position of the Source window or

Assemble window.
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[Come Here] Executes the program until the cursor position of the Source window or

Assemble window.

[Go & Go] Continues execution of the program.  If a break occurs because a break

condition is satisfied, it updates the window and then executes the user

program again.  Performs the same operation as clicking the  button each

time a break occurs.

[Slowmotion] Continues step execution of the program.

After updating the window for each step execution, it performs step execution

again.

Performs the same operation as clocking the  button each time step

execution is performed.

[CPU Reset] Resets the emulation CPU.  Performs the same operation as the  button.

[Change PC] Sets the address at the cursor position of the Source window or Assemble

window to the PC.

[Break Point] Sets/cancels a breakpoint at the cursor position of the Source window or

Assemble window.

[Software Break Point] Sets/cancels a software breakpoint at the cursor position of the Source window

or Assemble window.

[Delete All Software Break] Cancels all software breakpoints that are set.

[Uncond. Trace ON] Validates the unconditional trace function.  Always traces while the user

program is being executed (default).

When the tracer is started, the trace mode cannot be changed.

[Cond. Trace ON] Validates the trace function.  Traces while the user program is being executed

according to a trace condition.

When the tracer is started, the trace mode cannot be changed.

[Coverage Start or

Coverage Stop] Note

When coverage measurement is stopped, this starts it.

When coverage measurement is being performed, this stops it.

The display definitions are as follows.

“Coverage Start”: Measurement is stopped.  If selected, measurement will be

started.

“Coverage Stop”: Measurement is in progress.  If selected, measurement will

be stopped.

If there is currently no emulation, and if coverage measurement is off (no  “√”

mark next to the [Option] → [Coverage ON] item), this item is invalid (it is

dimmed).

Coverage measurement starts operating immediately after coverage has been

turned on and emulation is started.

Note   This function is valid only when the IE-78K0-NS-PA is installed in the IE-78K0-NS or the IE-78K0-NS-A/IE-

78K0S-NS-A is used.
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[Timer Start or

Timer Stop]

When timer measurement is stopped, this starts it.

When timer measurement is being performed, this stops it.

The display definitions are as follows.

“Timer Start”: Measurement is stopped.  If selected, measurement will be

started.

“Timer Stop”: Measurement is in progress.  If selected, measurement will be

stopped.

If there is currently no emulation, and if timer events are not used (no  “√” mark

next to the [Ignore Break Point] → [Run] item), this item is invalid (it is

dimmed).

Timer measurement starts operating immediately after the timer has been

turned on and emulation is started.

[Tracer Start or

Tracer Stop]

When tracer measurement is stopped, this starts it.

When tracer measurement is being performed, this stops it.

The display definitions are as follows.

“Tracer Start”: Measurement is stopped.  If selected, measurement will be

started.

“Tracer Stop”: Measurement is in progress.  If selected, measurement will be

stopped.

If there is currently no emulation, and if breaks are ignored (no  “√” mark next

to the [Run] → [Ignore Break Point] item), this item is invalid (it is dimmed).

Tracer measurement starts operating immediately after the tracer has been

turned on and emulation is started.

[Ignore Break Point] This selects whether to make a breakpoint valid or invalid.  If it is made invalid,

the breakpoint does not cause a break to occur.

No check mark (“ ”): Valid (default)

Check mark (“√”): Invalid

During emulation, this setting cannot be switched.

(6) Event

Figure 6-11.  Event Menu Bar
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[Event Manager] Manages each type of event condition.

Opens the Event Manager.

Operates the same as the  button.

[Software Break

Manager] Note

Switches enable/disable and cancels software break.

Opens the Software Break Manager.

[Event…] Enters event conditions.

Opens the Event dialog box.

Operates the same as the  button.

[Event Link…] Enters event link conditions.

Opens the Event Link dialog box.

[Break…] Enters and sets break conditions.

Opens the Break dialog box.

Operates the same as the  button.

[Trace…] Enters and sets trace event conditions.

Opens the Trace dialog box.

Operates the same as the  button.

[Snap Shot…] Enters and sets snap event conditions.

Opens the Snap Shot dialog box.

[Timer…] Enters and sets timer event conditions and displays the measurement results.

Opens the Timer dialog box.

Operates the same as the  button.

[DMM...] Note Opens the DMM dialog box.

[Pass Count...] Sets the pass count and displays the pass count value.

Opens the Pass Count dialog box.

[Delay Count...] Sets the delay count and displays the delay count value.

Opens the Delay Count dialog box.

Note   These functions are valid only when the IE-78K0-NS-PA is installed in the IE-78K0-NS or the IE-78K0-NS-

A/IE-78K0S-NS-A is used.
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(7) Browse

Figure 6-12.  Browse Menu Bar

[Source Text] Displays the source text.  Opens the Source window.  Performs the same

operation as the  button.

If a window exists that is already in the active state, it opens the window in the

static state.

[Assemble] Disassembles and displays the user program.  Opens the Assemble window.

Performs the same operation as the  button.

If a window exists that is already in the active state, it opens the window in the

static state.

[Memory] Displays the memory contents.  Opens the Memory window.  Performs the

same operation as the  button.

If a window exists that is already in the active state, it opens the window in the

static state.

[Watch] Displays the watch contents (variable and other data).  Opens the Watch

window.  Performs the same operation as the  button.

[Register] Displays the register contents.  Opens the Register window.  Performs the

same operation as the  button.

[SFR] Displays the contents of the SFRs.  Opens the SFR window.  Performs the

same operation as the  button.

[Local Variable] Displays the local variable.  Opens the Local Variable window.  Performs the

same operation as the  button.

[Stack Trace] Displays the stack contents.  Opens the Stack window.  Performs the same

operation as the  button.
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[Trace] Displays the result of a trace.  Opens the Trace View window.  Performs the

same operation as the  button.

[Coverage] Note Displays the result of coverage measurement.  Opens the Coverage window.

Performs the same operation as the  button.

If a window exists that is already in the active state, it opens the window in the

static state.

Note   This function is valid only when the IE-78K0-NS-PA is installed in the IE-78K0-NS or the IE-78K0-NS-A/IE-

78K0S-NS-A is used.

(8) Jump

Figure 6-13.  Jump Menu Bar

[SourceText] Sets the data selected in the current window as the jump address, and displays

the source text and source line starting from that address. No jump can be

performed if the jump address contains no line information.  Opens the Source

window.

If the Source window is being displayed in the active state, that window is

displayed on the front plane (operation object).

[Assemble] Sets the data selected in the current window as the jump address, and displays

the disassembled text starting from that address. Opens the Assemble window.

If the Assemble window is being displayed in the active state, that window is

displayed on the front plane (operation object).

[Memory] Sets the data selected in the current window as the jump address, and displays

the memory contents starting from that address. Opens the Memory window.

If the Memory window is being displayed in the active state, that window is

displayed on the front plane (operation object).

[Coverage] Note Sets the data selected in the current window as the jump address, and displays

the coverage measurement results from that window.  Opens the Coverage

window.

If the Coverage window is being displayed in the active state, that window is

displayed on the front plane (operation object).

Note   This function is valid only when the IE-78K0-NS-PA is installed in the IE-78K0-NS or the IE-78K0-NS-A/IE-

78K0S-NS-A is used.
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(9) Window

Figure 6-14.  Window Menu Bar

[New Window] Opens a new window displaying the same contents as the current window.

This is valid only in cases where the current window is the Source window,

Assemble window, Memory window or Coverage window.

[Cascade] Cascades the windows in the main window.

[Tile] Tiles the windows in the main window.

[Arrange Icons] Rearranges the icons in the main window.

[Close All] Closes all the windows except the main window.

[Refresh] Updates the contents of the window with the latest data.

[Active] Switches the window to the active state.

If it is currently in the active state, a check mark is entered on the left of this item.

[Static] Switches the window to the static state.

If it is currently in the static state, a check mark is entered on the left of this item.

[Open window] Lists the opened windows.  The window with a check mark added at the side of

the number is the current window.  The window selected by selecting a window

name is displayed as the current window.
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(10) Help

Figure 6-15.  Help Menu Bar

[Help Topics] Displays the table of contents of the Help window.

[Main Window Help] Displays the help for the main window.

[Current Window Help] Displays the help for the current window.

[About…] Displays the version of the debugger.
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Configuration Dialog Box

General

Displays and sets the operating environment of the in-circuit emulator.

This dialog box is displayed automatically after the debugger is started.  To use the debugger, the operating

environment of the in-circuit emulator must be set first in this dialog box.

When a project file is read, however, it doesn’t need to be set.  The result of reading the project file is reflected in

the Configuration dialog box.

Opening method

This dialog box can be opened by one of the following methods.

• When the debugger is started

Automatically opened

• In the main window

Select [Option] → [Configuration…].

Press the  GRPH  +  O , and  C  keys in that order.

Window

Figure 6-16.  Configuration Dialog Box

(1) Emulation CPU
select area

(2) Internal ROM/RAM
setting area

(3) CPU clock source
select area (6) Mask setting area

(4) Power supply
select area

(5) Break mode
select area

(7) Mapping setting
area
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Function

The Configuration dialog box consists of the following areas.

• Emulation CPU select area

• Internal ROM/RAM setting area

• CPU clock source select area

• Power supply select area

• Break mode select area

• Mask setting area

• Mapping setting area

The function of each area is explained below.

(1) Emulation CPU select area

This area selects an emulation CPU.  Note that this area can be selected only when the ID78K0-NS

(ID78K0S-NS) is started.  A chip name can be specified by inputting a name using the keyboard or selecting

one from the Name drop-down list.

(2) Internal ROM/RAM setting area

This area displays the size of the internal ROM and RAM of the emulation CPU.

The default size is automatically displayed followed by an asterisk (*) when the emulation CPU is selected.

To change the size of the internal ROM and RAM, select a size from the internal ROM and RAM drop-down

list.

If the selected size cannot be realized due to in-circuit emulator limitations, the debugger automatically

adjusts the size.

For that reason, when the Configuration dialog box is displayed again, the size being displayed may be

greater than the size specified the previous time.

Sizes that can be set are as follows.

Internal ROM Size Internal RAM SizeSize

Part Number
Alignment

(KB)
Set Range

(KB)
Alignment

(Bytes)
Set Range

(Bytes)

78K/0 Series (ID78K0-NS) 4 0 to 64

78K/0S Series

(ID78K0S-NS)

2 0 to 8,

12 to 64

64 64 to 1, 024
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(3) CPU clock source select area

This area selects the clock source to be input to the emulation CPU.

Select one of the following.

• Internal: The clock in the in-circuit emulator will be used as the CPU clock (default).

• External: The clock of the target device will be used as the CPU clock.

(4) Power supply select area

This area selects the power supply to be input to the emulation CPU.

Select one of the following.

• Internal: The power supply in the in-circuit emulator is used as the operating voltage (default).

The operation voltage is fixed to 5 V.

• Target: The power supply of the target is used as the operating voltage.  The operating voltage

can be changed within the range of the device's specifications.

(5) Break mode select area

This area selects the peripheral emulation operation of the in-circuit emulator during a break.

Select one of the following.

• Break: Stops the peripheral emulation function during a break.

• Non Break: Does not stop the peripheral emulation function during a break (default).
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(6) Mask setting area

This area specifies a mask for the signal sent from the target.

The signal of the masked pin cannot be input to the in-circuit emulator.

Mask pins only when the operation of the target is unstable at the debugging stage.

The RESET pin is the only pin for which a signal can be masked.

(7) Mapping setting area

This area specifies the mapping attribute and address, and sets mapping.

(a) Mapping attribute specification

The following types of mapping attributes can be selected.  Select a suitable attribute.

Note, however, that Emulation ROM, Emulation RAM, Target, and I/O Protect cannot be selected for

devices without external space and ID78K0S-NS.

Memory Attribute

• Emulation ROMNote: Selects an in-circuit emulator alternate ROM.

• Emulation RAMNote: Selects an in-circuit emulator alternate RAM.

• TargetNote: Selects a target memory.

• I/O ProtectNote: Selects an I/O protect area.

• Stack: Select a memory in the stack area.

Note Cannot be selected for the ID78K0S-NS.

The I/O Protect area can only be set inside the area set in the Target and the external SFR area.  The

area set as I/O Protect cannot be read unless it has been registered as an I/O port in the SFR window, or

registered in the Watch window.  If it is necessary to read this area, execute a forcible read in these

windows.

(b) Mapping address specification

Mapping Address: Specify the address to be mapped.

Input the mapping-start address and the mapping-end address from the keyboard.
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(c) Setting of memory mapping

• To add memory mapping

After specifying the Memory Attribute and Mapping Address, click the  button.

Memory mapping corresponding to the Memory Attribute and to the Memory Mapping address range

is added.

In ID78K0-NS, the mapping units for mapping attributes of other than Stack and I/O Protect are

adjusted when the  button is clicked.  If the mapping units do not match, the minimum

range subject to mapping that can be set, which includes the specified address, is used.

Stack area is set only in the internal RAM area (cannot be set in the internal expansion RAM area).

• To delete memory mapping

Select the mapping to be deleted from the displayed area, then click the  button.  The

currently selected mapping will be deleted.

Remark The mapping unit in the Stack and I/O Protect areas is bytes.

Function buttons

Validates the current environments.  Sets environments and closes the Configuration dialog

box.

If an error occurs when the  button is clicked, the debugger stops because it is

impossible to continue.

Cancels change and closes this dialog box.

This returns the environmental settings to the state they were in before the Configuration

dialog box was opened.

Opens the Project File Load dialog box.

If a project file is open or if an error occurs during reading, the debugger stops because it is

impossible to continue.

Opens the help window that explains the Configuration dialog box.
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Bank Set Dialog Box (ID78K0-NS only)

General

Sets the memory bank.

Note, however, that the memory bank does not need to be set when reading the project file.  The contents of the

project file read are reflected in the Bank Set dialog box.

Opening method

This dialog box can be opened by the following method.

• In the Extended Option dialog box

Turn on “Memory Bank” in the Memory Bank area, then click the   BANK Set   button.

Window

Figure 6-17.  Bank Set Dialog Box

(1) Bank access port setting area

(2) Bank address setting area

(3) Bank address display unit setting area

(4) External sense clip select area

(5) SFR setting area

(1)

(2)

(3)

(4)

(5)
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Function

The Bank Set dialog box consists of the following areas.

• Bank access port setting area

• Bank address setting area

• Bank address display unit setting area

• External sense clip select area

• SFR select area

The function of each area is explained below.

(1) Bank access port setting area

This area sets the port used to access the memory bank.

(2) Bank address setting area

This area sets the range within which the memory bank is switched.

(3) Bank address display unit setting area

This area sets display unit for the memory bank address.

(4) External sense clip select area

This area selects whether use the external sense clip for the memory bank or not.
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Setting Description

Debugger use The external sense clip is used by the debugger for event setting and

address creation during trace display for the memory bank area.

User use The user can freely set in this area. Note, however, that event setting and

trace display may be illegal for the memory bank.

When checking “Debugger use” to use the external sense clip, ports correspond to external sense clips as follows.

Bank Port Bit External Sense Clip No.

Bit 7 No. 8

Bit 6 No. 7

Bit 5 No. 6

Bit 4 No. 5

Bit 3 No. 4

Bit 2 No. 3

Bit 1 No. 2

Bit 0 No. 1

(5) SFR setting area

This area sets the access ports, memory expansion mode, and external bus type selection registers for

memory bank access.

The SFRs that need to be specified are shown below.

Setting Description Remarks

Pxx Specify the port used to access the

memory bank.

Specify in the access port setting area.

PMxx Specify when the port for memory bank

access is set as an output port.

This is set automatically by the

debugger.

MM Set the external expansion area and

number of waits.

–

EBTSO Set the external bus type. –
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Function buttons

Sets the specified memory bank and closes the Bank Set dialog box.

Closes the Bank Set dialog box.

Restores the input data.

Opens the help window.
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Mask Option Dialog Box

General

Sets the mask option.

Note, however, that the mask option does not need to be set when reading the project file.  The contents of the

project file read are reflected in the Mask Option dialog box.

Opening method

This dialog box can be opened by either of the following methods.

• In the main window

Select [Option] → [Mask option] from the menu bar.

Press the  GRPH  +  O , and  M  keys in that order.

Window

Figure 6-18.  Mask Option Dialog Box

Function

The Mask Option dialog box consists of the following areas.

• Pin group setting area

• Mask option setting area

(1) Pin group setting
area

(1) Mask option setting 
area
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The function of each area is explained below.

(1) Pin group setting area

This area sets the pin group.

(2) Mask option setting area

This area sets the mask option of the device and specifies the pin mode. When this dialog box is opened, the

setting option/specified pin mode is displayed at the top.

Function buttons

Sets the specified mask option/pin mode and closes the Mask Option dialog box.

Closes the Mask Option dialog box.

Set the specified mask option/pin mode.

Restores the input data.

Opens the help window.
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Extended Option Dialog Box

General

Displays and sets the various extended options of the debugger.

Opening method

This dialog box can be opened by either of the following methods.

• In the main window

Select [Option] → [Extended Option…] from the menu bar.

Press the  GRPH  +  O , and  E  keys in that order.

Window

Figure 6-19.  Extended Option Dialog Box

(1) Trace time tag counter division ratio select

areaNote 1

(2) Time tag total specification areaNote 1

(3) Real-time internal RAM sampling time

setting area

(4) Real-time internal RAM sampling range

setting areaNote 2

(5) Flash self mode setting areaNotes 1, 2

(6) Default break select area

(7) Beep sound specification area

(8) Memory bank setting areaNote 2

(5)

(4)

(3)

(2)

(1)

(6)

(7)

(8)
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Notes 1. This function is valid only when the IE-78K0-NS-PA is installed in the IE-78K0-NS or the IE-78K0-NS-

A/IE-78K0S-NS-A is used.

2. Valid only for the ID78K0-NS.

Function

The Extended Option dialog box consists of the following areas.

• Trace time tag counter division ratio select areaNote 1

• Time tag total specification areaNote 1

• Real-time internal RAM sampling time setting area

• Real-time internal RAM sampling range setting area (ID78K0-NS only)

• Flash self mode setting areaNote 2 (ID78K0-NS only)

• Default break select areaNote 3

• Beep sound specification area

• Memory bank setting area (ID78K0-NS only)

Notes 1. Valid only when the IE-78K0-NS-PA is installed in the IE-78K0-NS or the IE-78K0-NS-A/IE-78K0S-NS-

A is used.

2. Valid only for devices supporting flash self mode.

3. Valid only for product with new packages (IE-78K0-NS with a control code D or later or the IE-78K0-

NS-A/IE-78K0S-NS-A).

The function of each area is explained below.

(1) Trace time tag counter division ratio select area

This area sets the division ratio of the counter to be used as time tag display in Trace View window.

Select the division ratio from the drop-down list.  The following division ratios can be selected.

Numeric value on drop down list:  1 (default value) to 65,536

When a division ratio has been set, the number of clocks necessary for counting the counter displayed by

time tag is changed.

(2) Time tag total specification area

If this check box is checked, the trace data time tags will be totaled.

The default is an unchecked box, and therefore no totaling of time tags.
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(3) Real-time internal RAM sampling time setting area

This area specifies the sampling time (ms) of the real-time internal RAM sampling.

During emulation, the range specified in the real-time internal RAM sampling range setting area can be

sampled in real time.

Variables, data, etc. allocated to this range can be viewed in real time in the Watch window and the Memory

window.

Sampling time can be specified from 0 to 65500 in 100 ms units.

Real-time display is not performed if the sampling time is set at 0 or is left blank.

(4) Real-time internal RAM sampling range setting area (ID78K0-NS only)

This area specifies the range of the real-time internal RAM sampling.

Variables, data, etc. allocated to this range can be viewed in real time in the Watch window and the Memory

window.

The addresses can be specified in arbitrary 2 KB units.

(5) Flash self mode setting area (ID78K0-NS only)

This area sets the flash self mode.

The default setting for this area is "Off" (i.e. not flash self mode).

(6) Default break select area

Whether to make the breakpoint setting a software break or a hardware break can be selected by clicking the

mouse in the Source window or Assemble window.

• Soft Break: Sets a software break.

The breakpoint mark is displayed in blue.

• Hard Break: Sets a hardware break.

The breakpoint mark is displayed in red.
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(7) Beep sound specification area

This area specifies whether there will be a beep sound when there is a break.

If the check box is checked, a beep sound is emitted when there is a break (the default is with the beep

sound activated).

(8) Memory bank setting area (ID78K0-NS only)

This area sets the memory bank.

The default setting for this area is "Off" (i.e. memory bank function is not used).

If the   BANK Set   button is clicked, the Bank Set dialog box is displayed.

Function buttons

Makes the currently set environment active.

Sets the environment and closes the Extended Option dialog box.

Cancels the change contents and closes the Extended Option dialog box.

Returns to the environmental setting state that existed before the Extended Option dialog box

was opened.

Opens the help window that explains the Extended Option dialog box.
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Debugger Option Dialog Box

General

Displays and sets each type of extended option in the debugger.

Opening method

This dialog box can be opened by either of the following methods.

• In the main window

Select [Option] → [Debugger Option…] from the menu bar.

Press the  GRPH  +  O , and  D  keys in that order.

Window

Figure 6-20.  Debugger Option Dialog Box

(1) Source path specification area
(2) Default source specification area
(3) Default load module specification area

(4) Open file history setting area
(5) Display font setting area
(6) Project file setting area

(7) Toolbar display button setting area

(8) Kanji code setting area
(9) Tab size setting area
(10)Startup symbol setting area

(11)Offset display setting area
(12)Register name display select area
(13)Watch symbol setting area

(1)

(2)

(3)

(4)

(5)

(6)

(7)

(9)

(10)

(11)

(13)

(12)

(8)
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Function

The Debugger Option dialog box consists of the following areas.

• Source path specification area

• Default source specification area

• Default load module specification area

• Open file history setting area

• Tab size setting area

• Project file setting area

• Toolbar display button setting area

• Kanji code setting area

• Display font setting area

• Startup symbol setting area

• Offset display setting area

• Register name display select area

• Watch symbol setting area

The function of each area is explained below.

(1) Source path specification area

This area specifies the directory in which the source file or text files will be searched for.

The path is specified by inputting it from the keyboard or by using the  button.

When the  button is clicked, the Browse dialog box is displayed and the source path can be

added.

A relative path can also be specified.  The directory that is the reference for the relative path is displayed to

the right of “Base:”.  The reference directory is decided using the following procedure.

• The directory from which the project files were loaded.

• The directory from which the latest load module or hex file was loaded.

• Windows current directory.

Delimiters in path information are specified by “ ” (blank), “;” (semi-colon), or “,” (comma).

Japanese characters can be specified in the source path (Japanese version only).

Example If the source is located in the following directory,

b:\src

c:\asm

The source path specification becomes as follows.

b:\src;c:\asm
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(2) Default source specification area

When [File] → [Open...] is selected and the Browse dialog box is opened, the file extension of the displayed

source file is set in this area.

File extension delimiters are specified by “ ” (blank), “;” (semi-colon), or “,” (comma).

(3) Default load module specification area

This area sets the file extension of the load module displayed when the Download dialog box is opened.

File extension delimiters are specified by “ ” (blank), “;” (semi-colon), or “,” (comma).

(4) Open file history setting area

This area sets the number of items in the history displayed at the bottom of the [File] menu.

The number of items that can be set range from 0 to 10.

When 0 is set, the history is not displayed on the menu.

The default is 4.

(5) Display font setting area

This area specifies the display font in the Source window.  If the button is clicked, the Font dialog box opens

and the display font can be selected.



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14910EJ1V0UM00104

(6) Project file setting area

This area sets the project file auto save and auto load.

(a) Project file auto save

Selection can be made from among the following items.

Auto Save:

On: Performs project file auto save when closing.

Off: Does not perform project file auto save when closing.

Query: Displays the Exit Debugger dialog box when closing (default).

(b) Project file auto load

Selection can be made from among the following items.

Auto Load:

On: Performs project file auto load when starting.

Off: Does not perform project file auto load when starting (default).

(c) Auto load project file settings

Specifies the project file to be loaded during auto load.  This can be specified when “Auto Load” has

been turned “On.”  When it is turned “Off,” the specification column becomes inactive (dimmed).

Load Project File: Input the project file name from the keyboard or set it by clicking the 

button.

If the  button is clicked, the Browse dialog box is displayed.

(7) Toolbar display button setting area

This area sets the toolbar display buttons.

The display buttons can be selected from among the following items.

Pictures only: Displays buttons which show only graphics (default).

Pictures and Text: Displays buttons which show both graphics and text.
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(8) Kanji code setting area

This area specifies the kanji code of the files displayed in the Source window or Trace View window.

Kanji code can be selected from the following.

Sjis: SJIS is used for the kanji code (default).

Euc: EUC is used for the kanji code.

The kanji code is valid only for Japanese Windows.

(9) Tab size setting area

This area sets the tab size for each file extension when displaying files with that file extension.

(a) File extension setting

Set the file extension.

Extension: Setting of the file extension can be done by inputting it from the keyboard or by selecting

from the drop-down list.

(b) Tab size selection

The following tab sizes can be selected.

Tab Size:

2: Displays the tab code with 2 spaces.

4: Displays the tab code with 4 spaces.

8: Displays the tab code with 8 spaces.
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(c) Setting tab size for each file extension

Tab List:  Displays a list of the file extensions and tab sizes.

• If a tab size setting is added, and if a tab size is changed, set it by “Extension” and “Tab Size”, then

click the  button.

• To delete a tab size setting,

Select the file extension setting in the “Tab List,” then click the  button.

The currently selected file extension setting is deleted.

(10) Startup symbol setting area

This area specifies the beginning symbol (Begin label) and the end symbol (End label) of the startup routine.

If it is left blank, the Debugger Option dialog box cannot be closed.

The default is as follows.

Begin Label: _@cstart

End Label: _@cend

(11) Offset display setting area

This area sets whether there will be an offset display (symbol + offset) during disassemble display.

If there is no offset display, a symbol is displayed only when there is a symbol that matches the numerical

value, and when there is not a matching symbol, the numerical value is displayed as is in hex notation.

The areas where the offset display can be specified are of the following two types.

Label: Sets whether or not there will be an offset display in the label column.

The default is no offset display.

Mnemonic: Sets whether or not there will be offset display in the mnemonic column.

The default is offset display.
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(12) Register name display selection area

This area selects the display method of the register name in the mnemonic during disassemble display.

The display method can be selected from the following two methods.

Function Name: Displays the register name as a function name or alias (default).

Absolute Name: Displays the register name as an absolute name.

(13) Watch symbol setting area

This area specifies the watch symbol.

(a) Default size

Set the display size of data specified as “Adaptive” in the Watch window, etc.  The size displayed can be

selected from among the following items.

Size:

Byte: Displays data in 8 bits (default).

Word: Displays data in 16 bits.

Double Word: Displays data in 32 bits.

(b) Default radix

Set the display radix of data specified as “Proper” in the Watch window, etc.

The display radix can be selected from among the following items.

Radix:

Bin: Displayed in binary.

Oct: Displayed in octal.

Dec: Displayed in decimal.

Hex: Displayed in hexadecimal (default).

String: Displayed as a character string.
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(c) Variable type display on/off

Set the variable type display on/off.

Show Variable Type:

On: Displays variable types.

Off: Does not display variable types (default).

(d) Variable display format (ID78K0-NS only)

C: Displays in C language format.

ASM: Displays in assembly format.

Function buttons

After activating each type of option in the set debugger, the dialog box is closed.

Each of the options set in the debugger on this occasion are made inactive and

the dialog box is closed.

Returns to the environment setting state existing before the Debugger Option

dialog box was opened.

Opens the help window for the Debugger Option dialog box.
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Font Dialog Box

General

Selects the display font for the Source window and sets the font size.

Opening method

This dialog box can be opened by the following method.

• Click the  button in the Debugger Option dialog box.

Window

Figure 6-21.  Font Dialog Box

Function

The Font dialog box consists of the following areas.

• Font name specification area

• Font size specification area

• Sample display area

The function of each area is explained below.

(1) Font name
specification
area

(3) Sample display
area

(2) Font size
specification 
area
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(1) Font name specification area

This area selects the specified font from among the currently usable fonts.

Fixed-width fonts (fonts with a constant stroke width and fixed-pitch fonts) only are listed.

When the font name is selected from the list, the font name is displayed in the edit box and the font sizes with

which that font can be used are displayed in the font size specification area.

It is also possible to type the font name directly in the edit box using the keyboard.

(2) Font size specification area

The usable sizes of the font specified in the font name specification area are listed in point units in this area.

When selecting the font size from the list, the size is displayed in the edit box.

It is also possible to type the font size directly in the edit box using the keyboard.

(3) Sample display area

This area displays sample character string showing the specified font and font size.
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Function buttons

Changes the font in the Source window to the specified font face and font size and

closes the dialog box.

Closes the dialog box without changing the font.
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Project File Load Dialog Box

General

Restores previous debugging environments.

The size of the window and the position of the environments in the window are also restored following the project

file load.

Opening method

This dialog box can be opened by one of the following methods.

• In the main window

Select [File] → [Project…] → [Open Project…] from the menu bar.

Press the  GRPH  +  F ,  J , and  O  keys in that order.

• Click the  button on the toolbar.

Window

Figure 6-22.  Project File Load Dialog Box

(3)  File kind select area(2)  File name select area

(1)  File location select area
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Function

Loads project files.

This dialog box consists of the following areas.

• File location select area

• File name select area

• File kind select area

The function of each area is explained below.

(1) File location select area

This area selects the drive or directory.

(2) File name select area

This area specifies the file name.

The file name can be input from the keyboard or it can be selected from the list in the top column of the area.

(3) File kind select area

This area displays the kind of file displayed in the list.  Project (*.prj) files are displayed.

Loaded contents

The items from each window shown in the following table are loaded in the project file.  However, if the files are

loaded after the debugger is started, when a project file with a different target device is loaded, the debugger itself is

reset and the project file is loaded (when the target device differs from the target device specified when the debugger

was started, the target device becomes the target device specified in the project file).

(1/2)

Window Set Data

Configuration dialog box All items (target device, clock source selection, pin mask setting, mapping information)

Main window Display position, toolbar/status bar/button display information, execution mode information,

trace On/Off information, coverage On/Off information

Download dialog box File information to be downloaded

Extended Option dialog box Setting information

Debugger Option dialog box Setting information

Source window Display information of window, font information

Assemble window Display information of window, display start address

Memory window Display information of window, display start address

Stack window Display information of window

SFR window Display information of window

Local Variable window Display information of window

Trace View window Display information of window

Event dialog box Display information of window, event information
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(2/2)

Window Set Data

Event Link dialog box Display information of window, link event information

Break dialog box Display information of window, break event information

Trace dialog box Display information of window, trace event information

Snap Shot dialog box Display information of window, snap event information

Timer dialog box Display information of window, timer event information

Event Manager Display information of window, event information

Register window Display information of window

Watch window Display information of window, watch entry information

Coverage window Display information of window

DMM dialog box Setting information

Caution The substance of the ID78K0-NS or ID78K0S-NS project is stored in the XXXX.PRI file.

When specifying the XXXX.prj file, be sure to place the XXXX.PRI in the same directory.

Function buttons

Loads the selected file as the project file.

Closes the dialog box.

Closes this dialog box without loading the project file.

Opens the help window.
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Project File Save Dialog Box

General

A project file is a file that stores debugging environments.

When saving debugging environments in a project file, the size of the window and the position of the environments

in the window are also saved.

Opening method

This dialog box can be opened by either of the following methods.

• In the main window

Select [File] → [Project] → [Save As…] from the menu bar.

Press the  GRPH  +  F ,  J , and  A  keys in that order.

If a project file was loaded or saved previously, and to save a file of the same name, do as follows:

• In the main window

Select [File] → [Project] → [Save] from the menu bar.

Press the  GRPH  +  F ,  J , and  S  keys in that order.

In this way, a file of the same name as the previously loaded or saved project file can be saved without the Project

File Save dialog box being opened.
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Window

Figure 6-23.  Project File Save Dialog Box

Function

Saves a new project file or a project file whose name has been changed.

This dialog box consists of the following areas.

• Save location select area

• File name select area

• File kind select area

The function of each area is explained below.

(1) Save location select area

This area selects the drive or directory.

(2) File name select area

This area specifies the file name.

The file name can be input from the keyboard or it can be selected from the list in the top column of the area.

(3) File kind select area

This area displays the kind of file displayed in the list.  Project (*.prj) files are displayed.

(1) Save location select area (2) File name select area

(3) File kind select area
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Saved contents

The items from each window shown in the following table are saved in the project file.

Window Set Data

Configuration dialog box All items (target device, clock source selection, pin mask setting, mapping information)

Main window Display position, toolbar/status bar/button display information, execution mode information,

trace On/Off information, coverage On/Off information

Download dialog box File information to be downloaded

Extended Option dialog box Setting information

Debugger Option dialog box Setting information

Source window Display information of window, font information

Assemble window Display information of window, display start address

Memory window Display information of window, display start address

Stack window Display information of window

SFR window Display information of window

Local Variable window Display information of window

Trace View window Display information of window

Event dialog box Display information of window, event information

Event Link dialog box Display information of window, link event information

Break dialog box Display information of window, break event information

Trace dialog box Display information of window, trace event information

Snap Shot dialog box Display information of window, snap event information

Timer dialog box Display information of window, timer event information

Event Manager Display information of window, event information

Register window Display information of window

Watch window Display information of window, watch entry information

Coverage window Display information of window

DMM dialog box Setting information

Caution Although XXXX.prj is specified as the project, the substance of the ID78K0-NS or ID78K0S-NS

project is stored in the automatically created XXXX.prj file.  Use the same XXXX.prj as the

Project Manager.  Note that project files created using V.1.10 or earlier cannot be used.
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Function buttons

Saves the project information in the selected file.

After saving, closes the dialog box.

Closes this dialog box without saving the project file.

Opens the help window.
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View File Load Dialog Box

General

Reads display files, and also reads source files, other text files and event setting files, and opens a window.

Opening method

This dialog box can be opened by one of the following methods.

• In the main window

Select [File] → [Open] from the menu bar.

Press the  GRPH  +  F , and  O  keys in that order.

Press shortcut keys  CTRL  +  O .

• Click the  button on the toolbar.

Window

Figure 6-24.  View File Load Dialog Box

(1) File location select area

(2) File name select area (3) File kind select area
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Function

Reads display files, and also reads source files, other text files and event setting files, and opens a window.

Depending on the file loaded, the window opened and the status differ.

• Loading of a source file (files in which symbol information has been written)

If a Source window exists in the active state, it is opened in the static state. If there is no Source window in the

active state, a Source window in the active state is opened.

• Display file or some other text file

It is opened as a text format file in a Source window in the static state.

• Loading of an event setting file

The Event Manager is opened and the event setting contents are returned to the previous environment.

This dialog box consists of the following areas.

• File location select area

• File name select area

• File kind select area

The function of each area is explained below.

(1) File location select area

This area selects the drive or directory.

(2) File name select area

This area specifies the file name.  The file name can be input from the keyboard or it can be selected from the

list in the top column of the area.

(3) File kind select area

This area displays the kind of files displayed in the list.

Note that the kind of the file that used in the prior operation is displayed by default, so specify a suitable file

extension in this area.

The file kinds are as shown below.
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File Kind (File Extension) Meaning

Source (*.c; *.s; *.asm)Note Source file

Text (*.txt) Text file

Source Text (*.svw) Source window display file

Assemble (*.dis) Assemble window display file

Memory (*.mem) Memory window display file

Watch (*.wch) Watch window display file

Register (*.rgw) Register window display file

SFR (*.sfr) SFR window display file

Local Variable (*.loc) Local Variable window display file

Stack Trace (*.sth) Stack window display file

Trace (*.tvw) Trace View window display file

Coverage (*.cov) Coverage window display file

Event (*.evn) Event setting file

All (*.*) All files

Note The source file extension (c, s, asm) can be changed in the Debugger Option dialog box.

Remark If the conventional Variable window display file is used, it can be used as a Watch window display file

by changing the file extension from var to wch.

Function buttons

Loads the selected file.

Closes this dialog box without loading the display file.

Opens the help window.
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View File Save Dialog Box

General

Saves the contents of the current window when the dialog box was opened to a display file or event setting file.

Opening method

This dialog box can be opened by the following method.

• In the main window, make the window to be saved the current window and perform either of the following

operations.

• Select [File] → [Save As…] from the menu bar.

• Press the  GRPH  +  F , and  A  keys in that order.

Window

Figure 6-25.  View File Save Dialog Box (1/3)

No range (when saved window is Local Variable window,

Stack window, SFR window, Register window, Watch window, or Event Manager)

(1) Save location select area

(2) File name select area (3) File kind select area
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Figure 6-25.  View File Save Dialog Box (2/3)

Address range (when saved window is Assemble window, Memory window, or Coverage window)

Frame range (when saved window is Trace View window)

(4) Save range setting area

(4) Save range setting area
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Figure 6-25.  View File Save Dialog Box (3/3)

Line range (when saved window is Source window)

Function

Saves the contents of the current window in a display file.

This dialog box consists of the following areas.

• Save location select area

• File name select area

• File kind select area

• Save range setting area

The function of each area is explained below.

(1) Save location select area

This area selects the drive or directory.

(2) File name select area

This area specifies the file name.

The file name can be input from the keyboard or it can be selected from the list in the top column of the area.

(3) File kind select area

This area displays the kind of file displayed in the list.

(4) Save range setting area
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The file kinds are as shown below.

File Kind (File Extension) Current Window Name

Source Text (*.svm) Source window

Assemble (*.dis) Assemble window

Memory (*.mem) Memory window

Watch (*.wch) Watch window

Register (*.rgw) Register window

SFR (*.sfr) SFR window

Local Variable (*.loc) Local Variable window

Stack Trace (*.stk) Stack window

Trace (*.tvw) Trace View window

Coverage (*.cov) Coverage window

Event (*.evn) Event Manager

(4) Save range setting area

This area is displayed only when the current window to be saved is the Assemble window, Memory window,

Coverage window, Source window, or Trace View window.

All: Specifies that all the area from the first line to the last line be saved.

Screen shot: This specifies that the entire visible area from the top line to the bottom line of the screen

be saved.  However, in cases where there is a mixed display with the Source window, the

area saved is the from the source line included in the visible area of the screen.

Specify Line (in the case of the Source window),

Specify Frame (in the case of the Trace View window),

Specify Address (in the case of other windows):

Specify the starting line and end line of the area to be saved.  When the starting line and

end line are omitted, it is regarded as if the first line/last line were specified.  Details are

as shown below.
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(a) If current window is Assemble window, Memory window, or Coverage window

Specify an address range to be saved.  Addresses can also be specified by symbols or expressions.

(The specification method is the same as in the case of the Address Move dialog box.) The default radix

when numbers are input is hexadecimal.

If an area with 256 bytes or more is specified, a dialog box indicating the saving status is displayed.  To

stop saving midway, click the  button in this dialog box.

(b) If current window is Trace View window

Specify the range of trace frames to be saved.  (The specification method is the same as in the case of

the Trace Move dialog box.)  The default radix when numbers are input is decimal.

If a range of more than 100 frames is specified, a dialog box indicating the saving status is displayed.  To

stop saving midway, click the  button in this dialog box.
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(c) If current window is Source window

Specify the range by line numbers.  The default radix when numbers are input is decimal.

When the Source window is in the mixed display mode, the mixed display portion in the specified lines is

also saved.

If a range of more than 100 lines is specified, a dialog box indicating the saving status is displayed.  To

stop saving midway, click the  button in this dialog box.

Function buttons

Saves the contents of the current window to the selected file.

After that, closes the View File Save dialog box.

Closes the View File Save dialog box without saving.

Opens the help window.

Caution The Stack Trace window cannot save an area other than one currently displayed in the window.
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Download Dialog Box

General

Selects the name and format of a file to be downloaded, and downloads the contents of the target memory or the

results of coverage to the in-circuit emulator or target.

The files and file formats that can be downloaded are as follows.

• NEC load module format (XCOFF (.lnk, .lmf))

• Intel HEX format file (normal or extended)

• Motorola HEX format file S type (S0, S2, S3, S7, and S8)

• Extended Tektronix HEX format file

• Binary data format file

• Results of coverage

If a file other than an object file in the load module format is loaded, debugging cannot be executed at the source

level.

Network files must be used after being allocated to network drives.

Opening method

This dialog box can be opened by one of the following methods.

• In the main window

Select [File] → [Download…] from the menu bar.

Press the  GRPH  +  F , and  D  keys in that order.

• Click the  button on the toolbar.
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Window

Figure 6-26.  Download Dialog Box

Function

The Download dialog box consists of the following areas.

• File location select area

• File name select area

• File kind select area

• Offset setting area

• Load condition specification area

• Reset condition specification area

The function of each area is explained below.

(1) File location select area

This area selects the drive or directory.

(1) File location select area

(2) File name
select area

(3) File kind
select area

(5) Load condition specification area (6) Reset condition specification area (4) Offset setting area
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(2) File name select area

This area specifies the file name.  The file name can be input from the keyboard or it can be selected from the

list in the top column of the area.  Multiple files can be specified in this area.

When specifying multiple file names, place " (quotation marks) on both sides of each file name.  It is also

possible to specify multiple file names from the top column of the area while pressing the  SHIFT  key or the

CTRL  key.

(3) File kind select area

This area displays the kind of file displayed in the list.

The file kinds are as shown below.

File Kind (File Extension) Format

Load Module (*.lnk, *.lmf) Load module format

Hex Format (*.hex) Hex format (the format is auto-judged)

Binary Data (*.bin) Binary data format

Coverage (*.cvb) Coverage results

UBROF (*.d26) Load module format output by IAR's compiler

Remark The Hex format is judged automatically.

Note that these are the default file extensions; file extensions other than these can also be used.

(4) Offset setting area

This area specifies the offset address when loading the hex format, the binary data format, and the coverage

results.  Address specification can also be made by an expression (except symbols).  The specification

method is the same as in the case of the Address Move dialog box.  The default radix when inputting

numerical values is hexadecimal.  Offset values are disregarded for load module format files.

(5) Load condition specification area

This area sets the load conditions.

Symbol: Specifies whether the symbol information is read (checked, default) or not.  Note that this

condition is disregarded for files other than those in the load module format.

Object: Specifies whether the object information is read (checked, default) or not.
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(6) Reset condition specification area

This area sets the reset conditions.

Symbol: Reset the symbol information (always checked).

CPU: Specifies whether to reset the emulation CPU or not (checked, default).

Function buttons

Loads the selected file and closes dialog box.

Closes this dialog box without loading the file.

Opens the help window that explains the Download dialog box.

Returns the input data to its original form.



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14910EJ1V0UM00132

Upload Dialog Box

General

Selects the name and format of the file to be saved, and saves the contents of the target memory or results of

coverage in this file.

The following files and file formats can be saved.

• Intel HEX format file (extended only)

• Motorola HEX format file S type (S0, S2, and S8 only)

• Extended Tektronix HEX format file

• Binary data format file

• Results of coverage

Opening method

The dialog box can be opened by the following methods.

• In the main window

Select [File] → [Upload…] from the menu bar.

Press the  GRPH  +  F , and  U  keys in that order.

Window

Figure 6-27.  Upload Dialog Box

(1) File location select area

(2) File name
select area

(3) File kind select
area

(4) Save range setting area
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Function

The Upload dialog box consists of the following areas.

• File location select area

• File name select area

• File kind select area

• Save range setting area

The function of each area is explained below.

(1) File location select area

This area selects the drive or directory.

(2) File name select area

This area specifies the file name.  The file name can be input from the keyboard or it can be selected from the

list in the top column of the area.

(3) File kind select area

The file kinds are as shown below.

File Kind (File Extension) Format

Intel Hex (*.hex) Intel extended hex format

Motorola Hex (*.hex) Motorola hex format

Tektro Hex (*.hex) Extended Tektronics hex format

Binary Data (*.bin) Binary data format

Coverage (*.cvb) Coverage results

All (*.*) All files

These are the default file extensions; file extensions other than these can also be used.

The data format is decided by the file extension in which it is saved.  However, if “All (*.*)” is selected, the file

is saved in the default Intel extended hex format.

(4) Save range setting area

This area specifies the address range which is to be saved.  It is possible to specify the address by symbols

or by an expression.  The specification method is the same as in the case of the Address Move dialog box.

The default radix when numbers are input is hexadecimal.
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Function buttons

Saves the specified address range in the selected file and closes the dialog box.

Closes this dialog box without saving the file.

Opens the help window that explains the Upload dialog box.

Returns the input data to its original form.
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Browse Dialog Box

General

Selects the file set in the Debugger Option dialog box or Source Search dialog box.

Opening method

This dialog box can be opened by one of the following methods.

• Click the  button in the Debugger Option dialog box.

• Click the  button in the Source Search dialog box.

• Click the  button in the Source Move dialog box.

Window

Figure 6-28.  Browse Dialog Box

(1) File location select area

(2) File name
select area

(3) File kind select
area
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Function

The Browse dialog box consists of the following areas.

• File location select area

• File name select area

• File kind select area

The function of each area is explained below.

(1) File location select area

This area selects the drive or directory.

(2) File name select area

This area specifies the file name.  The file name can be input from the keyboard or it can be selected from the

list in the top column of the area.

(3) File kind select area

This area displays the kinds of files in the list.

The file kinds are as shown below.

File Kind (File Extension) Format

Source (*.c;, *.s; *.asm) Source file (The file extension is specified in the Debugger Option dialog box)

Text (*.txt) Text file

All (*.*) All files

Remark The source (c, s, asm) file extension can be changed in the Debugger Option dialog box.

Function buttons

Sets the selected file and closes the dialog box.

Closes this dialog box without setting the file.

Opens the Help window that explains the Browse dialog box.
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Source Move Dialog Box

General

Specifies the file displayed in the Source window and specifies the display start position.

Opening method

This dialog box can be opened by the following methods.

• When the Source window is active

Select [View] → [Move…] from the menu bar.

Press the  GRPH  +  V , and  V  keys in that order.

Press shortcut keys  CTRL  +  J .

Window

Figure 6-29.  Source Move Dialog Box

Function

This dialog box is displayed when [View] → [Move...] is selected while the Source window is open and can be used

to change the file’s display start position (a new window does not open).

The Source Move dialog box consists of the following areas.

• Input mode select area

• File/address specification area

The function of each area is explained below.

(1) Input mode select area

(2) File/address specification area
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(1) Input mode select area

This area selects the input mode in cases where the movement destination is specified.

{ Address/Symbol: Specifies the movement destination by an address (or a symbol).

{ Line/File: Specifies the movement destination by a line No. (or file name).

(2) File/address specification area

This area specifies the display file name or display address.  With the default, the string selected in the

accessed window, or when there is no selected string, the first character string in the input history, is

displayed, but as necessary, it can be changed by inputting from the keyboard.

The following two specification methods are used.

• Display address specification

• Display file name specification

By clicking the  button and displaying the input history, the contents input previously can be reused.  Up to

16 items of input history can be retained.

(a) Display address specification

Specify the address where the display starts.  It is possible to specify the address by symbols or by an

expression.

The specification method is the same as in the Address Move dialog box.  When “Address/Symbol” is

selected, the default radix when inputting numerical values becomes hexadecimal.

The source text is displayed so that the source line corresponding to the specified address value can be

seen.

(b) Display file name specification

Specify the name of the file to be displayed in the Source window.

For the file name, it is possible to specify the file name only and to specify the absolute path or the

relative path.

If the file name only, or the relative path, is specified, search is made for the file in each of the following

directories in the order shown.  The first file to be found as a result of the search is displayed.

• The directory which is the source path specified in the Debugger Option dialog box.

The line number can also be specified other than the file name.  The file’s line number is specified as

follows.
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• <<Path Name>File Name #> Line No.

The file name and line number are specified delimited by a “#”.  The line number is specified by a decimal

number.  The file name can be omitted.  When “Line/File” is selected, the default radix when inputting

numerical values is decimal.

The specified line number is made the header line, and the specified file is displayed.  If the file name is

omitted, the file is displayed from the specified line of the currently displayed file.

When the line number is omitted, the file is displayed from the header line.

Function buttons

Opens the Browse dialog box.

Displays the source text from the specified position.

Closes this dialog box.

Returns the input data to its original form.

Opens the help window.
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Address Move Dialog Box

General

Specifies a display start address in the Memory window, Assemble window, or Coverage window.

Opening method

This dialog box can be opened by one of the following methods.

(1) When Assemble window is displayed

• In the main window

Select [View] → [Move…] from the menu bar.

Press the  GRPH  +  V , and  V  keys in that order.

Press shortcut keys  CTRL  +  J .

(2) When Memory window is displayed

• In the main window

Select [View] → [Move…] from the menu bar.

Press the  GRPH  +  V , and  V  keys in that order.

Press shortcut keys  CTRL  +  J .

(3) When Coverage window is displayed

• In the main window

Select [View] → [Move…] from the menu bar.

Press the  GRPH  +  V , and  V  keys in that order.

Press shortcut keys  CTRL  +  J .

Window

Figure 6-30.  Address Move Dialog Box (1/2)

Address Move dialog box of Assemble window
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Figure 6-30.  Address Move Dialog Box (2/2)

Address Move dialog box of Memory window

Address Move dialog box of Coverage window

Function

The Address Move dialog box consists of the following area.

• Address specification area

The function of this area is explained below.

(1) Address specification area

This area specifies an address.  The default address is the string selected in the called window, or the value

of the current PC.  This value can be changed by keyboard input as necessary.  An address can also be

specified by a symbol or an expression.

The specification method is the same as in the case of the Symbol To Address dialog box, but the default

radix when inputting numerical values is hexadecimal.

By clicking the  button and displaying the input history, the contents input previously can be reused.  Up to

16 items of input history can be retained.



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14910EJ1V0UM00142

Function buttons

Displays the Memory window, Assemble window, or Coverage window from the specified address.

Closes this dialog box.

Returns the input data to its original form.

Opens the help window.
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Trace Move Dialog Box

Outline

Specifies the display start position in the Trace View window.

Opening Method

This dialog box can be opened by the following methods.

• When the Trace View window is active,

Select [View] → [Move...] from the menu bar.

Press the  GRPH  +  V , and  V  keys in that order.

Press shortcut keys  CTRL  +  J .

Window

Figure 6-31.  Trace Move Dialog Box

Function

This dialog box is displayed by selecting [View] → [Move...] when the Trace View window is open, and can be used

to change the trace results display starting position.

The Trace Move dialog box consists of the following areas.

• Frame select area

• Frame No. specification area

The function of each area is explained below.

(2)  Frame No. specification area

(1)  Frame select area
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(1) Frame select area

This area selects the frame that is the move destination.

Selected Item Description

1st frame of last block Move to the first frame of the latest block frame in the trace data.

Trigger frame of last block Move to the latest trigger frame of the latest block frame in the trace data.

Last frame of last block Move to the last frame in the trace data.

Frame No. Move to the frame with the specified No.

When 0 is specified, move to the first frame in the trace data.

When this item is checked, shift the focus to the area specified by the frame

No.

(2) Frame No. specification area

If “Frame No.” is selected in the frame selection area, this area specifies the frame No.  In the default, the

string selected in the accessed window, or “Last” is displayed, but as necessary, it can be changed by

inputting from the keyboard.

The default radix when inputting numerical values is decimal.

When a “+” mark is input in front of a numerical value, the area moves forward the specified number of

frames (toward the end of the display) from the frame at the cursor position.  Conversely, when a “–” mark is

input in front of the numerical value, the area moves backward the specified number of frames (toward the

beginning of the display).

The frame No. specification can also be specified in the following format.  It is also possible to specify it in

abbreviated form.  The input characters are not case sensitive.

The contents are shown below.

Specification Abbreviated Form Description

First S Move to the first frame of the current trace block.

Trigger T Move to the trigger frame of the current trace block.

Last L Move to the last frame of the current trace block.

Top O Move to the first frame of the trace data.

Bottom B Move to the last frame of the trace data.

By clicking the  button and displaying the input history, the contents input previously can be reused.  Up to

16 items of input history can be retained.
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Function buttons

Performs trace display from the specified position.

Closes the Trace Move dialog box.

Returns the input data to its original form.

Opens the help window.
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Symbol To Address Dialog Box

General

Displays the address of a specified variable or function, and the value of a symbol.

Opening method

This dialog box can be opened by the following methods.

Select [View] → [Symbol…] from the menu bar.

Press the  GRPH  +  V , and  Y  keys in that order.

Window

Figure 6-32.  Symbol To Address Dialog Box

Function

The Symbol To Address dialog box consists of the following areas.

• Symbol specification area

• Conversion results display area

• Display radix specification area

The function of each area is explained below.

(1) Symbol specification area

(1)  Symbol specification area

(2) Conversion results
display area

(3)  Display radix specification area
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This area specifies the variable, function name, symbol name, or line number to be converted.  Other than

this, an I/O port name, SFR name, register name, PSW flag name, or an expression can be specified.

The I/O port name and SFR name are displayed by address values, the register name is displayed by the

register contents and the PSW flag name is displayed by the flag value.  Also, bit symbols are converted to

“Address.bit”.  Furthermore, an expression which includes a bit symbol cannot be written.

Specification methods are shown below.

Conversion Object Specification Method

Variable var

file#var  (If a static function with a file name attached is specified.)

func#var  (If a static function with a function name attached is specified.)

file#func#var  (If a static function with a file name and function name attached is specified.)

Function func

file#func (If a static function with a file name attached is specified.)

Label label

file#label (If a local label with a file name attached is specified.)

EQU symbol equsym

file#equsym (If a local EQU symbol with a file name attached is specified.)

Bit symbol bitsym

file#bitsym (If a local bit symbol with a file name attached is specified.)

Line number of source file file#no

I/O Port portname

SFR sfrname

Register regname

PSW Flag pswname

Remark var: Variable name, func: Function, file: File name, label: Label name, equsym: EQU symbol name,

bitsym: Bit symbol name, portname: I/O port name, sfrname: SFR name, regname: Register name,

pswname: PSW flag name, no: Source file line number.

A “#” (sharp) is used as the delimiter between the file name and the variable, function name, and line

No.

If the specified symbol could not be found inside the scope, all symbols are searched for (static

variable, static function, local label, local EQU symbol, and local bit symbol).

As the default, the symbol name has priority.  Furthermore, when desiring to change the priority order

temporarily, adding a “$” (Dollar) sign in front of the symbol causes the register name to have priority.

If reading multiple load modules, when specifying the load module names, use the delimitor “$”

between the load module name and the file name, variables, function name, and symbol name.

In the default, the string selected in the accessed window is displayed, but as necessary, it is possible

to change it by inputting from the keyboard.  The radix of the default when inputting numerical values is

decimal.  When changing the contents of the symbol specification area, clicking the  button

displays the conversion results in the conversion results display area.

By clicking the  button and displaying the input history, the contents input previously can be reused.

Up to 16 items of input history can be retained.
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(2) Conversion results display area

The variables specified in the symbol specification area, the function address, symbol values, line number

addresses and expression values, etc. are displayed in this area.

(3) Display radix specification area

This area specifies the display radix of the conversion results display area.

Displayed in hexadecimal (default).

Displayed in decimal.

Displayed in octal.

Displayed in binary.

Function buttons

When the contents of the symbol specification area have been changed, the symbols are

converted. When the contents of the symbol specification area are unchanged after conversion,

the dialog box closes.

Closes the Symbol To Address dialog box.

Returns the input data to the original values.  If the  button has already been clicked,

the data returns to the state it was in just after the  button was clicked.

Opens the help window.
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Source Window

General

This window displays the source file or text file.

Also, display of disassembly of a program mixed with a source file, and execution of online assembly on a mixed

display is possible.

There are two modes in the Source window, normal display mode and mixed display mode.

Opening method

This window can be opened by the following methods.

• In the main window

Select [Browse] → [SourceText] from the menu bar.

Press the  GRPH  +  B , and  S  keys in that order.

• Click the  button on the toolbar.

• In the View File Load dialog box, select source file or text file, then click the  button.

Window

Figure 6-33.  Source Window (1/2)

Normal Display Mode
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Figure 6-33.  Source Window (2/2)

Mixed Display Mode

There are two modes in the Source window, normal display mode and mixed display mode.  An explanation of

each of these modes is given below.

Refer to (4) Source text display area  for further details.

(a) Normal display mode

In the normal display mode, general text files as well as source files can be displayed.

(b) Mixed display mode

In the mixed display mode, disassembly of programs combined with source files is displayed.

Online assembly cannot be performed in the Source window.  Perform online assembly in the Assemble

window.

The display contents in the mixed display mode can be saved as a display file.

Also, in a Source window that displays the source file from which the symbol information is read, there are two

states, the active state and the static state.

Source windows in the active state can only be opened one at a time, whereas multiple windows can be opened at

the same time in the static state.  Switching between states is done via the [Window] menu.

When switching the state of a window from static to active, the window which was active is switched to static.  After

being switched to static, the window is displayed with a new number such as Source[2].

Source files in which symbol information has not been read are read as text format files and their contents are not

changed.

These two states are described below.



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14910EJ1V0UM00 151

(a) Active state

A Source window in the active state is synchronized with the current PC value and the Source window’s

display is updated continuously so that it is always displaying the current PC line.

Also, if a Source window in the active state is synchronized not only with the jump function’s jump destination

but also with the Trace View window, the display in the Source window is updated in synch with the Trace

View window.

The first Source window opened is in the active state.

(b) Static State

A Source window in the static state is not synchronized with the current PC value and does not change the

display position, but its contents are updated.

Also, a Source window in the static state does not become a jump destination and is not synchronized with

the Trace View window.

If an active Source window is already open, a new Source window is opened in the static state.

Function

This window displays source files or text files.  It also displays disassembled display of programs mixed with source

files and can also perform online assembly in a mixed display.  The tab size and display font can be specified in the

Debugger Option dialog box.

The Source window consists of the following areas.

• Point mark area

• Current PC mark area

• Line number/address display area

• Source text display area

The function of each area is explained below.

(1) Point mark area

This area sets or deletes breakpoints, and displays the set status of each event condition and whether the

program code exists or not.

(a) Breakpoint setting/deletion function

By clicking this area with the mouse, a breakpoint can be set or deleted.

The necessary mouse operations are as follows depending on the line where mouse is clicked.
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Line Setting of “On Mouse Click” in
Extended Option Dialog Box

Operation

Soft Break Sets software breakpointWhere blank or marks other than the “B”
mark are displayed (E, L, T mark etc.)

Hard Break Sets hardware breakpoint

Soft Break Deletes software breakpointWhere “B” mark (blue) is displayed
(software breakpoint)

Hard Break Sets hardware breakpoint

Soft Break Sets software breakpointWhere “B” mark (red, black) is displayed
(hardware breakpoint)

Hard Break Deletes hardware breakpoint

Setting and deletion of breakpoints can be performed for lines which have an “*” displayed in the point

mark area.

As for lines without an “*” displayed, setting or deletion can be done on either the line above or below the

line where an “*” is displayed.

If a breakpoint is set, the “B” mark is displayed in the point mark area.  However, if a mark other than the

“B” mark is displayed, the “A” mark is displayed.

The “A” mark shows that multiple events are set.

When a hardware breakpoint and a software breakpoint overlap, the “A” mark is displayed.

If a breakpoint is deleted, the “B” mark in the point mark area is deleted and the area is left blank or a

mark other than the “B” mark is displayed.

The “B” mark is displayed in the following colors in accordance with the type of breakpoint and its state.

Display Color Explanation

Blue Shows that a software breakpoint is set.

Red Shows that the set hardware breakpoint is valid.

Black Shows that the set hardware breakpoint is invalid.  The hardware breakpoint can be
made valid in the Event Manager or the Break dialog box.

If a breakpoint is set in the point mark area, it becomes valid as soon as it is set.

(b) Event condition display function

The set status of each event is displayed.  If an execution event or access fetch event is set to the

corresponding source line, a mark corresponding to the type of event is displayed.

Mark Meaning

E Shows that an event condition is set

L Shows that the final stage of an event link is set

B Shows that a break event is set

T Shows that a trace event is set

Ti Shows that a timer event is set

S Shows that a snapshot event is set

A Shows that two or more events are set

MNote Shows that a DMM event is set

Note   ID78K0S-NS only.
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If a range address is specified as an event’s address condition, the lower address of the range becomes

the object.  Also, the address condition’s mask specification is not reflected.

(c) Program code display function

Lines where an “*” is displayed in the point mark area show that program code corresponding to the line

number exists.

Symbol Explanation

With “*” Shows that program code corresponding to the source file line No. exists.  This is
displayed only in cases where the load module is downloaded and symbol information
has been read.

Without “*” Shows that program code corresponding to the source file line No. does not exist.
Also, if a file other than a source file, such as a text file, is displayed, no lines have “*”
displayed.

(2) Current PC mark display area

This area displays the mark “>” indicating the value of the current PC (PC register value).  By clicking this

mark with the mouse, the PC register value is displayed in the pop-up window.

The program is executed up to the specified line by double-clicking on the current PC mark area.

(3) Line number/address display area

Normal display mode          Mixed display mode

This area displays the line number of the source file or text file.

On lines where program code corresponding to the source file line number exists, the line number is

displayed in red characters and on lines where no program code exists, the line number characters are

displayed in black.
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Also, the disassemble display’s address is displayed in the mixed display mode.  Address characters are

dimmed.

The position of the line number/address display area can be selected as desired by clicking the mouse.  A

selected line number or address is highlighted.

The following functions are included in line number or address selection.

(a) Drag-and-drop function

The selected highlighted line number or address can be dragged to another window or area.

If the line number or address position selected in the line number/address display area is dragged using

the left button of the mouse, the mouse cursor’s shape changes from an arrow to a .

If the cursor is moved into a window or area where it is possible to drop it, the shape of the mouse cursor

changes form  to .

The operation is executed for the address determined from the dropped address or line number in the

window where it was dropped.

The operation after drag-and-drop differs depending on the window or area where the items were

dropped.

Window or Area Which Is the Drop Object Operation After Drop

• Event Manager
Event manager area in each of the setting
dialog boxes below
• Event dialog box
• Event Link dialog box
• Break dialog box
• Trace dialog box
• Snap Shot dialog box
• Timer dialog box

With the dropped line number or address as the address condition,
the execution event conditions are generated automatically.
The event condition names are generated automatically, as
Evt00001, Evt00002, ... The external sense data conditions are not
specified.
Address conditions are set in the form of symbol name + offset value
for the symbol which is the closest.

• Link condition setting area in the Event Link
dialog box

• Break condition setting area in the Break
dialog box

• Section trace start condition area, section
trace end condition area, and qualify trace
condition area in the Trace dialog box

• Snapshot condition setting area in the
Snap Shot dialog box

• Timer condition setting area in the Timer
dialog box

With the dropped line number or address as the address condition,
the execution event conditions are generated automatically.
Furthermore, automatically generated event conditions are set in the
condition setting area where they were dropped.
The event condition names are generated automatically, as
Evt00001, Evt00002, ... The external sense data conditions are not
specified.
Address conditions are set in the form of symbol name + offset value
for the symbol which is the closest.

• Address condition setting area and data
condition setting area in the Event dialog
box

• Memory snap data setting area in the Snap
Shot dialog box

The line numbers or the address texts are set in the area where they
were dropped.
Address conditions are set in the form of symbol name + offset value
for the symbol which is the closest.
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(b) Window link function

Uses a line number or address to show the linked relationship between the Trace View window and the

Source window.  The line number or address which is the link object with the Trace View window is

highlighted.  For details, refer to the window link function under Trace View window.

(4) Source text display area

This area performs display and disassembly display of source files and text files and online assembly.

The display contents of the source text display area can be scrolled using the vertical and horizontal scroll

bars.

By selecting [View] → [Mix] on the menu bar, the normal display mode and the mixed display mode can be

switched.

Example 1. Normal display mode

The normal display mode is the mode in which the contents of source files or text files are

viewed.

2. Mixed display mode

The mixed display mode is the mode where disassembly display in combination with source

file display is performed.

• If a line of the displayed source file corresponds to program code, the disassemble line is

displayed following that source line.  In the disassemble line, the address label, code data, and

disassembled mnemonic are displayed.

• The mnemonic’s display starting position is adjusted according to the tab size setting value.

• The mixed display mode is valid only in cases where a load module is downloaded and symbol

information is read into it, and a source file corresponding to the downloaded load module is

displayed.
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• Even if [View] → [Mix] on the menu bar is checked and mixed display mode is selected, in

cases where a source file other than one corresponding to a load module is displayed, the

display mode is the normal display mode.

• The disassemble display in the mnemonic column displayed in the mixed display mode can be

changed.  In the case of a change, move the cursor to the mnemonic column of the

disassemble display line and change it.  The overwrite mode and the insert mode can be

switched during editing using the  INS  key.

If the cursor is moved to a different line after making changes in the mnemonic column, the change contents

are checked.  If the change contents are incorrect, the code data in the line where the change was made

becomes an “*”.

Even if moved to a different line, the change contents are not written to memory.  A different line can be

changed with the change contents not written to memory.

The changed contents of the mnemonic column are written to memory using the  Enter  key.  The change

contents are also checked if the  Enter  key is pressed.  If the change contents are incorrect, the code data in

the incorrect line become an “*”.  If there is even one incorrect line, the change contents are not written to

memory.  In such a case, correct the change contents.  To discard the change contents, press the  ESC  key.

If there are no errors in the change contents, press the  Enter  key.  After the change contents are written to

memory, the cursor moves to the next line’s mnemonic column.  The next line can then be changed.

The current PC line and the breakpoint setting line are displayed with different display colors and in bold

characters.

Meaning of Line Display Color Explanation

Current PC line Yellow This is the source line or the disassemble display line corresponding to

the current PC value.

It is the line where a “>“ is displayed in the current PC mark area.

When there is a mixed display, the display color of the disassemble

display line only is changed.  The source line is displayed with the

normal display color.

Breakpoint setting line Red This is a source line or a disassemble display line where a valid

breakpoint is set.

It is the line where a red or blue “B” is displayed in the point mark area.

When there is a mixed display, the display color of the disassemble

display line only is changed.  The source line is displayed with the

normal display color.

The source text display area has a number of functions, including program execution with the line where the

cursor is positioned as the object and setting of the breakpoint.

• Start function

• Come function

• Breakpoint setting function

• Program counter setting function

• Jump function



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14910EJ1V0UM00 157

With these functions, if there is a cursor located on the source text line, the top address of the program code

corresponding to the source line becomes the object and if the cursor is located on the disassemble display

line, that address becomes the object.  Also, if no program code exists on the source line, the top address of

either the line above or the line below that line, where program code exists, becomes the object.

Furthermore, these functions cannot be executed in the following cases.  The corresponding menu becomes

unavailable (dimmed).

• In the case where a file other than a source file is being displayed.

• In the case where a user program is being executed.

Each function is explained below.

(a) Start function

Executes the user program from the line where the cursor is placed.

This function is executed by performing the following operations in sequential order.

<1> Move the cursor to the line where execution is to start.

<2> Perform one of the following operations in the main window.

Select [Run] → [Start From Here] from the menu bar.

Press the  GRPH  +  R , and  A  keys in that order.

Press the shortcut keys  SHIFT  +  f·6 .

(b) Come function

Executes the user program up to the line where a cursor is placed.

While the user program is being executed by this function, however, the currently set break event is not

generated.

This function is executed by performing the following operations in sequential order.

<1> Move the cursor to the line at which a break is to occur.

<2> Perform one of the following operations in the main window.

Select [Run] → [Come Here] from the menu bar.

Press the  GRPH  +  R , and  M  keys in that order.

Press the shortcut key  f·6 .

(c) Breakpoint setting function

Sets a breakpoint to the line where a cursor is placed.  An execution event is used as the breakpoint to

be set.

This function is executed by performing the following operations in sequential order.

<1> Move the cursor to the line on which a breakpoint is to be set.

<2> Perform one of the following operations in the main window.

Select [Run] → [Break Point] or [Software Break Point] from the menu bar.

Press the  GRPH  +  R , and  B  keys or  GRPH  +  R , and  F  keys in that order.

Press shortcut key  f·9  or  f·11 .
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(d) Program counter setting function

Sets the address of the line where a cursor is placed to the program counter (PC).

This function is executed by performing the following operations in sequential order.

<1> Move the cursor to the line where the program counter (PC) is to be set.

<2> Perform one of the following operations in the main window.

Select [Run] → [Change PC] from the menu bar.

Press the  GRPH  +  R  , and  H  keys in that order.

Press shortcut keys  CTRL  +  f·9 .

(e) Jump function

Jumps to the Assemble window, Memory window, or Coverage window by using the address of the line

where a cursor is placed as a jump pointer.  The jump destination window displays the jump pointer at

the beginning.

This function is executed by performing the following operations in sequential order.

<1> Move the cursor to the line that is the jump origin.

<2> Perform one of the following operations in the main window.

• If the jump destination is the Assemble window

Select [Jump] → [Assemble] from the menu bar.

Press the  GRPH  +  J , and  A  keys in that order.

Press shortcut keys  CTRL  +  D .

• If the jump destination is the Memory window

Select [Jump] → [Memory…] from the menu bar.

Press the  GRPH  +  J , and  E  keys in that order.

Press shortcut keys  CTRL  +  M .

• If the jump destination is the Coverage window

Select [Jump] → [Coverage] from the menu bar.

Press the  GRPH  +  J , and  C  keys in that order.

Press shortcut keys  CTRL  +  I .

The text displayed in the source text display area can be selected by the following methods.

• From the desired position in the displayed text, drag the text to the desired position within the range of

one line.  Select the text from the drag start position to the end position.

• Double-click on the character string.  The words in the double-clicked position are selected.

In the source text display area, there are a number of functions which can be performed with the selected

text as the object, such as watch and quick watch.
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(f) Watch function

Adds the selected variables, etc. to the Watch window and displays their contents.  This function can be

run by performing the following operations in order.

<1> Select the text.

<2> Perform one of the following operations in the main window.

Select [View] → [View Watch] from the menu bar.

Press the  GRPH  +  V , and  I  keys in that order.
Click the  button in the Source window.

If the assembler symbol was selected, add it to the Watch window in accordance with the settings in the

Debugger Option dialog box.

Apart from the above method, this function can also be run by performing the following operation.

<1> Select the text.

<2> Perform one of the following operations in the main window.

Select [View] → [Add Watch…] from the menu bar.

Press the  GRPH  +  V , and  W  keys in that order.

By performing the above operation, the Add Watch dialog box is opened and the selected text is added

to the Watch window.  Furthermore, if the Watch window has not yet been opened, it will be opened.

(g) Quick watch function

This displays the contents of the selected variables, etc. temporarily in the Quick Watch dialog box.

This function is run by performing the following operations in order.

<1> Select the text.

<2> Perform one of the following operations in the main window.

Select [View] → [Quick Watch…] from the menu bar.

Press the  GRPH  +  V , and  Q  keys in that order.

Press the shortcut keys  CTRL  +  W .
Click the  button in the Source window.

The Quick Watch dialog box will open and the contents will be displayed.

(h) Drag-and-drop function

Through a drag-and-drop operation, the selected text can be dragged to another window or area and

dropped.  The operation order is shown below.

<1> Drag the selected text using the left button of the mouse.  The mouse cursor’s shape will change

from an arrow to a .

<2> If the mouse cursor is moved into a window or area where it is possible to drop it, the shape of the

cursor changes form  to .

Operation after drag-and-drop differs depending on the window or area where the items were dropped.
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Window or Area Which Is the Drop Object Operation After Drop

• Event Manager
Event manager area in each of the setting
dialog boxes below
• Event dialog box
• Event Link dialog box
• Break dialog box
• Trace dialog box
• Snap Shot dialog box
• Timer dialog box

If it is possible to convert the dropped text to an address value as a symbol,
with the converted address value as the address condition, the Access
status (all-access status) or the Execute status event conditions are
generated automatically.
The event condition names are generated automatically, as Evt00001,
Evt00002, ... The data conditions and external sense data conditions are not
specified.
The dropped text is set in the address conditions.  The relationship between
the generated event conditions and the symbols is as follows.

Symbol Status

Variable R/W
Function Execution

Symbols in the data section R/W
Symbols in the code section Execution

Other R/W

• Link condition setting area in the Event
Link dialog box

• Break condition setting area in the Break
dialog box

• Section trace start condition area,
section trace end condition area, and
qualify trace condition area in the Trace
dialog box

• Snapshot condition setting area in the
Snap Shot dialog box

• Timer condition setting area in the Timer
dialog box

If it is possible to convert the dropped text to an address value as a symbol,
with the converted address value as the address condition, the Access
status (all-access status) or the Execute status event conditions are
generated automatically.  Furthermore, the automatically generated event
conditions are set in each dropped conditions setting area.
The event condition names are generated automatically, as Evt00001,
Evt00002, ... The data conditions and external sense data conditions are not
specified.
The dropped text is set in the address conditions.  The relationship between
the generated event conditions and the symbols is as follows.

Symbol Status

Variable R/W
Function Execution

Symbols in the data section R/W
Symbols in the code section Execution

Other R/W

• Address condition setting area and data
condition setting area in the Event dialog
box

• Memory snap data setting area in the
Snap Shot dialog box

Text is set in the dropped area.

Watch window If the dropped text can be recognized as a symbol, the symbol contents are
displayed.
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Function buttons

Opens the Source Search dialog box and searches for source text character strings.

If text is selected in the source text display area, the selected text is set as the search object and the

Source Search dialog box is opened.  If text has not been selected, the Source Search dialog box is

opened with the search object in the blank state.

The search method is specified in the Source Search dialog box.  The search results are displayed

as selected in the Source window.

Performs the same operation as [View] → [Search] on the menu bar.

Searches for the text that matches the search conditions set in the Source Search dialog box in the

backward direction from the cursor position (toward the top of the display).  It changes to a
 button during a search.

Searches for the text that matches the search conditions set in the Source Search dialog box in the

forward direction from the cursor position (toward the bottom of the display).  It changes to a
 button during a search.

Interrupts a search.
During a search, the  button or the  button changes to a  button.

Adds variables and other items selected in the source text display area to the Watch window.

If the Watch window is currently not open, this button opens it.

If text is not selected in the source text display area, the Watch window is only opened.

This button operates the same as [View] → [View Watch].

Displays the selected variables and other contents of the source text display area temporarily in the

Quick Watch dialog box.

Opens the Quick Watch dialog box.

If text is not selected in the source text display area, the Quick Watch dialog box is only opened.

This button operates the same as [View] → [Quick Watch].

Updates the contents of the window with the latest data.

Closes this window.

Caution

If program code is described in an include file and if multiple files are included, the 1 to 1 relationship between line

numbers and addresses disappears.  In such include files, the function which uses the relationship between the line

number and the address does not function normally.
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Source Search Dialog Box

General

Searches file contents.

Opening method

This dialog box can be opened by the following methods.

• When the Source window is active

Select [View] → [Search…] from the menu bar.

Press the  GRPH  +  V , and  S  keys in that order.

Press the shortcut keys  CTRL  +  G .

Click the  button.

Window

Figure 6-34.  Source Search Dialog Box

Function

The Source Search dialog box consists of the following areas.

• Search data specification area

• Search condition specification area

• Search direction specification area

• Search file specification area

The function of each area is explained below.

(1) Search data
specification area

(2) Search condition
specification area

(3) Search direction specification area(4) Search file specification area
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(1) Search data specification area

This area specifies the data to be searched.

Although the character string selected in the window that has called this dialog box is displayed as the default

assumption, the character string can be changed by keyboard input as necessary.

By clicking the  button and displaying the input history, the contents input previously can be reused.  Up to

16 items of input history can be retained.

(2) Search condition specification area

This area specifies via a check box whether the data specified for searching is case sensitive or not.  As the

default, the data is case sensitive.

Not case sensitive

Case sensitive (default)

(3) Search direction specification area

This area specifies the search direction.  Two directions, upward and downward, can be selected.

• Up: Upward search.  Searches the data from the current cursor position toward the beginning

(upward on display).

• Down: Downward search.  Searches the data from the current cursor position toward the end

(downward on display).

(4) Search file specification area

This area specifies the search file.  If the specification is omitted, a search is made within the accessed

window.
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Function buttons

Searches the specified data under given conditions.

If a matching character string is found as a result of the search, it is highlighted.

To continue searching data, click this button again.

Sets the specified conditions as search conditions and closes the dialog box.

Stops searching the data.

The  button changes to the  button while data is being searched.

Closes the Source Search dialog box.

This button changes to the  button while data is being searched.

Opens the help window that explains the Source Search dialog box.

Opens the Browse dialog box.
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Assemble Window

General

This window displays a disassemble text and can also execute online assemble.

Opening method

This window can be opened by the following methods.

• In the main window

Select [Browse] → [Assemble…] from the menu bar.

Press the  GRPH  +  B , and  A  keys in that order.

• Click the  button on the toolbar.

Window

Figure 6-35.  Assemble Window

Function

Performs disassemble display and online assembly.

Online assembly is performed by moving the cursor to the mnemonic.

The online assembly results are also reflected in the Memory window.

The Assemble window has two states, the active state and the static state.

Only one Assemble window in the active state can be opened at a time, but multiple Assemble windows which are

in the static state can be opened at the same time.

These two states are described below.
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(1) Active state

The first Assemble window that is opened is in the active state.

The Assemble window’s display is updated when it is in the active state so that the current PC line is

displayed at all times in sync with the current PC value.

Also, when in the active state, the Assemble window becomes the jump destination for the jump function and,

if it is synchronized with the Trace View window, the Assemble window’s display is updated in sync with the

Trace View window.

(2) Static state

An Assemble window in the static state is not synchronized with the current PC value and it displays a

constant address.

Also, an Assemble window in the static state cannot be made a jump destination, nor can it be synchronized

with the Trace View window.

If an Assemble window has already been opened in the active state, then all subsequent windows are

opened in the static state.

The Assemble window consists of the following areas.

• Point mark display area

• Current PC mark display area

• Address display area

• Disassemble display area

The function of each area is explained below.

(1) Point mark display area

This area sets or deletes breakpoints, and displays the setting status of each event.

(a) Breakpoint setting/deletion function

By clicking this area with the mouse, breakpoints can be set or deleted.  The operation when clicking the

mouse is as follows depending on the line where the mouse is clicked and the setting of On Mouse Click

in the Extended Option dialog box.

Line Setting of “On Mouse Click” in
Extended Option Dialog Box

Operation

Soft Break Sets software breakpointWhere blank or marks other than the “B”
mark are displayed (E, L, T mark etc.) Hard Break Sets hardware breakpoint

Soft Break Deletes software breakpointWhere “B” mark (blue) is displayed
(software breakpoint) Hard Break Sets hardware breakpoint

Soft Break Sets software breakpointWhere “B” mark (red, black) is displayed
(hardware breakpoint) Hard Break Deletes hardware breakpoint
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If a breakpoint is set, the “B” mark is displayed in the point mark area.  However, if a mark other than the

“B” mark is displayed, the “A” mark is displayed.

The “A” mark shows that multiple events are set.

When a hardware breakpoint and a software breakpoint overlap, the “A” mark is displayed.

If a breakpoint is deleted, the “B” mark in the point mark area is deleted and the area is left blank or a

mark other than the “B” mark is displayed.

The “B” mark is displayed in the following colors in accordance with the type of breakpoint and its state.

Display Color Explanation

Blue Shows that a software breakpoint is set.

Red Shows that the set hardware breakpoint is valid.

Black Shows that the set hardware breakpoint is invalid.  The hardware breakpoint can be

made valid in the Event Manager or the Break dialog box.

If a breakpoint is set in the point mark area, it becomes valid at the time it is set.

(b) Event condition display function

The set status of each event is displayed.  If the execution event, or the fetch condition of an access

event is set, a mark indicating the type of each event condition is displayed in the corresponding

assemble line.

Mark Meaning

E Shows that an event condition is set

L Shows that the final stage of an event link is set

B Shows that a break event is set

T Shows that a trace event is set

Ti Shows that a timer event is set

S Shows that a snapshot event is set

A Shows that two or more events are set

MNote Shows that a DMM event is set

Note ID78K0S-NS only.

If a range address is specified as an event’s address condition, the lower address of the range becomes

the object.  Also, the address condition’s mask specification is not reflected.
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(2) Current PC mark display area

This area displays mark “>” indicating the value of the current PC (PC register value).  The program is

executed up to the specified line by double-clicking the current PC mark area.

(3) Address display area

This area displays the disassemble start address.  When this field is clicked, an address is highlighted and

selected.

In addition, this area has the following functions.

(a) Drag-and-drop function

A selected address which is highlighted can be dragged to another window or area.

If the mouse cursor is positioned on the position of the selected address in the address display area and

the left button is pressed and held down, then when the mouse is dragged, the arrow cursor form

changes to a .

If the mouse cursor is moved into a window or area where it is possible to drop it, the shape of the cursor

changes form  to .

The operation is performed with respect to the dropped address in the window where it was dropped.

Operations after an address is dropped depend on the respective window or area where it was dropped.
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Window or Area Which Is the Drop Object Operation After Drop

• Event manager

Event manager area in each of the setting

dialog boxes below

• Event dialog box

• Event Link dialog box

• Break dialog box

• Trace dialog box

• Snap Shot dialog box

• Timer dialog box

With the dropped address as the address condition, the execution

event conditions are generated automatically.

The event condition names are generated automatically, as

Evt00001, Evt00002, ... The external sense data conditions are not

specified.

Address conditions are set in the form of symbol name + offset value

for the symbol which is the closest.

• Link condition setting area in the Event Link

dialog box

• Break condition setting area in the Break

dialog box

• Section trace start condition area, section

trace end condition area, and qualify trace

condition area in the Trace dialog box

• Snapshot condition setting area in the

Snap Shot dialog box

• Timer condition setting area in the Timer

dialog box

The execution event conditions are generated automatically with the

dropped address as the address condition.

Furthermore, automatically generated event conditions are set in the

conditions setting area where they were dropped.

The event condition names are generated automatically, as

Evt00001, Evt00002, ... The external sense data conditions are not

specified.

Address conditions are set in the form of symbol name + offset value

for the symbol which is the closest.

• Address condition setting area and data

condition setting area in the Event dialog

box

• Memory snap data setting area in the Snap

Shot dialog box

The address text is set in the area where it was dropped.

Address conditions are set in the form of symbol name + offset value

for the symbol which is the closest.

(b) Window link function

Uses an address to show the linked relationship between the Trace View window and the disassemble

display.

The address which is the link object with the Trace View window is highlighted.  For details, refer to the

window link function of the Trace View window.
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(4) Disassemble display area

The address label, code data, and disassembled mnemonic are displayed in the disassemble display area.

The disassemble display in the mnemonic column can be changed.

To change it, move the cursor to the mnemonic column.  During editing, the  INS  key can be used to switch

between the overwrite mode and the insert mode.

After making the desired changes in the mnemonic column, if the cursor is moved to a different line, the

contents of the change are checked.  If the change contents are incorrect, the code data in the changed line

becomes an “*”.

Even if it is moved to a different line, the change contents are not written to memory.  Another line can be

changed without the changes being written to memory.

The changed contents in the mnemonic column are written to memory by pressing the  Enter  key.  The

change contents are also checked when the  Enter  key is pressed.  If the change contents are incorrect, the

code data in the incorrect line become an “*”.  If even one line is incorrect, the change contents are not

written to memory.  In such a case, correct the change contents.  To discard the change contents, press the

 ESC  key.  If the change contents are not incorrect, if the  Enter  key is pressed, after the change contents

are written to memory, the cursor moves to the next line’s mnemonic column.  In this way changes can

continue to be made in the next line.

If, as a result of the change, the number of bytes in the instructions after the change is fewer than the number

of bytes in the instruction before the change, the remaining bytes are replaced by the “NOP” instruction.

Also, if, as a result of the change, the number of bytes in the instructions after the change is greater than the

number of bytes in the instruction before the change, the next instruction is overwritten.  In this case also, the

remaining bytes are replaced by the “NOP” instruction.  Even in cases where the change runs into the source

line, it is overwritten in the same way.

As for the current PC line and the breakpoint setting line, the display color is changed and they are displayed

in bold.
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Meaning of Line Display Color Explanation

Current PC line Yellow This line corresponds to the current PC value.

This is the line where a “>“ is displayed in the current PC mark

area.

Breakpoint setting line Red This is the line where the valid breakpoint is set.

This is the line where a red or blue “B” is displayed in the point

mark area.

The disassemble display area includes a number of functions such as program execution with the line where

the cursor is located as the object, or setting of the breakpoint, etc.

• Start function

• Come function

• Breakpoint setting function

• Program counter setting function

• Jump function

Furthermore, in the following case, these functions cannot be executed.  The corresponding menu is dimmed

and becomes impossible to select.

• If a user program is being executed.

Each function is explained below.

(a) Start function

Executes the user program from the line where the cursor is located.

This function is executed by performing the following operations in sequential order.

<1> Move the cursor to the line where execution is to start.

<2> Perform one of the following operations in the main window.

Select [Run] → [Start From Here] from the menu bar.

Press the  GRPH  +  R , and  A  keys in that order.

Press the shortcut keys  SHIFT  +  f·6 .

(b) Come function

Executes the user program up to the line where a cursor is placed.

While the user program is being executed in this mode, however, the break event currently set is not

generated.

This function is executed by performing the following operations in sequential order.

<1> Move the cursor to the line where execution is to end.

<2> Perform one of the following operations in the main window.

Select [Run] → [Come Here] from the menu bar.

Press the  GRPH  +  R , and  M  keys in that order.

Press the shortcut key  f·6 .
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(c) Breakpoint setting function

Sets a breakpoint to the line where a cursor is placed.

An execution event is used as the breakpoint to be set.

This function is executed by performing the following operations in sequential order.

<1> Move the cursor to the line to which a breakpoint is to be set.

<2> Perform one of the following operations in the main window.

Select [Run] → [Break Point] from the menu bar.

Press the  GRPH  +  R , and  B  keys in that order.

Press shortcut key  f·9 .

(d) Program counter setting function

Sets the address of the line where the cursor is placed to the PC (program counter).

<1> Move the cursor to the line where the program counter is to be set (PC).

<2> Perform one of the following operations in the main window.

Select [Run] → [Change PC] from the menu bar.

Press the  GRPH  +  R , and  H  keys in that order.

Press the shortcut keys  CTRL  +  f·9 .

(e) Jump function

Jumps to the Source window, Memory window, or Coverage window by using the address of the line

where the cursor is placed as a jump pointer.

The jump destination window displays the jump pointer at the beginning.

This function is executed by performing the following operations in sequential order.

<1> Move the cursor to the line which is the jump origin.

<2> Perform one of the following operations in the main window.

• If the jump destination is the Source window

Select [Jump] → [SourceText] from the menu bar.

Press the  GRPH  +  J , and  S  keys in that order.

Press shortcut keys  CTRL  +  U .

• If the jump destination is the Memory window

Select [Jump] → [Memory] from the menu bar.

Press the  GRPH  +  J , and  E  keys in that order.

Press shortcut keys  CTRL  +  M .

• If the jump destination is the Coverage window

Select [Jump] → [Coverage] from the menu bar.

Press the  GRPH  +  J , and  C  keys in that order.

Press the shortcut keys  CTRL  +  I .
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The text displayed in the disassemble display area can be selected by the following method.

• From the position where the desired text starts in the display, drag the mouse to the position within the

range of 1 line.  The text from the starting position to the end position is the text that is selected.

• Double-click the character string.  The words in the double-clicked position are selected.

In the disassemble display area, a number of functions, such as watch and quick watch with the selected

text as the object, can be performed.

(f) Watch function

This adds the selected data to the Watch window and displays its contents.

Furthermore, if an assembler symbol is selected, it is added to the Watch window in accordance with the

settings in the Debugger Option dialog box.

This function is executed by carrying out the following operations in order.

<1> Select the text.

<2> Perform one of the following operations in the main window.

Select [View] → [View Watch] from the menu bar.

Press the  GRPH  +  V , and  I  keys in that order.

Select [View] → [Add Watch…] from the menu bar.

Press the  GRPH  +  V , and  W  keys in that order.
Click the  button in the Assemble window.

If any of these operations is carried out, the Add Watch dialog box opens and adding is performed.

If the Watch window is not currently open, the Watch window is opened.

(g) Quick watch function

This temporarily displays the contents of the selected data in the Quick Watch dialog box.

This function is executed by carrying out the following procedure in order.

<1> Select the text.

<2> Perform one of the following operations in the main window.

Select [View] → [Quick Watch…] from the menu bar.

Press the  GRPH  +  V , and  Q  keys in that order.

Press the shortcut keys  CTRL  +  W .
Click the  button in the Assemble window.

The Quick Watch dialog box opens and its contents are displayed.
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(h) Drag-and-drop function

Through a drag-and-drop operation, the selected text can be dragged to another window or area.  The

operation order is shown below.

<1> Drag the selected text using the left button of the mouse.  The mouse cursor’s shape will change

from an arrow to a .

<2> If the mouse cursor is moved into a window or area where it is possible to drop it, the shape of the

cursor changes form  to .

Operation after drag-and-drop differs depending on the window or area where the items were dropped.

Window or Area Which Is the Drop Object Operation After Drop

• Event Manager
Event manager area in each of the setting
dialog boxes below
• Event dialog box
• Event Link dialog box
• Break dialog box
• Trace dialog box
• Snap Shot dialog box
• Timer dialog box

If it is possible to convert the dropped text to an address value as a symbol,
with the converted address value as the address condition, the Access
status (all-access status) or the Execute status event conditions are
generated automatically.
The event condition names are generated automatically, as Evt00001,
Evt00002, ... The data conditions and external sense data conditions are not
specified.
The dropped text is set in the address conditions.  The relationship between
the generated event conditions and the symbols is as follows.

Symbol Status

Variable R/W
Function Execution

Symbols in the data section R/W
Symbols in the code section Execution

Other R/W

• Link condition setting area in the Event
Link dialog box

• Break condition setting area in the Break
dialog box

• Section trace start condition area,
section trace end condition area, and
qualify trace condition area in the Trace
dialog box

• Snapshot condition setting area in the
Snap Shot dialog box

• Timer condition setting area in the Timer
dialog box

If it is possible to convert the dropped text to an address value as a symbol,
with the converted address value as the address condition, the Access
status (all-access status) or the Execute status event conditions are
generated automatically.  Furthermore, the automatically generated event
conditions are set in each dropped conditions setting area.
The event condition names are generated automatically, as Evt00001,
Evt00002, ... The data conditions and external sense data conditions are not
specified.
The dropped text is set in the address conditions.  The relationship between
the generated event conditions and the symbols is as follows.

Symbol Status

Variable R/W
Function Execution

Symbols in the data section R/W
Symbols in the code section Execution

Other R/W

• Address condition setting area and data
condition setting area in the Event dialog
box

• Memory snap data setting area in the
Snap Shot dialog box

Text is set in the dropped area.

Watch window If the dropped text can be recognized as a symbol, the symbol contents are
displayed.
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Function buttons

Opens the Assemble Search dialog box and searches the character string of a mnemonic.  If text

has been selected in the disassemble display area, sets the selected text as the search object and

opens the Assemble Search dialog box.

If text has not been selected, the Assemble Search dialog box will open with the search object in the

blank state.

Specify the search method in the Assemble Search dialog box.  The search results are selectively

displayed in the Assemble window.

Operation is the same as when [View ] → [Search...]  is selected on the menu bar.

Searches for the contents that match the search conditions set in the Assemble Search dialog box

in the backward direction from the cursor position (toward the top of the display).
During the search, it changes to a  button.

Searches for the contents that match the search conditions set in the Assemble Search dialog box

in the forward direction from the cursor position (toward the bottom of the display).
During the search, it changes to a  button.

Interrupts the search.
During a search, the  button or the  button changes to the  button.

Adds the symbol, etc. selected in the disassemble display area to the Watch window.

If the Watch window has not been opened, it opens the Watch window.

If text has not been selected in the disassemble display area, the Watch window is only opened.

The operation is the same as when [View] → [View Watch] is selected on the menu bar.

Temporarily displays the contents of symbols, etc. selected in the disassemble display area in the

Quick Watch dialog box.

It opens the Quick Watch dialog box.

If text has not been selected in the disassemble display area, the Quick Watch dialog box is only

opened.

The operation is the same as when [View] → [Quick Watch]  is selected on the menu bar.

Updates the window contents with the latest data.

Closes the Assemble window.
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Assemble Search Dialog Box

General

Searches the contents of the Assemble window.

Opening Method

This dialog box can be opened by one of the following methods when the Assemble window is the current window.

• In the main window

Select [View] → [Search...] from the menu bar.

Press the  GRPH  +  V , and  S  keys in that order.

Press the shortcut keys  CTRL  +  G .

• In the Assemble window

Click the  button.

Window

Figure 6-36.  Assemble Search Dialog Box

Function

Initiates a search for the disassemble contents.  Continuous null characters which include input character strings

and disassemble character strings are compared as a single null character.

The Assemble Search dialog box consists of the following areas.

• Search data specification area

• Search conditions specification area

• Search direction specification area

• Search range specification area

The function of each area is explained below.

(1) Search data
specification area

(2) Search conditions
specification area

(3) Search direction specification area(4) Search range specification area
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(1) Search data specification area

This area specifies the data that is to be searched for.

In the default setting, the string selected in the accessed window is displayed, but as necessary, it can be

changed by inputting from the keyboard.

By clicking the  button and displaying the input history, the contents input previously can be reused.  Up to

16 items of input history can be retained.

(2) Search conditions specification area

(a)

When searching, this check box specifies whether the data specified for searching is case sensitive or

not.

In the default setting, the data is case sensitive.

Not case sensitive.

Case sensitive (default)

(b)

When searching, this check box specifies whether to search the whole range or not.  In the default

setting, only the remaining portion of the range is searched.

Only the remaining portion of the range is searched (default).

The whole range is searched.

(3) Search direction specification area

This specifies the search direction.

There are two types of search, upward, and downward.

Up: Upward search.  Searches the data from the current cursor position toward the beginning

(upward on display).

Down: Downward search.  Searches the data from the current cursor position toward the end

(downward on display).
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(4) Search range specification area

This area specifies the addresses being searched.  A symbol or an expression can also be specified for an

address.

The specification method is the same as in the case of the Address Move dialog box.  The default radix when

inputting numerical values is hexadecimal.

Function buttons

Searches for the specified search data in accordance with the conditions.  As the search results, the

matching character string is highlighted.  For a continuous search, press this button again.

Sets the specified conditions as the search conditions and closes the dialog box.

Interrupts the search for data.
During the data search, the  button changes to the  button.

Closes the Assemble Search dialog box.
During a data search, it changes to the  button.

Opens the help window that explains the Assemble Search dialog box.
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Memory Window

General

This window displays and changes the memory contents.

Opening method

This window can be opened by the following methods.

• In the main window

Select [Browse] → [Memory] from the menu bar.

Select [Jump] → [Memory] from the menu bar.

Press the  GRPH  +  B , and  M  keys in that order.

Press the  GRPH  +  J , and  E  keys in that order.

Click the  button on the toolbar.
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Window

Figure 6-37.  Memory Window

Without ASCII display

With ASCII display
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Function

Displays and changes the memory contents.

A vertical scroll bar is always displayed so that the memory contents can be scrolled.

The  button or the  button can also be used to move the display one page up or one page down.

Also, even during emulation, the memory contents can be displayed in real time.  The real-time display range is the

address range set in the Extended Option dialog box.

The Memory window has two states, the active state and the static state.

Only one Memory window in the active state can be opened at a time, but multiple Memory windows which are in

the static state can be opened at the same time.

Each Memory window state is explained below.

(1) Active state

A Memory window in the active state is the jump destination for the jump function and, if it is synchronized

with the Trace View window, the Memory window’s display is updated in synchronization with the Trace View

window.  The first Memory window opened is in the active state.

(2) Static State

A Memory window in the static state is not the jump destination and is not synchronized with the Trace View

window.  Except for those points, it operates in the same way as in the active state.

If an active Memory window is already open, then all subsequent Memory windows are opened in the static

state.

The Memory window consists of the following areas.

• Address display area

• Memory display area

• ASCII display area

The function of each area is explained below.

(1) Address display area

This area displays memory addresses.

The address width changes when memory bank is used.
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(2) Memory display area

This area displays and changes the memory contents.  The contents to be changed are displayed in red

characters, then by pressing the  Enter  key, they are actually written to the target.  The contents prior to the

change (when in the red character state) can be erased using the  ESC  key.

Up to 256 bytes of data can be changed at one time.

This area also has the following two functions in addition to displaying the memory contents making changes.

(a) Jump function

Jumps to the Source window, Assemble window, or Coverage window by using the address at the cursor

position as a jump pointer.  The jump destination window displays the jump pointer at the beginning.

This function is executed by performing the following operations in sequential order.

<1> Move the cursor to the line which is the jump origin.

<2> Perform one of the following operations in the main window.

• If the jump destination is the Source window

Select [Jump] → [ SourceText] from the menu bar.

Press the  GRPH  +  J , and  S  keys in that order.

Press shortcut keys  CTRL  +  U .

• If the jump destination is the Assemble window

Select [Jump] → [Assemble] from the menu bar.

Press the  GRPH  +  J , and  A  keys in that order.

Press shortcut keys  CTRL  +  D .

• If the jump destination is the Coverage window

Select [Jump] → [Coverage] from the menu bar.

Press the  GRPH  +  J , and  C  keys in that order.

Press shortcut keys  CTRL  +  I .

(b) Window link function

Shows the relationship between the Trace View window and the Memory window via memory contents.

For further information, refer to the description of the window link function for the Trace View window.
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(3) ASCII display area

This area displays the memory contents in ASCII.  The memory contents can be converted into ASCII

characters for display.  The conversion method is the same as the memory display area.

The display can be turned on and off by selecting [View] → [Ascii] on the menu bar (the display is on by the

default setting).

This area is also a jump pointer for the jump function, in the same way as in (2) Memory display area .

Function buttons

Opens the Memory Search dialog box and searches for a character string in the displayed memory

contents or memory contents.  At this time, the selected data (memory value) is displayed in the

Memory Search dialog box as the search subject.  If the dialog box is opened without data

specified, specify data by key input.  The result of the search is highlighted in the Memory window.

Searches for the memory contents that match the search conditions set in the Memory Search

dialog box in the backward direction from the cursor position (toward the top of the display).  It

changes to a  button during a search.

Searches for the memory contents that match the search conditions set in the Memory Search

dialog box in the forward direction from the cursor position (toward the bottom of the display).  It

changes to a  button during a search.

Interrupts a search.

During a search, the  button or the  button changes to a  button.

Updates the window’s contents with the latest data.

Closes this window.
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Memory Search Dialog Box

General

Searches the memory contents.

Opening method

This dialog box can be opened by one of the following methods.

• Set the Memory window as the current window and in the main window;

Select [View] → [Search…] from the menu bar.

Press the  GRPH  +  V , and  S  keys in that order.

Press the shortcut keys  CTRL  +  G .

• In the Memory window
Click the  button.

Window

Figure 6-38.  Memory Search Dialog Box

(1) Search data
specification area

(3) Search direction specification area

(4) Search range
specification area

(2) Search condition
specification area
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Function

This searches the contents of memory for the Memory window where the cursor is placed.

If the cursor is in the memory display area, the specified data is regarded as a binary data string and the memory

display area is searched.

If the cursor is in the ASCII display area, the specified data is regarded as an ASCII character string and the ASCII

display area is searched.

Unmapped areas, SFR areas, and I/O protected areas are not searched.

The search result is highlighted in the Memory window.  The highlighted data can be placed on the clipboard, but

note that only the last line is placed when the data extends to several lines.

The Memory Search dialog box consists of the following areas.

• Search data specification area

• Search condition specification area

• Search direction specification area

• Search range specification area

The function of each area is explained below.

(1) Search data specification area

This area specifies the data to be searched.

Although the character string selected in the window that has called this dialog box is displayed as the default

assumption, the character string can be changed by keyboard input as necessary (input cannot be made

using a symbol or expression.)

When searching the memory display area, a maximum of 16 items of data can be specified at one time.

Specify each item of data using a space as a delimiter.

When searching the ASCII display area, a maximum of 256 characters of data can be specified.  Spaces in

the data are treated as null characters.

By clicking the  button and displaying the input history, the contents input previously can be reused.  Up to

16 items of input history can be retained.

(2) Search condition specification area

(a)

This area specifies the bit size each specified search data is to be regarded as via a check box.  As the

default, the data is searched as 8-bit data.

Byte: Search as 8-bit data (default)

Word: Search as 16-bit data

Double Word: Search as 32-bit data
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(b)

This is a check box which specifies whether to search the whole specified region or not when conducting

search.  With the default, only the portion remaining in the range is searched.

Searches the remaining portion of the range (default).

Searches the whole range.

(3) Search direction specification area

This area specifies the direction of search.  Two directions, upward and downward, can be selected.

• Up: Upward search.  Searches the data from the current cursor position toward the beginning

(upward on display).

• Down: Downward search.  Searches the data from the current cursor position toward the end

(downward on display).

(4) Search range specification area

This area specifies the addresses being searched.  A symbol or expression can also be specified for an

address.

The specification method is the same as in the case of the Address Move dialog box.  The default radix when

inputting numerical values is hexadecimal.

Function buttons

Searches for the specified search data in accordance with the conditions.  As the search results, the

matching character string is highlighted.  For a continuous search, press this button again.

Sets the specified conditions as the search conditions and closes the dialog box.

Interrupts the search for data.

During the data search, the  button changes to the  button.

Closes the Memory Search dialog box.

During a data search, it changes to the  button.

Opens the help window that explains the Memory Search dialog box.
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Memory Fill Dialog Box

General

Initializes the memory contents with a specified code.

Opening method

This dialog box can be opened by the following methods.

• In the main window

Select [Edit] → [Memory] → [Fill…] from the menu bar.

Press the  GRPH  +  E ,  M , and  F  keys in that order.

Window

Figure 6-39.  Memory Fill Dialog Box

Function

The Memory Fill dialog box consists of the following areas.

• Address range specification area

• Data specification area

The function of each area is explained below.

(1) Address range specification area

(2) Data specification area
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(1) Address range specification area

This area specifies the address range of the memory contents to be initialized.

A symbol or expression can also be specified for an address.  The default radix when inputting numerical

values is hexadecimal.

Specify the initialization top and end addresses, in that order.

(2) Data specification area

This area specifies the data to be initialized.

Binary data strings (byte data strings) with up to 16 items of data can be specified.  Specify each item of data

using a space as a delimiter.

The default radix is hexadecimal and the radix can be specified for each item of data.

Function buttons

Initializes the memory contents.

Closes this dialog box.

This button changes to the  button during memory initialization.

Stops initializing the memory.

The  button changes to the  button during memory initialization.

Returns the input data to its original form.

Opens the help window.
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Memory Copy Dialog Box

General

Copies the memory contents.

Opening method

This dialog box can be opened by the following methods.

• In the main window

Select [Edit] → [Memory] → [Copy…] from the menu bar.

Press the  GRPH  +  E ,  M , and  C  keys in that order.

Window

Figure 6-40.  Memory Copy Dialog Box

Function

The Memory Copy dialog box consists of the following area.

• Address range specification area

The function of this area is explained below.

(1) Address range specification area

(1) Address range specification area
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This area specifies the copy source and copy destination addresses.

A symbol or expression can also be specified for an address.  The default radix when inputting numerical

values is hexadecimal.

From: Specifies the address range of the copy source.  Specify the copy source top address and copy

source end address, in that order.

To: Specifies the top address of the copy destination.

Function buttons

Copies the memory contents.

Closes this dialog box.

This button changes to the  button while copying the memory.

Stops copying the memory data.

The  button changes to the  button while copying the memory.

Returns the input data to its original value.

Opens the help window.
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Memory Compare Dialog Box

General

Compares the memory contents.

Opening method

This dialog box can be opened by the following methods.

• In the main window

Select [Edit] → [Memory] → [Compare…] from the menu bar.

Press the  GRPH  +  E ,  M , and  P  keys in that order.

Window

Figure 6-41.  Memory Compare Dialog Box

Function

The Memory Compare dialog box consists of the following area.

• Compare range specification area

The function of this area is explained below.

(1) Compare range specification area

(1) Compare range specification area
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This area specifies the compare source and compare destination addresses.

A symbol or expression can also be specified for an address.  The default radix when inputting numerical

values is hexadecimal.

Specify the address range of the compare source and the compare destination so that a guard area is not

included.  If a guard area is included, an error will occur and the error message f201 (F) will be displayed.

Mem1: Specify the address range of the compare source. Specify the compare source top address and

compare source end address, in that order.

Mem2: Specify the top address of the compare destination.

Function buttons

Compares the memory contents.

If no difference is found as a result of comparison, a confirmation dialog box is displayed.  If a

difference is found, a Memory Compare Result dialog box is opened.  The confirmation dialog box

that is displayed if no difference is found as a result of comparison is shown below.

By clicking the  button in this confirmation dialog box, the Memory Compare dialog box is

closed.

Closes this dialog box.

This button changes to the  button during comparison.

Stops comparing the memory contents.

The  button changes to the  button while comparing the memory contents.

Returns the input data to its original value.

Opens the help window.
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Memory Compare Result Dialog Box

General

Displays the result of comparing memory contents.

This dialog box is opened if a discrepancy is found as a result of comparing the memory contents in the Memory

Compare Dialog box.  If no discrepancy is found, a confirmation dialog box is opened instead of this dialog box.

Window

Figure 6-42.  Memory Compare Result Dialog Box

Function

The Memory Compare Result dialog box consists of the following area.

• Compare result display area

The function of this area is explained below.
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(1) Compare result display area

This area displays the result of comparing memory contents.  Only those parts where there were comparison

errors are displayed.

Mem1 Addr: Displays the compare source address at which an error has been found.

Memory: Displays the data that has caused the error.  The compare source data is displayed on

the left, and the compare destination data is displayed on the right.

Mem2 Addr: Displays the compare destination address at which an error has been found.

The address width changes when a memory bank is used.

Function buttons

Closes this dialog box.

Opens the help window.
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Watch Window

General

This window displays and changes the specified data.

Opening method

This window can be opened by one of the following methods.

• In the main window

Select [Browse] → [Watch] from the menu bar.

Press the  GRPH  +  B , and  W  keys in that order.

Click the  button on the toolbar.

• In the Source window

After selecting data, select [View] → [View Watch] from the menu bar.

Press the  GRPH  +  V , and  I  keys in that order.
Click the  button.

• In the Assemble window

After selecting data, select [View] → [View Watch] from the menu bar.

Press the  GRPH  +  V , and  I  keys in that order.
Click the  button.
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Window

Figure 6-43.  Watch Window

Function

Displays and changes data.

The data display is added to by selecting a variable name or symbol name in the Source window or the Assemble
window and clicking the  button, or by dragging the selected part directly to the Watch window with the

mouse.

Adding can also be done by specifying a variable name or symbol name in the Quick Watch dialog box or the Add

Watch dialog box and clicking .

To delete a data display, click a variable name or symbol name, then after highlighting it, click the 

button.  Alternatively, make a selection using the arrow keys, then after highlighting the selection delete it by pressing

the  DEL  key.

Data value update results and rewrites are reflected in the Memory window.

Also, wide-area data allocated to any 2 KB of internal RAM area (such as global variables or public symbols) can

be displayed in real time even during emulation, just as in the Memory window.

The boundary line between the symbol name display area and data value display/setting area can be moved to the

left or right using the mouse.

To move the boundary, drag the mouse cursor at the point when it changes from “ ” to “↔”.

The Watch window consists of the following areas.

• Symbol name display area

• Data value display/setting area
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The function of each area is explained below.

(1) Symbol name display area

This area displays the variable names and symbol names.

A “+” is displayed in front of arrays, pointer type variables, and structures/unions.  These variables are

expanded and displayed as shown below by double-clicking them.

• For an array, all the elements of the variable are displayed in accordance with the type of array variable.

• For pointer type variables, the data indicated by the pointer is displayed.

• For structures/unions, all the members of the structure/union are displayed in accordance with the type of

member variable.

However, if a structure/union is defined within a structure/union, the members up to the tag name or

variable name in the internal structure/union are displayed.

For variables which have been expanded and displayed, the “+” display is changed to a “–” display.  If they

are double-clicked in this state, the expansion display is deleted.

Note that variables with a “+” that are displayed inside a structure/union are expanded and displayed in the

same way by double-clicking them.

To expand and display, or to delete an expansion display, select the variable with the arrow keys, then press

the  Enter  key.

Data which has become invalid due to changes in the scope or optimization compilation is dimmed.

Whether to display or not display variable types can be set in the Debugger Option dialog box.
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(2) Data value display/setting area

This area is where data values are displayed and changed.

• When the variable is a structure/union, the address is displayed.

• When the variable is an enumeration type, the member name is displayed.

• When the variable is an integer, it is displayed as follows.

XXXH: Displayed in hexadecimal.

XXXT: Displayed in decimal.

XXXQ: Displayed in octal.

XXXY: Displayed in binary.

• When the variable is a floating point, it is displayed as follows.

[+|–]  inf

[+|–]  nan

[+|–]  integer portion e [+|–] exponent

[+|–]  integer portion.  Decimal portion [e [+|–] exponent]

Values are updated when execution is stopped.  To save values, select [File] → [Save As…] in the main

window, then save to the displayed file.  Also, if the acquisition of data values has failed, this area will be

blank.

Data which has become invalid due to the changing of the scope or optimization compilation is displayed

together with a “?”.

The contents of changes are written to the target by pressing the  Enter  key.  The contents prior to the

change can be erased using the  ESC  key.
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If the display size of variables, or assembler bit symbols or registers, etc. in the C language is fixed, the

display size cannot be selected.

Function buttons

Opens the Add Watch dialog box.

In the Add Watch dialog box, if the data is specified and the  button is

clicked, the specified data is added to the Watch window.

Deletes the specified data from the watch window.  The  DEL  key also performs this

operation.

Moves the selected data one line up.

Moves the selected data one line down.

Updates the contents of the window with the latest data.

Closes the Watch window.



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14910EJ1V0UM00200

Quick Watch Dialog Box

General

Temporarily displays and changes specified data.

Opening method

This dialog box can be opened by one of the following methods.

• In the main window

Select [View] → [Quick Watch…] from the menu bar.

Press the  GRPH  +  V , and  Q  keys in that order.

• In the Source window

Click the  button in the Source window.

Press the shortcut keys  CTRL  +  W .

• In the Assemble window

Click the  button in the Assemble window.

Press the shortcut keys  CTRL  +  W .

Window

Figure 6-44.  Quick Watch Dialog Box

(5) Display size select area(4) Display radix select area

(1) Symbol
specification
area

(2) Symbol name display area

(6) Display item number
specification area

(3) Data value display/setting area
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Function

Temporarily displays and changes specified data.

The boundary between the symbol name display area and the data value display/setting area can be moved to the

left or right using the mouse.  To move the boundary, drag the mouse cursor at the point when it changes from “ ” to

“↔”.

The Quick Watch dialog box consists of the following areas.

• Symbol specification area

• Symbol name display area

• Data value display/setting area

• Display radix select area

• Display size select area

• Display item number specification area

The function of each area is explained below.

(1) Symbol specification area

This area specifies the data to be displayed.

In the default setting, the string selected in the accessed window is displayed, but as necessary, it is also

possible to change it by inputting from the keyboard.  However, if the selected string does not exist, this area

becomes blank.

By clicking the  button and displaying the input history, the contents input previously can be reused.  Up to

16 items of input history can be retained.

When the contents of the symbol specification area have been changed, clicking the  button

causes the data specified in the symbol specification area to be displayed in the symbol name display area

and data value display/setting area.

(2) Symbol name display area
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This area displays the variable names or symbol names.  The display contents are the same as in the Watch

window.

However, data which has becomes invalid due to changes in the scope or optimization compilation is not

displayed.

(3) Data value display/setting area

This area displays the data values.

The display contents and the way to change the contents are the same as in the Watch window.

(4) Display radix select area

This area selects the radix to be displayed.

(5) Display size select area

This area selects the size to be displayed.

(6) Display item number specification area

This area specifies the number of data items to be displayed.

Specify blank or a number from 1 to 256.  The default is blank.

If blank, the data is displayed as a simple variable.  If a number 1 or greater is specified, it is displayed as an

array variable.  In this case, a “+” is displayed in front of the data.  By double-clicking this data, all the

elements of the data are expanded and displayed in accordance with the data type.  “+” of the expanded and

displayed data changes to “–”.  Double-clicking in this state cancels the expanded display.

If the display number of variables, or assembler bit symbols or registers, etc. in the C language is fixed, the

display number cannot be specified.
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Function buttons

Displays the data specified in the symbol specification area in the symbol name display area

and the data value display/setting area.

Adds the data specified in the symbol specification area to the Watch window.

Closes this dialog box.

Change contents that have not actually been written to the target are erased.
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Add Watch Dialog Box

General

Registers data to be displayed in the Watch window.

Opening method

This dialog box can be opened by either of the following methods.

• In the main window

Select [View] → [Add Watch…] from the menu bar.

Press the  GRPH  +  V , and  W  keys in that order.

• In the Watch window

Click the  button in the Watch window.

Window

Figure 6-45.  Add Watch Dialog Box

Functions

The Add Watch dialog box consists of the following areas.

• Symbol specification area

• Display radix select area

• Display size select area

• Display item number specification area

The function of each area is explained below.

(1) Symbol specification
area

(2) Display radix
select area

(4) Display item number specification area

(3) Display size
select area
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(1) Symbol specification area

This area specifies the data to be viewed in the Watch window.

In the default setting, the string selected in the accessed window is displayed, but as necessary, it is also

possible to change it by inputting from the keyboard.  However, if the selected string does not exist, this area

becomes blank.

By clicking the  button and displaying the input history, the contents input previously can be reused.  Up to

16 items of input history can be retained.

The expressions that can be used for inputting data are as shown below.

• C language variable name (Variable expression:  Variable name)

Variable expression [decimal constant values]: Array elements

Variable expression. Member name: Structure/union actual member

Variable expression → Member name: Member of structure/union that indicates a pointer

*Variable expression: Value of pointer variable

• Register name

• SFR name, SFR bit name

• Label, EQU and immediate address

• Register name.bit

• Label name.bit, EQU symbol name.bit, immediate address.bit

• Bit symbol

(2) Display radix select area

This area selects the display radix.

The display radix can be selected from among the following.

Proper: In the case of a variable, the value specified for each variable is displayed.

In the case of a symbol, it is displayed in the radix set in the Debugger Option dialog box.

Hex: Displayed in hexadecimal (XXXH).

Dec: Displayed in decimal (XXXT).

Oct: Displayed in octal (XXXQ).

Bin: Displayed in binary (XXXY).

String: Displayed as a character string.
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(3) Display size select area

This area selects the display size.

The display size can be selected from among the following.

Adaptive: In the case of a variable, the value specified for each variable is displayed.

In the case of a symbol, the size set in the Debugger Option dialog box is displayed.

Byte: Displayed in 8 bits.

Word: Displayed in 16 bits.

Double word: Displayed in 32 bits.

If the display size of variables, or assembler bit symbols or registers, etc. in the C language is fixed, the

specified size is displayed in the Watch window regardless of the specified display size.

(4) Display item number specification area

This area specifies the number of data items to be displayed.

Specify blank or a number from 1 to 256.  The default is blank.

If blank, the data is displayed as a simple variable.  If a number 1 or greater is specified, it is displayed as an

array variable.  In this case, a “+” is displayed in front of the data.  By double-clicking this data, all the

elements of the data are expanded and displayed in accordance with the data type.  “+” of the expanded and

displayed data changes to “–”.  Double-clicking in this state cancels the expanded display.

If the display number of variables, or assembler bit symbols or registers, etc. in the C language is fixed, the

display number cannot be specified.

Function buttons

Adds the specified data to the Watch window.  Does not close the Add Watch dialog box.

Adds the specified data to the Watch window and closes the Add Watch dialog box.

Closes the Add Watch dialog box.

Returns the input data to its original form.

Opens the help window.
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Register Window

General

This window displays and changes the contents of the registers (general-purpose registers and control registers).

Opening method

This window can be opened by the following methods.

•  In the main window

Select [Browse] → [Register] from the menu bar.

Press the  GRPH  +  B , and  R  keys in that order.

Click the  button on the toolbar.

Window

Figure 6-46.  Register Window

Function

Displays and changes the contents of registers (general-purpose registers and control registers).

The register to be displayed can be selected in the Register Select dialog box.

The Register window can be opened only in the active state.



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14910EJ1V0UM00208

The Register window consists of the following areas.

• Register bank setting area (ID78K0-NS only)

• General-purpose register display area

• Control register display area

The boundary line between the general-purpose register display area and control register display area can be

moved up or down using the mouse.  To move the boundary, drag the mouse cursor at the point when it changes from

“ ” to “↔”.

The function of each area is explained below.

(1) Register bank setting area

This area displays and sets the bank number of the general-purpose registers.

Item Description

Register Bank: Displays and sets the register bank displayed in the general-

purpose register display area. Changing the bank number is

performed using the  button.

Current Bank: Displays the register bank number currently set to the target

(current bank).

(2) General-purpose register display area

This area displays or changes the contents of the registers with the bank number displayed by Register Bank:

in the register bank setting area. The contents can be written to the target memory by pressing the  Enter    

key.  The contents prior to the change can be erased using the  ESC  key.

This area also functions as a jump pointer for the jump function in addition to displaying/changing general-

purpose registers.  Operation of the jump function is the same as in the case of the control registers.

General-purpose registers are displayed as absolute names or function names, which can be switched using

an item in the View menu displayed or the menu bar.
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(3) Control register display area

This area displays or changes the contents of the control registers.  The contents can be written to the target

memory by pressing the  Enter  key.  The contents prior to the change can be erased using the  ESC  key.

The flag names and flag values of the register to which “+” is prefixed are displayed by double-clicking the

register name.  “+” then changes to “−”.  Switching can also be done by selecting a register name using the

arrow keys then pressing the  Enter  key.

In addition, this area also functions as a jump pointer for the jump function.

The jump function is a function to jump to the Source window, Assemble window, Memory window, or

Coverage window by using a selected control register value as a jump pointer.  The jump destination window

displays the jump pointer at the beginning.

This function is executed by performing the following operations in sequential order.

<1> Select the control register.

<2> Perform one of the following operations in the main window.

• If the jump destination window is the Source window.

Select [Jump] → [Source] from the menu bar.

Press  GRPH  +  J , and  S  keys in that order.

Press the shortcut keys  CTRL  +  U .

• If the jump destination window is the Assemble window.

Select [Jump] → [Assemble] from the menu bar.

Press  GRPH  +  J , and  A  keys in that order.

Press the shortcut keys  CTRL  +  D .

• If the jump destination window is the Memory window.

Select [Jump] → [Memory] from the menu bar.

Press  GRPH  +  J , and  E  keys in that order.

Press the shortcut keys  CTRL  +  M .

• If the jump destination window is the Coverage window.

Select [Jump] → [Coverage] from the menu bar.

Press  GRPH  +  J , and  C  keys in that order.

Press the shortcut keys  CTRL  +  I .

When the memory bank is used, the address width of the PC changes.
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Function buttons

Updates the contents of the window with the latest data.

Closes the Register window.
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SFR Window

General

This window displays and changes SFRs. The I/O ports set in the Add I/O Port dialog box can also be displayed

and changed.

Opening method

This window can be opened by the following methods.

• In the main window

Select [Browse] → [SFR] from the menu bar.

Press the  GRPH  +  B , and  F  keys in that order.

Click the  button in the tool bar.

Window

Figure 6-47.  SFR Window

Function

Displays and changes the contents of the SFRs. Note, however, that values cannot be changed for read-only

SFRs.

Also, SFRs that cause the device to operate when read are read-protected and cannot therefore be read. When

reading such SFRs, select the SFR to be read and execute [View] → [Compulsion read] from the menu bar.

The I/O ports set in the Add I/O Port dialog box can also be displayed and changed.

The operation for read-only or read-protected I/O ports is the same as that for SFRs.
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The SFR window consists of the following areas.

• SFR name display area

• Attribute display area

• Contents of SFR display area

The function of each area is explained below.

(1) SFR name display area

This area displays the SFR and I/O port names.

When the I/O port address is an undefined value, the I/O port name is dimmed.

(2) Attribute display area

This area displays the read/write attribute, access type, and absolute address of the SFR name or I/O port.

Whether to display or not display the attribute display area can be selected using [View] → [Attribute] from the

menu bar.
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The types of read/write attributes are as follows.

Attribute Meaning

R Read-enabled SFR or I/O port

W Write-enabled SFR or I/O port

R/W Read-/Write-enabled SFR or I/O port

The access types are as follows.

Access Type Meaning

1 Bit-access-enabled SFR

8 Byte-access-enabled SFR or I/O port

16 Word-access-enabled SFR or I/O port

(3) Contents of SFR display area

This area displays and changes the contents of the SFRs or I/O ports. This area is displayed as follows

depending on the attribute of the SFR or I/O port.

• Read-enabled SFR or I/O port: Displayed in black

• Write-enabled SFR or I/O port: Displayed with “—-”

• Read-/Write-enabled SFR or I/O port: Displayed in black

• SFR or I/O port with values that change when read: Displayed with “**”

The changed contents are written to the target by pressing the  Enter  key. The contents before change can

be erased with the  Esc  key. The value of an SFR or I/O port which is protected from reading can be read by

executing [View] → [Compulsion read] from the menu bar.
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Function buttons

Updates the contents of the window with the latest data.

Closes the SFR window.
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SFR Select Dialog Box

General

Selects SFRs or I/O ports that are not displayed in the SFR window.

Opening method

This dialog box can be opened by the following methods when the current window is the SFR window.

•  In the main window

Select [View] → [Select…] from the menu bar.

Press the  GRPH  +  V , and  E  keys in that order.

Window

Figure 6-48.  SFR Select Dialog Box

Function

The SFR Select dialog box consists of the following areas.

• Display SFR select area

• Display order specification button

• No display list display order change button

The function of each area is explained below.
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(1) Display SFR select area

Select the SFRs or I/O ports that are to be displayed in the SFR window, and the SFRs or I/O ports that are

not to be displayed.

The SFRs or I/O ports displayed in the SFR window are shown on the [Display:] list, and the SFRs or I/O

ports not displayed are shown on the [No Display:] list.  The SFRs or I/O ports displayed or not displayed in

the SFR window can be changed by selecting an SFR or I/O port name from these lists and by clicking the  

<< Show   or   Hide >>   button.  If all the SFRs or I/O ports are to be displayed, click the

  << Show All   button.  If all the SFRs or I/O ports are to be hidden, click the   Hide All >>   button.  The

function of each button is explained below.

    << Show    Moves the SFR or I/O port selected in the [No Display:] area to the [Display:] list

area.

    Hide >>      Moves the SFR or I/O port selected in the [Display:] list area to the [No Display:]

area.

 << Show All Moves all the SFRs or I/O ports to the cursor position in [Display:].

  Hide All >>  Moves all the SFRs or I/O ports to [No Display:].

Two or more SFRs or I/O ports can be selected by clicking the mouse while holding down the control key or

the shift key when selecting an SFR or I/O port from the [Display:] list or [No Display:] list.
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(2) Display order specification button

This button sets the display order in the [Display:] list. The SFR or I/O port selected in the [Display:] list is

moved to the top of the list with the  button, and to the bottom with the  button. It is

also moved up one line with the  button and down one line with the  button.

The function of each button is as follows.

Moves the SFR or I/O port selected in the [Display:] list to the top of the list.

Moves the SFR or I/O port selected in the [Display:] list up one line in the list.

Moves the SFR or I/O port selected in the [Display:] list to down one line in the list.

Moves the SFR or I/O port selected in the [Display:] list to the bottom of the list.

(3) Display order of non-display list change button

This button selects the display order in the [No Display:] list. SFRs or I/O ports are displayed in alphabetical

order using the  button and in address order using the  button.

The function of each button is as follows.

Displays the list in [No Display:] in alphabetical order.

Displays the list in [No Display:] in address order.

Function buttons

Reflects the result of selection and specification of display order in the SFR window and closes the

SFR Select dialog box.

Cancels the change and closes this dialog box.

Cancels the change and restores the original setting.

Opens the help window.
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Add I/O Port Dialog Box

General

Registers an I/O port to be added to the SFR window.

Opening method

This dialog box can be opened by either of the following methods.

•  In the main window

Select [Option] → [Add I/O Port] from the menu bar.

Press  GRPH  +  O , and  P  keys in that order.

Window

Figure 6-49.  Add I/O Port Dialog Box

Function

The Add I/O Port dialog box consists of the following areas.

• I/O port select area

• I/O port name specification area

• I/O port address specification area

• Access size specification area

• Access attribute specification area

The function of each area is explained below.

(2) I/O port name specification area (3) I/O port address specification area(1) I/O port select area

(4) Access size specification area (5) Access attributes specification area
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(1) I/O port select area

This area displays a list of the currently entered I/O ports.  If a new I/O port is entered, it is added to this list.

An I/O port that has already been entered can also be selected and changed or deleted.

(2) I/O port name specification area

This area specifies the name of the I/O port to be added.

An I/O port name with up to 15 characters can be specified.

(3) I/O port address specification area

This area specifies the I/O port address to be added.

Addresses can be specified using symbols or expressions.  The specification method is the same as in the

case of the Address Move dialog box.

The default radix when inputting numerical values is hexadecimal.

(4) Access size specification area

This area specifies the access size of the added I/O port.

Byte: 8 bits (default)

Word: 16 bits

Word access can be specified only for SFRs or external SFRs.
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(5) Access attribute specification area

This area specifies the access attributes of the added I/O port.

Read Only: Sets exclusive read only.

Write Only: Sets exclusive write only.

Read Protect: Sets read protect.

In the default (all unchecked state), read and write are both enabled.

Function buttons

Reflects the add results in the SFR window and closes the Add I/O Port dialog box.

Cancels the change and closes this dialog box.

Cancels the change and restores the original state.

Opens the help window.

Adds the I/O port with the specified address.

Changes the settings for the selected I/O port.

Deletes the selected I/O port.
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Local Variable Window

General

This window displays or changes the local variable in the current function.

Opening method

This window can be opened by the following methods.

•  In the main window

Select [Browse] → [Local Variable] from the menu bar.

Press the  GRPH  +  B , and  L  keys in that order.

Click the  button on the toolbar.

Window

Figure 6-50.  Local Variable Window

Function

Displays or changes the local variable.

This window automatically displays the local variable in the current function.  Variables cannot be added or deleted.

The boundary line between the local variable name display area and local variable value display/setting area can

be moved to the left or right by the mouse. The boundary can be moved by dragging when the mouse cursor changes

from “ ” to “↔”.

(1) Local variable name display area

(2) Local variable value display/setting area
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The Local Variable window consists of the following areas.

• Local variable name display area

• Local variable value display/setting area

The function of each area is explained below.

(1) Local variable name display area

This area displays local variable names.

The type and variable name are shown.  These are displayed in the same way as in the Watch window.  Also,

it is possible to have an expansion display like in the Watch window.  However, variable names that have

become invalid due to optimization compilation, etc., are not displayed.

The auto variable, internal static variable and the register variable can be displayed.

(2) Local variable value display/setting area

This area displays/changes local variable values.

The variable value is displayed in the same way as in the Watch window.

Change contents are written to the target by pressing the  Enter  key.  The contents prior to the change can

be erased using the  ESC  key.

Function buttons

Updates the contents of the window with the latest data.

Closes this window.
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Stack Window

General

This window displays and changes the current stack contents of the user program.

Opening method

This window can be opened by the following methods.

•  In the main window

Select [Browse] → [Stack Trace] from the menu bar.

Press the  GRPH  +  B , and  K  keys in that order.

Click the  button on the toolbar.

Window

Figure 6-51.  Stack Window

(1) Stack frame number display area

(2) Stack frame contents display area (3) Stack contents display/setting area
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Function

Displays and changes the stack contents.

If the full traced contents cannot be displayed, a vertical scroll bar is displayed so that the contents can be scrolled.

The boundary between the stack frame contents display area and the stack contents display/setting area can be

moved to the left or right by the mouse.  To move the boundary, drag the mouse cursor at the point when it changes

from “ ” to “↔”.

This window has an active state only.

This window consists of the following areas.

• Stack frame number display area

• Stack frame contents display area

• Stack contents display/setting area

The function of each area is explained below.

(1) Stack frame number display area

This area displays the stack frame numbers.

The stack frame number is a natural number starting from 1, and the shallower the stack nest is, the larger

this number becomes.  A stack number that is 1 larger than a certain function is the calling function of that

function.

(2) Stack frame contents display area

This area displays the stack frame contents.

The function or local variable names are displayed.

If the stack contents are functions, they is displayed by [Program name $ File name # Function name (Index

list) # Line no.].  The delimiter between the program name and the file name is a “$” and the delimiter

between the file name and the function name is a “#”.  The “#” is also used as the delimiter between the

function name and the line no.  If there are local variables in a function, the local variables are displayed on

the following and subsequent lines.
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If the contents of the stack are local variables, the type and variable name is displayed.  They are displayed in

the same way as in the Watch window.  Whether to display or not display the variable type can be set in the

Debugger Option dialog box.  Note that internal static variables and register variables other than current

functions are not displayed.

(3) Stack contents display/setting area

This area displays and changes the contents of the stack.  “–” or local variable values are displayed.  If the

stack contents are functions, a “–” is displayed and the contents cannot be changed.

If the stack contents are local variables, the variable values are displayed.  Variable values are displayed in

the same way as in the Watch window.  It is possible to change variable values.

Changed contents are written to the target by pressing the  Enter  key.  The contents prior to the change can

be erased using the  ESC  key.

Other than displaying the stack contents, this area has the following functions.

(a) Jump function

Jumps to the Source window, Assemble window, Memory window, or Coverage window by using the

function indicated by the stack frame number at the cursor as a jump pointer.  The jump destination

window displays the jump pointer at the beginning.

This function is executed by performing the following operations in the sequential order.

<1> Position the cursor in the stack contents display/setting area.

<2> Perform one of the following operations on the main window.

• If the jump destination is the Source window

Select [Jump] → [SourceText] from the menu bar.

Press the  GRPH  +  J , and  S  keys in that order.

Press shortcut keys  CTRL  +  U .

• If the jump destination is the Assemble window

Select [Jump] → [Assemble] from the menu bar.

Press the  GRPH  +  J , and  A  keys in that order.

Press shortcut keys  CTRL  +  D .

• If the jump destination is the Memory window

Select [Jump] → [Memory] from the menu bar.

Press the  GRPH  +  J , and  E  keys in that order.

Press the shortcut keys  CTRL  +  M .
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• If the jump destination is the Coverage window

Select [Jump] → [Coverage] from the menu bar.

Press the  GRPH  +  J , and  C  keys in that order.

Press the shortcut keys  CTRL  +  I .

Details of the jump destination are as follows.

Type of Function Description of Operation

Function with the shallowest

nest (in the case of the current

function)

• If the jump destination is the Source window, it jumps to the

current PC line.

• If the jump destination is other than the Source window, it jumps

to the current PC address.

Functions with nests below

(in the case of a function other

than the current function)

• If the jump destination is the Source window, it jumps to the line

where the function nested below is called.

• If the jump destination is other than the Source window, it jumps

to the next address of the instruction that is calling the function

nested below.

Function buttons

Updates the contents of the window with the latest data.

Closes this window.

Cautions

(1) If the stack trace display function has a function that does not push the frame pointer (HL) to a stack

frame (such as the noauto or norec function) or the -qf option is added as an optimization option

when compiling, it may not be displayed correctly.

(2) [ERROR] may be displayed during function prologue processing or epilogue processing.
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Trace View Window

General

This window displays the trace results.

Opening method

This window can be opened by the following methods.

•  In the main window

Select [Browse] → [Trace] from the menu bar.

Press the  GRPH  +  B , and  T  keys in that order.

Click the  button on the toolbar.

Window

Figure 6-52.  Trace View Window

Function

Displays the trace results.

The contents can be scrolled by the vertical scroll bar.  It is also possible to move up one page or down one page

using the  button or  button.

There are two modes in the Trace View window, the normal display mode and the mixed display mode.

• Normal display mode: Displays the trace results only.

• Mixed display mode: Displays the source file together with the trace results.
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The Trace View window can be opened only in the active state and the window’s display is updated during a break

or step execution.

The tracer has a ring structure.  For that reason, if data exceeding a valid frame is written, the oldest data is

overwritten.  Also, in the display, the frames are displayed in frame order with the oldest data as frame 0.

Block information is written to the tracer between the end of one execution of the user program and the beginning

of the next one.  A horizontal line is displayed indicating the block information display in each display area.  Block

information is written in the following cases, depending on the previous and subsequent execution mode.

Previous Execution Mode Execution Mode This Time

Real-time execution When executing real-time execution

When executing step execution

Step execution When executing real-time execution

When executing step execution after changing execution address

To clear the trace contents, select [Option] → [Trace Clear] .

Note that, operation with respect to a tracer during program execution is performed by selecting [Run] → [Tracer

Start/Close] (this is possible only when executing with a break ignored).

The Trace View window consists of the following areas.

• Point mark display area

• Trace mode display area

• Trace result display area

The function of each area is explained below.

(1) Point mark display area

This area displays the setting states of various events.  If an execution event or fetch event (access

operation) is set to the corresponding trace address, the mark corresponding to the type of the event is

displayed.

Note that the marks displayed are not marks from tracing but are event marks set when the trace results are

displayed.
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Mark Meaning

E Shows that an event condition is set.

L Shows that the final level of an event link is set.

B Shows that a break event is set.

T Shows that a trace event is set.

Ti Shows that a timer event is set.

S Shows that a snapshot event is set.

A Shows that two or more events are set.

MNote Shows that a DMM event is set

Note ID78K0S-NS only.

(2) Trace mode display area

This area displays the type of trace mode.

The display contents are as follows.

A:  All traces or section-traced frames

Q:  Qualify-traced frames

S:  Step execution frames

T:  Delay trigger frames

“T” is displayed for all the frames in which a delay trigger is generated.

“Q” is displayed when the qualify trace condition is met while the section trace condition has been met.

(3) Trace result display area

This area displays the trace results.  If this area is selected, the jump function and the window linking function

can be used.

The following contents are displayed in the trace results display area.  Note that display or non-display of

each area can be selected in the Trace Data Select dialog box.
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• Trace frame number display

• Time tag displayNote

• Fetch access display

• Data access display

• External sense data displayNote

• Mnemonic display

Note Valid only when the IE-78K0-NS-PA is installed in the IE-78K0-NS or the IE-78K0-NS-A/IE-

78K0S-NS-A is used.

(a) Trace frame number display (Frame)

This is where the trace frame number is displayed.

(b) Time tag display (Time)

Displays the clocks required for the target chip from the start of execution of the previous trace contents

to the start of execution of the current trace contents.

This is valid only when the IE-78K0-NS-PA is installed in the IE-78K0-NS or the IE-78K0-NS-A/IE-78K0S-

NS-A is used.

The count division rate can be changed in the Extended Option dialog box.

The Trace Data Select dialog box can select the display or non-display of the time tag.

The time tag display can be switched between clock count display and time display.

Time Tag ValueNumber of

Clocks
Division Ratio 1 Division Ratio 2 Division Ratio 4 Division Ratio 8

1 1 1 1 1

2 2 2 2 2

3 3 2 2 2

4 4 3 2 2

5 5 3 2 2

6 6 4 3 2

7 7 4 3 2

8 8 5 3 2

9 9 5 3 2
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(c) Fetch access display (Address Data Status)

This is where the fetch results of the program and the snap contents are displayed.  This field is

displayed as follows depending on the status displayed in the status display field (Status).

Item Display Contents

M1 Program fetch display (the first byte fetch of the instruction)

OP Program fetch display (2nd and subsequent op code fetch)

IF Program fetch display (invalid fetch or status unknown)

SNAPNote Snap display

Status

Other than

above

No display (blank)

Note Valid only when the IE-78K0-NS-PA is installed in the IE-78K0-NS or the IE-78K0-NS-A/IE-78K0S-

NS-A is used.

In the case of the program fetch display, the display is as follows.

Item Display Contents

Address Fetch address display

Data Fetch data display

Note that display/non-display of fetch operation access can be selected in the Trace Data Select dialog

box.

In the case of the snap display, the display is as follows.

Item Snap Type Display Contents

Register Register name

SFR SFR name

Address

Memory Memory address

Register Register name

SFR SFR name

Data

Memory Memory contents

(d) Data access display (Address Data Status)

This is where the data access results are displayed.

Items Display Contents

VECT Vector read

R Data read

Status

W Data write

Address Address display

Data Data display
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(e) External sense data display (Ext Probe)

This is where the input level of the external sense clip at trace time is displayed.

This is valid only when the IE-78K0-NS-PA is the IE-78K0-NS-PA is installed in the IE-78K0-NS or the IE-

78K0-NS-A/IE-78K0S-NS-A is used.

The correspondence of each bit is as follows.

External Sense Data Display External Sense Clip Number

bit 15 NO.16

bit 14 NO.15

bit 13 NO.14

bit 12 NO.13

bit 11 NO.12

bit 10 NO.11

bit 9 NO.10

bit 8 NO.9

bit 7 NO.8

bit 6 NO.7

bit 5 NO.6

bit 4 NO.5

bit 3 NO.4

bit 2 NO.3

bit 1 NO.2

bit 0 NO.1

Note that display/non-display of external sense data can be selected in the Trace Data Select dialog box.

(f) Mnemonic display (DisAsm)

This is where the disassemble result is displayed.

This is displayed only when the status of the fetch operation access display is M1.

In the trace results display area, the normal display mode and mixed display mode can be switched by

selecting [View] → [Mix] from the menu bar.

• Normal display mode

Normal display mode is the mode in which only the trace results are shown.

• Mixed display mode

Mixed display mode is the mode in which the source file is displayed in combination with the trace

results.

If the program code corresponds to the displayed program fetch address line, the source file line is

displayed before that trace results line.

When the load module is downloaded and symbol information is being read, the mixed display mode

becomes valid only in cases where fetch address, fetch data, fetch status, or disassemble results are

being displayed.
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Even in cases where [View] → [Mix] is selected on the menu bar and mixed display mode is selected, if

none of the above items is being displayed, the display is normal.

The source file line’s display color is changed and is highlighted in green.

The jump function and window link function are detailed below.

• Jump function

• Window link function

(i) Jump function

The jump function is executed by carrying out the following operations in order.

<1> Move the cursor to the jump source line.

<2> In the main window, do one of the following operations.

• If the jump destination window is the Source window

Select [Jump] → [Source] from the menu bar.

Press the  GRPH  +  J , and  S  keys in that order.

Press the shortcut keys  CTRL  +  U .

• If the jump destination window is the Assemble window

Select [Jump] → [Assemble] from the menu bar.

Press the  GRPH  +  J , and  A  keys in that order.

Press the shortcut keys  CTRL  +  D .

• If the jump destination window is the Memory window

Select [Jump] → [Memory] from the menu bar.

Press the  GRPH  +  J , and  E  keys in that order.

Press the shortcut keys  CTRL  +  M .

• If the jump destination window is the Coverage window

(The Coverage window is valid only when the IE-78K0-NS-PA is installed in the IE-78K0-NS or

the IE-78K0-NS-A/IE-78K0S-NS-A is used.)

Select [Jump] → [Coverage] from the menu bar.

Press the  GRPH  +  J , and  C  keys in that order.

Press the shortcut keys  CTRL  +  I .

The address used as the jump source changes according to the cursor position.

Cursor Position Jump Pointer

Access address display area Access addressNote

Access data display area Access addressNote

Access status display area Access addressNote

Other than above Fetch address

Note If the jump destination is the Source window or the Assemble window, the fetch address is made the

jump pointer.
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(ii) Window link function

The window link function can be used by carrying out the following operations in order.

<1> Make the Trace View window the current window and select the window to be synchronized with

from among the items in [View] → [Window Synchronize] on the menu bar

Items in [Window Synchronize] Linked Window

Source Source window

Assemble Assemble window

Memory Memory window

Coverage Coverage windowNote

Note Valid only when the IE-78K0-NS-PA is installed in the IE-78K0-NS or the IE-78K0-NS-A/IE-

78K0S-NS-A is used.

<2> Move the cursor to the synchronization origin line in the trace results display area in the Trace

View window.  If the window to be synchronized with is not open in the active state, it will open in

the active state.

<3> The trace results address selected in <2> is used as the pointer, and the linked contents are

displayed in the corresponding window selected in <1>, or the cursor is positioned there.

In the case of window linking, the address which is the link origin also changes as follows in accordance

with the cursor position.

Cursor Position Jump Pointer

Access address display area Access addressNote

Access data display area Access addressNote

Access status display area Access addressNote

Other than above Fetch address

Note If the linking destination is the Source window or the Assemble window, the fetch address is always

made the jump pointer.  Unlike the jump function, if the cursor’s position is moved in the Trace View

window, the cursor or the highlighted display in each linked window is also moved.
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Function buttons

Opens the Trace Search dialog box and searches trace results or performs pick up.

Search results are highlighted in the Trace View window.  In the pick up display modeNote, frames

which matched the search conditions are picked up and displayed.

This button cannot be selected when a snap frame is picked up and displayed.

Searches for the trace results that match the search conditions set in the Trace Search dialog

box in the backward direction from the cursor position frame (toward the top of the display).

This button cannot be selected in the pick up display.

Searches for the trace results that match the search conditions set in the Trace Search dialog

box in the forward direction from the cursor position frame (toward the bottom of the display).

This button cannot be selected in the pick up display.

Updates the contents of the window with the latest data.

Close this window.

Note The pick up display mode is when [View] → [Pick Up] → [Search] is selected or when

“Pick Up Search Frame” is selected in the Trace Data Select dialog box.
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Trace Search Dialog Box

General

Searches trace data.

If search frame pick up is specified from the [View] menu, or the Trace Data Select dialog box (pick up display

mode), pick up of trace data is executed.

Opening method

This dialog box can be opened by one of the following methods when the current window is the Trace View

window.

• In the main window

Select [View] → [Search…] from the menu bar.

Press the  GRPH  +  V , and  S  keys in that order.

• In the Trace View window

Click the  button.

Press the shortcut keys  CTRL  +  G .

Window

Figure 6-53.  Trace Search Dialog Box (1/2)

When pick up is not displayed

(1) Status select area (5) External sense data setting area

(2) Access size select area (6) Search conditions specification area

(3) Address setting area (7) Search direction specification area

(4) Data setting area (8) Search range specification area

(1)

(3)

(4)

(5)

(6)

(8)

(7)

(2)
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Figure 6-53.  Trace Search Dialog Box (2/2)

When pick up is displayed

Functions

Trace data is searched and picked up.

• If [View] → [Pick Up] → [Off] is selected from the menu bar, or [Pick Up Off] is selected in the Trace Data

Select dialog box, a trace data search is executed.

• If [View] → [Pick Up] → [Search] is selected from the menu bar, or [Pick Up Search Frame] is selected in the

Trace Data Select dialog box (pick up display mode), trace data pick up is executed.

Note that if pick up of a snap frame is specified from the menu bar or the Trace Data Select dialog box, the Trace

Search dialog box cannot be called.

The Trace Search dialog box consists of the following areas.

• Status select area

• Access size select area

• Address setting area

• Data setting area

• External sense data setting area

• Search conditions specification area

• Search direction specification area

• Search range specification area

The function of each area is explained below.
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(1) Status select area

This area sets and selects the status conditions.

The status conditions that can be specified are shown below.  It is possible to specify the status condition in

abbreviated form.  There is no distinction between uppercase and lowercase characters in the input status

condition.

Status Abbreviated Form Meaning

M1 Fetch M1 M1 fetch

R/W RW Data read/write (including R, W)

Read R Data read

Write W Data write

Vector Read VECT Vector read by an interrupt

All status ALL All of the above specifications (M1, RW, R, W, VECT)

If the status condition setting is omitted, all the frames become search objects.

(2) Access size select area

This area sets and selects the access size conditions.

By specifying the access size conditions, the access width for the data condition during a trace data search is

determined.

The access size conditions that can be specified are shown below.  It is possible to specify the access size

conditions in abbreviated form.  There is no distinction between uppercase and lowercase characters in the

input access size condition.

Size Abbreviated Form Meaning

Byte B Search is made with an 8-bit width as the data condition.

Search is made only during 8-bit access.

No Condition NC An access-size search is not executed.

Bit 1 Detection is carried out with a 1-bit width as the data condition.

Detection is carried out only during 8-bit access.
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When an op code fetch access event is specified as a status condition, the selection of Bit is not displayed.

Even if Bit or 1 is selected, an error will occur.

If Bit is specified as the access size condition, the search is made with a 1-bit width as the data condition.

However, due to emulator operation, access to the bit itself cannot be traced directly and the debugger

searches for a pseudo bit access by setting the address conditions and data conditions internally as follows.

Input Example Trace Search Setting

Address fe20.1 Address fe20

Data 1 Data 00000010B

Mask 11111101B

For that reason, for access to other bits in the same address, or even for access to all 8 bits in the same

address, if the values match the specified values (address, bit), trace data is searched for in accordance with

the specified status.

• If No Condition is specified, the data setting area is displayed in gray and input is not possible.

• If the access size condition setting is omitted, it is judged automatically from the address conditions and

data conditions and set.

• If a bit is set for the address condition, the condition becomes Bit.

• If 8 bits is set for the data condition, the condition becomes Byte.

• If the data condition specification is omitted, the condition becomes No Condition.

(3) Address setting area

This area sets the address condition.

The setting range is as follows.

(When a bank is not used)

Setting range: 0  ≤  Address value ≤  0xFFFF

0  ≤  Mask value ≤  0xFFFF

(When a bank is used)

Setting range: 0  ≤  Address value ≤  (nNote << 16) | 0xFFFF

0  ≤  Mask value ≤  (nNote << 16) | 0xFFFF

Note n is the maximum bank number used.

There are two types of address conditions: Address, where the address value is set, and Mask, where the

mask value for the address value is input.  The setting method is shown below.
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(a) Address

Input the lower address and higher address, in that order.

The following three types of settings are possible for the address condition.

<1> Point setting

For a point setting, set a value in the lower address only, or set the same value in both the lower

address and the higher address.  A mask setting can be made.

<2> Range setting

For a range setting, set values in the lower address and the higher address.  Mask settings cannot

be made.  Note that if the same value is input for the lower address and the higher address, it is

not handled as a range setting.  In this case, it becomes a point setting or a bit setting.

<3> Bit setting

For a bit setting, set a value in the lower address only, or set the same value in the lower address

and the higher address.  Specify the value in the address.bit format.  Mask settings cannot be

made.  The value of the bit that shows the bit position must be 0 ≤ bit ≤  7.

For the address value, it is possible to specify a symbol or an expression.  The specification method is

the same as in the Address Move dialog box.

The default radix when numerical values are input is hexadecimal.

If the address condition setting is omitted, detection of the address condition is not performed.

(b) Mask

Set the mask value for the address value.

When mask setting is made, for a bit with a mask value of 1, it doesn’t matter if the address value is 0 or

1.

Example 1. Address:  0x4000  to  0x4000 

Mask:  0xFF 

In this kind of setting, the conditions match up to addresses 0x4000 to 0x40FF.

2. Address:  0x4000  to  0x4000 

Mask:  0x101 

In this kind of setting, addresses 0x4000, 0x4001, 0x4100 and 0x4101 match the

conditions.

If the mask value setting is omitted, masking is not executed.

The default radix when numerical values are input is hexadecimal.

(4) Data setting area

This area sets the data condition.  The setting range is as follows.



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14910EJ1V0UM00 241

Access Size Condition Setting Range

Byte 0  ≤  Data value  ≤  0xFF

0  ≤  Mask value  ≤  0xFF

Bit Data value = 0, 1

Mask value = Cannot be specified.

There are two types of data conditions: Data, where the data value is set, and Mask, where the mask

value for the data value is set.  The setting method is shown below.

(a) Data

Specify the data value.

It is also possible to set a symbol or expression for the data value.  The specification method is the same

as in the case of the Symbol To Address dialog box, but the default radix when numerical values are

input is hexadecimal.

If the data condition setting is omitted, data conditions are not detected.

(b) Mask

Set the mask value for the data value.

When mask setting is made, for a bit with a mask value of 1, it doesn’t matter if the data value is 0 or 1.

Example 1. Data:  0x4000 

Mask:  0xFF 

In this kind of setting, the conditions match when the data value is 0x4000 to 0x40FF.

2. Data:  0x4000 

Mask:  0x101 

In this kind of setting, when the data are 0x4000, 0x4001, 0x4100, and 0x4101, they match

the conditions.

If the mask value setting is omitted, masking is not executed.

The default radix when numerical values are input is hexadecimal.

(5) External sense data setting area

The external sense data cannot be set in this version.
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(6) Search conditions specification area

This check box specifies whether to search the whole specified region or not when conducting a search.  With

the default, only the portion remaining in the range is searched.

Searches the remaining portion of the range (default).

Searches the whole range.

(7) Search direction specification area

Specify the search direction.

There are two search directions, an upward search and a downward search.

Up: Upward search.  This searches in the forward direction from the current cursor position (toward the

top of the display).

Down: Downward search.  This searches in the backward direction from the current cursor position (toward

the bottom of the display) (default).

(8) Search range specification area

This area specifies the frame number that is being searched for.  The specification method is the same as in

the case of the Trace Move dialog box, but the default radix during input of numerical values is decimal.



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14910EJ1V0UM00 243

Function buttons

Searches from the trace results in accordance with the specified conditions.

From the search results, the frames that match are highlighted in the Trace View window.

For a continuous search, click this button again.

Sets the specified conditions as the search conditions and closes the Trace dialog box.

Search is executed by the  and  buttons in the Trace View window.

Pick up the specified search data from the trace results in accordance with the conditions.

 (During Pick Only the frames that match the trace window conditions are displayed.  To change the

  Up Display) conditions and conduct pick up again, click this button again.

This closes the Trace Search dialog box.

This opens the help window that explains the Trace Search dialog box.
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Trace Data Select Dialog Box

General

Selects the items to be displayed in the Trace View window.

Opening method

This dialog box can be opened by the following methods when the current window is the Trace View window.

•  In the main window

Select [View] → [Select] from the menu bar.

Press the   GRPH  +  V , and  E  keys in that order.

Window

Figure 6-54.  Trace Data Select Dialog Box

Function

The Trace Data Select dialog box consists of the following areas.

• Trace display item select area

• Trace display radix select area

• Pick up select area

The function of each area is explained below.

(1) Trace display item select area (2) Trace display radix select area

(3) Pick up select area
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(1) Trace display item select area

This area selects the items to be displayed in the Trace View window.

The following items can be selected to be displayed or not displayed.

If there is a check mark, that area is displayed.

Frame: Frame no. display field

TimetagNote: Time tag display field

· Clock: Clock display (default)

· Time: Time display

Instruction Fetch Address: Fetch address display field

Instruction Fetch Data: Fetch data display field

Instruction Fetch Status: Fetch status display field

Memory Access Address: Access address display field

Memory Access Data: Access data display field

Memory Access Status: Access status display field

External ProbeNote: External sense data display field

DisAssemble: Disassemble display field

Note Valid only when the IE-78K0-NS-PA is installed in the IE-78K0-NS or the IE-78K0-NS-A/IE-78K0S-

NS-A is used.

(2) Trace display radix select area
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This area selects the radix to be displayed.  The display radix can be selected for the following items.

Instruction Fetch Data: Fetch data display field

Memory Access Data: Access data display field

External ProbeNote: External sense data display field

Note Valid only when the IE-78K0-NS-PA is installed in the IE-78K0-NS or the IE-78K0-NS-A/IE-78K0S-

NS-A is used.

The display radix can be selected from the following.

Hex: Displayed in hexadecimal

Dec: Displayed in decimal

Oct: Displayed in octal

Bin: Displayed in binary

(3) Pick up select area

This area selects the pick up conditions.

Pick Up Off: Pick up is not displayed.

Pick Up Search Frame: Picks up and displays frames which match the search conditions.

Pick Up Snap FrameNote 1: Picks up and displays snap frames.

Pick Up BRM1 FrameNote 2: Picks up and displays the first M1 fetch frame (BRM1) after a program branch.

Notes 1. Valid only when the IE-78K0-NS-PA is installed in the IE-78K0-NS or the IE-78K0-NS-A/IE-78K0S-

NS-A is used.

2.Cannot be selected in this version.

Function buttons

Reflects the result of selection in the Trace View window.

Closes this dialog box.

Cancels the change and restores the original setting.

Opens the help window.
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Coverage Window

(Only valid if the IE-78K0-NS-PA is installed in the IE-78K0-NS or the IE-78K0-NS-A/IE-78K0S-NS-A

is used)

General

This window displays the coverage result.

Opening method

This window can be opened by the following methods.

•  In the main window

Select [Browse] → [Coverage] from the menu bar.

Press the  GRPH  +  B , and  O  keys in that order.

Click the  button on the toolbar.

Window

Figure 6-55.  Coverage Window
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Function

Displays the coverage result.

The vertical scroll bar is displayed at all times and the contents can be scrolled.  It is also possible to move up one

page or down one page using the  button or  button.

The Coverage window has two states, the active state and the static state.

There can be only one Coverage window in the active state, but multiple windows can be opened in the static state

at the same time.

Active state: The Coverage window in the active state has a display position and contents which are

synchronized with the current PC value and which are updated automatically.  Also, in

addition to becoming a jump destination for the jump function, if it is synchronized with the

Trace View window, the Coverage window’s display is updated in synchronization with the

Trace View window.

The first Coverage window to be opened is in the active state.

Static state: When in the static state, the Coverage window’s contents are updated in synchronization

with the current PC value, but the display position does not move.  Also, it does not become

a jump destination and is not synchronized with the Trace View window.

If a Coverage window in the active state has already been opened, a new window is opened

in the static state.

Coverage measurement is enabled by selecting the check box in [Option] → [Coverage ON].  Note that operations

with respect to coverage measurement while a program is being executed are executed by [Run] → [Coverage

Start/Stop].

The Coverage window consists of the following areas:

• Address display area

• Coverage display area

The function of each area is explained below.

(1) Address display area

This area displays coverage addresses.
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(2) Coverage display area

This area displays the coverage result.

The symbols displayed in this area have the following meanings.

When in 1-byte display mode

Symbol Meaning

. Nothing has been executed.

X Execution only

R Read only

W Write only

A Read and write

$ Execute and read

# Execute and write

% All execution, reading, and writing have been performed.

When in 64-/1024-byte display mode

Symbol Meaning

. No execution, read, and write operations concerning the addresses
within the 64-/1,024-byte area were performed.

X All addresses in the 64-/1,024-byte area were executed.

R All addresses in the 64-/1,024-byte area were read.

W All addresses in the 64-/1,024-byte area were written.

A Reading and writing were executed at all addresses in the 64-/1,024-
byte area.

$ Execution and reading were performed at all addresses in the 64-/1,024-
byte area.

# Execution and writing were performed at all addresses in the 64-/1,024-
byte area.

% All execution, read, and write operations concerning all addresses within
the 64-/1,024-byte area were performed.

This area has two functions besides displaying the coverage results.
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(a) Jump function

Jumps to the Source window, Assemble window, or Memory window using the address at the cursor as a

jump pointer.  The jump destination window is displayed with the jump pointer at the beginning.

This function is executed by performing the following operations in sequential order.

<1> Position the cursor.

<2> Perform one of the following operations in the main window.

• If the jump destination is the Source window

Select [Jump] → [SourceText] from the menu bar.

Press the  GRPH  +  J , and  S  keys in that order.

Press shortcut keys  CTRL  +  U .

• If the jump destination is the Assemble window

Select [Jump] → [Assemble] form the menu bar.

Press the  GRPH  +  J , and  A  keys in that order.

Press shortcut keys  CTRL  +  D .

• If the jump destination is the Memory window

Select [Jump] → [Memory] from the menu bar.

Press the  GRPH  +  J , and  E  keys in that order.

Press shortcut keys  CTRL  +  M .

(b) Window link function

Uses the coverage results to show the linked relationship between the Trace View window and the

Coverage window.  The coverage results that are the target of linking with the Trace View window are

positioned by the cursor.  For details, refer to the Window link function of the Trace View window.

Function buttons

Opens the Coverage Search dialog box and searches for coverage results.

Search results are highlighted in the Coverage window.

This button can be selected when in 1-byte display mode only.

Searches the Coverage results which match the search conditions, and which have been set in the

Coverage Search dialog box, from the cursor position toward the beginning (toward the top of the

display).

This button can be selected when in 1-byte display mode only.

It changes to the  button during a search.

Searches the Coverage results which match the search conditions, and which have been set in the

Coverage Search dialog box, from the cursor position toward the end (toward the bottom of the

display).

This button can be selected when in 1-byte display mode only.

It changes to the  button during a search.
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Interrupt a search.

During a search, the  and  buttons change to the  button.

Updates the window’s contents with the latest data.

Closes this window.
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Coverage Search Dialog Box

General

Searches the coverage result.

This can be called only when in 1-byte mode display.

Opening method

This dialog box can be opened by the following methods when the current window is the Coverage window.

•  In the main window

Select [View] → [Search…] from the menu bar.

Press the  GRPH  +  V , and  S  keys in that order.

•  In the Coverage window

Click the  button.

Press the shortcut keys  CTRL  +  G .

Window

Figure 6-56.  Coverage Search Dialog Box
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Functions

Searches for coverage results.

Unmapped areas are not searched.

Also, searches cannot be performed when there are unmapped areas between areas to be searched.

The Coverage Search dialog box consists of the following areas.

• Search data specification area

• Search condition specification area

• Search direction specification area

• Search range specification area

The function of each area is explained below.

(1) Search data specification area

The search conditions can be specified from these 8 check boxes.  The meanings of the respective symbols

are as shown below.

Symbol Meaning

No Use [.] Nothing has been executed.

Read [R] Read only

Write [W] Write only

Read x Write [A] Read and write

Execute [X] Execute only

Execute x Read [$] Execute and read

Execute x Write [#] Execute and write

Execute x Read x

Write [%]

All execution, reading, and writing has been performed.

If multiple search conditions have been selected, whichever one of the conditions matches is searched (an

OR search).
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(2) Search condition specification area

This is a check box which specifies whether to search the whole specified region or not when conducting a

search.  With the default, only the portion remaining in the range is searched.

Searches the remaining portion of the range (default).

Searches the whole range.

(3) Search direction specification area

This area specifies the search direction.

There are two search directions, an upward search and a downward search.

Up: Upward search.  Searches the data from the current cursor position toward the beginning (upward

on display).

Down: Downward search. Searches the data from the current cursor position toward the end (downward on

display).

(4) Search range specification area

This area specifies the address that is being searched for.  Addresses can be specified using a symbol or

expression.  The specification method is the same as in case of the Address Move dialog box.  The default

radix during input of numerical values is hexadecimal.

Function buttons

Searches from the coverage results in accordance with the specified conditions.

For the search results, the frames that match are highlighted.

For continuous search, click this button again.

Sets the specified conditions as the searched conditions and closes this dialog box.

Interrupts a search.
During a search, the  button changes to the  button.

Closes the Coverage Search dialog box.
It changes to the  button during a search.
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Opens the help window that explains this dialog box.
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Coverage-Clear Dialog Box

General

Clears the coverage results.

Opening method

This dialog box can be opened by the following methods.

• In the main window

Select [Option] → [Coverage] → [Clear…] from the menu bar.

Press the  GRPH  +  O ,  O , and  L  keys in that order.

Window

Figure 6-57.  Coverage-Clear Dialog Box

Function

Clears the coverage measurement results in the specified address range.

It initializes the Coverage window and the contents in the Coverage-Efficiency View dialog box.

The Coverage-Clear dialog box consists of the following area.

• Address specification area

The function of this area is explained below.

(1) Address specification area

This area specifies the addresses in the coverage results to be cleared.  Addresses can also be specified

using symbols or an expression.  The specification method is the same as in the case of the Address Move

dialog box.  The default radix during input of numerical values is hexadecimal.
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Function buttons

Clears the coverage results in the address range specified by the address specification area and

closes the dialog box.

Interrupts clearing the coverage results.

During the coverage result clear operation, the  button changes to the  button.

Closes this dialog box.

It changes to the  button during the coverage result clear operation.

Cancels the change and restores the original setting.

Opens the help window.
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Coverage-Condition Setting Dialog Box

General

Specifies the coverage efficiency measurement range.

Opening method

This dialog box can be opened by the following methods.

•  In the main window

Select [Option] → [Coverage] → [Condition…] from the menu bar.

Press the  GRPH  +  O ,  O , and  O  keys in that order.

• Click the  button in the Coverage-Efficiency View dialog box.

Window

Figure 6-58.  Coverage-Condition Setting Dialog Box

Function

The Coverage-Condition Setting dialog box consists of the following areas.

• Select list display area

• Address specification area

• Function specification area

• Coverage condition specification area

(4) Coverage condition specification area

(1) Select list display
area

(2) Address specification
area

(3) Function specification
area
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The function of each area is explained below.

(1) Select list display area

Displays the currently selected lists.

Selected lists can be added by the following two methods.

(a) When adding from the function list

<1> Specify the status conditions in the status condition specification area.

<2> Select the function to be added to the function specification area and click the  button.

The specified function can be deleted from the list by using the  button.

Note It is meaningless to select an instruction other than Execute.

(b) When specifying and adding an address

<1> Specify the status conditions in the status condition specification area.

<2> Input the address range to the address specification area and click the  button.

The specified address range can be deleted from the list by using the  button.

(2) Address specification area

This area is used to input the coverage efficiency address range conditions.  Addresses can also be specified

by a symbol or expression.  The specification method is the same as in the case of the Address Move dialog

box.  The default radix during input of numerical values is hexadecimal.

(3) Function specification area

This area is used to input the coverage efficiency address conditions in function units or to select the function

name from the drop-down list.

Function names registered to the load module file are displayed.
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(4) Status condition specification area

This area selects the coverage efficiency status conditions.  The selectable status conditions are as follows:

Status Description

Execute Proportion of program execution performed.

Read Proportion of memory read performed.

Write Proportion of memory write performed.

All Proportion of either program execution, memory read or memory write performed.

Function buttons

Closes the Coverage-Condition Setting dialog box.

Displays the coverage efficiency.  Opens the Coverage-Efficiency View dialog box.

Cancels the changes and restores the original setting.

Opens the help window.

Clears the contents in the select list display area.

Deletes the function name or the address range specified in the select list display area from the

list.

Enters the function name specified in the function specification area or the address range

specified in the address specification area in the select list display area.
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Coverage-Efficiency View Dialog Box

General

Displays the coverage results in the range specified in the Coverage-Condition Setting dialog box as coverage

efficiency.

Opening method

This dialog box can be opened by the following methods.

•  In the main window

Select [Option] → [Coverage] → [Efficiency…] from the menu bar.

Press the  GRPH  +  O ,  O , and  E  keys in that order.

• Click the  button in the Coverage-Condition Setting dialog box.

Window

Figure 6-59.  Coverage-Efficiency View Dialog Box

Function

The Coverage-Efficiency View dialog box consists of the following areas.

• Coverage range display area

• Coverage efficiency display area

(1) Coverage range display area

(2) Coverage efficiency display area
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The function of each area is explained below.

(1) Coverage range display area

This area specifies the coverage efficiency measurement range.

The range specified in the Coverage-Condition Setting dialog box is displayed in this area.

If specified by a function name, it is displayed as “Program name $ File name # Function name.”

(2) Coverage efficiency display area

This area displays the coverage efficiency.

The coverage efficiency shows what percentage of the measurement range the specified status (execute,

read, write) occupies.

The status list is shown below.

Status Description

X Proportion of program execution performed.

W Proportion of memory write performed.

R Proportion of memory read performed.

All Proportion of either program execution, memory read or memory write performed.
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Function buttons

Closes the Coverage-Efficiency View dialog box.

Sets the displayed contents of the coverage efficiency.

Opens the Coverage-Condition Setting dialog box.

Opens the help window.
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Event Manager

General

This window displays, enables/disables and deletes various events.

Through manipulation in this window, the event conditions registered in the Event dialog box or Event Link dialog

box can be allocated to break events, trace events, snapshot events, DMM events, or timer events.

Opening method

This window can be opened by one of the following methods:

•  In the main window

Select [Event] → [Event Manager] from the menu bar.

Press the  GRPH  +  N , and  M  keys in that order.

Click the  button from the toolbar.

• In the Source window

Moves the cursor to the source line in the source text display area where the event is set, or to the

disassemble line in case of the mix display mode, and carry out either of the following steps:

Select [View] → [Event?] from the menu bar.

Press the  GRPH  +  V , and  E  keys in that order.

• In the Assemble window

Moves the cursor to the line in the mnemonic display/change area where the event is set, and carry out either

of the following steps:

Select [View] → [Event?] from the menu bar.

Press the  GRPH  +  V , and  E  keys in that order.

•  In the Event dialog box

Click the  button.

Press the shortcut keys  GRPH  +  G .

•  In the Set Other dialog box

Click the  button.

Press the shortcut keys  GRPH  +  M .
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Window

Figure 6-60.  Event Manager

In list display mode

In detailed display mode

Function

Displays, enables/disables, and deletes various events and manages event conditions for registering or setting

various event conditions (such as event link conditions, break event conditions, trace event conditions, snapshot event

conditions, DMM event conditions, and timer event conditions).

The Event Manager consists of the following areas.

• Event display area

• Event detail display area

The function of each area is explained below.

(1) Event display area

(1) Event detail display area(1) Event display area
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(1) Event display area

• In list display mode

• In detailed display mode

In the event display area, icons (event icons) for various types of event conditions of the registered event,

event link, break, trace, snapshot, DMM, and timer are displayed.

The icon of the event condition consists of a mark indicating the type of each event condition and an event

name.

The contents displayed in the event display area can be changed by the Event Info dialog box which is

opened by the [View] menu or the  button in the Event Manager.

The marks are listed below.

Mark Meaning

Indicates event condition

Indicates event link condition

Indicates break event

Indicates trace event

Indicates snapshot event

Indicates DMM event

Indicates timer event

The color of the character displayed in a mark indicates the setting status of each event condition.

Mark Event name

M.
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Character Color

in Mark

Corresponding Mark Meaning

 , 
Indicates that the event conditions using events and event

link conditions are valid.

Red

 ,  ,  ,  , 
Indicates that each event condition is “enabled”.  Each event

is generated when condition is satisfied.

 , 
Indicates that the event conditions using events and event

link conditions are invalid.

Black

 ,  ,  ,  , 
Indicates that an event is invalid.  The event does not occur

even if the conditions are established.

Yellow
 ,  ,  ,  ,  ,  ,

Indicates that the symbol specified in the event cannot be

recognized by the program that is currently loading, so it is

held pending.

In addition to the above function, this area also has the following four functions.

(a) Jump function

Jumps to the Source window, Assemble window, Memory window or Coverage window by using the

address condition of the selected icon as a jump pointer if the selected icon is the event condition.  The

jump destination window displays the jump pointer at the beginning.

If the address condition is a range setting, the lower address becomes the jump pointer.  If a mask is set,

the point address before the mask is executed becomes the jump pointer.

In the case of a bit setting, the address of the specified bit position becomes the jump pointer.

This function is executed by performing the following operations in sequential order.

<1> Select an icon (  ).

<2> Perform one of the following operations in the main window.

• If the jump destination is the Source window

Select [Jump] → [SourceText] from the menu bar.

Press the  GRPH  +  J , and  S  keys in that order.

Press shortcut keys  CTRL  +  U .

• If the jump destination is the Assemble window

Select [Jump] → [Assemble] from the menu bar.

Press the  GRPH  +  J , and  A  keys in that order.

Press shortcut keys  CTRL  +  D .

• If the jump destination is the Memory window

Select [Jump] → [Memory] from the menu bar.

Press the  GRPH  +  J , and  E  keys in that order.

Press shortcut keys  CTRL  +  M .

M.

M.

M.
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• If the jump destination is the Coverage window

Select [Jump] → [Coverage] from the menu bar.

Press the  GRPH  +  J , and  C  keys in that order.

Press shortcut keys  CTRL  +  I .

(b) Open function

Opens the setting dialog box corresponding to the selected icon’s event.  The contents of the selected

event are displayed in each setting dialog box that is opened.

This function is executed by performing one of the following operations.

<1> Double-click the icon.

<2> Select the icon, then click .

(c) Enabled state switching function

Switches the state of the event corresponding to the selected icon between enabled and disabled.

Except for an event and event link, it is possible to operate break, trace, snapshot, DMM and timer

events by icons.

This function is executed by performing one of the following operations.

<1> Click the left button of the mouse when the mouse cursor is on the icon mark.

<2> Select an icon and click  or , or press the  GRPH  +  Enter  keys.

If an event is in the enabled state, it becomes disabled (black), and if the event is in the disabled state, it

becomes enabled (red).

The  button is displayed when an icon in the disabled state is selected, and the 

button is displayed when an icon in the enabled state is selected.

(d) Delete function

Deletes registration/set contents of the event condition of a selected icon.

Multiple icons can be selected using the  SHIFT  and  CTRL  keys.

To select all the icons, select [View] → [Select All Event] from the menu bar.

However, an event condition  and event link condition  can be deleted only when that event

condition is not used by other event condition (  ,  ,  ,  , or  ).  If the event

condition or event link condition has already been used for any other event, delete the event used.

This function is executed by performing one of the following operations.

<1> Select an icon and perform one of the following operations in the main window.

Select [Edit] → [Delete Event] from the menu bar.

Press the  GRPH  +  E , and  D  keys in that order.

<2> Select an icon and perform one of the following operations in the Event Manager.

Click  button.

Press the  DEL  key.

M.



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14910EJ1V0UM00 269

(2) Event detail display area

This area is displayed only when the detailed display mode is selected.

This area displays the detailed information corresponding to the icon of each event.  This area displays the

contents of the status condition, access size condition, data condition, external sense data condition, and

pass count condition, in that order, by using the information of each key as a delimiter, when an event

condition is specified.  The following tables show the correspondence between the information of each key

and the condition.

• Event condition

Key Information Description

[S] Status condition

[Z] Access size condition

[A] Address condition

[D] Data condition

[E] External sense data condition

[M] Mask condition

• Event link condition

Key Information Description

[P1] to [P4] Event link condition of nth stage (n = 1 to 4)

[D] Disable condition

[P] Pass count condition

• Break condition

Key Information Description

[B] Break condition
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• Trace condition

Key Information Description

[M] Trace mode

[D] Delay count

[Q] Qualify trace condition

• Timer condition

Key Information Description

[S] Timer measurement start condition

[E] Timer measurement end condition

[U] Timer measurement unit

• Snapshot condition

Key Information Description

[SN] Snapshot condition

[R] Register condition

[B] Register bank condition

[M] Memory condition

[Z] Access size condition

[F] SFR condition

• DMM condition

Key Information Description

[DM] DMM condition

[A] Address condition

[D] Data condition

[Z] Data size condition

If the address condition of an event condition, a data condition, or the memory condition of a snapshot

condition is a symbol or an expression, the actual address is displayed within “(  )”.
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Function buttons

Opens the New Event dialog box.

In the New Event dialog box, by clicking each button, the setting dialog box for event, event

link, break, trace, snapshot, DMM and timer events can be opened.

Each setting dialog box that is opened has the new event name set in it.

After each setting dialog box is opened, the New Event dialog box is closed.
If  is clicked or the  ESC  key is pressed, the New Event dialog box closes and

the screen returns to the Event Manager.

Opens the setting dialog box corresponding to the event condition selected in the event

display area.  The event condition contents selected in the event display area are displayed

in the setting dialog box.

If the event condition has not been selected, or if multiple conditions are selected, this button

is dimmed and can no longer be clicked.

The  Enter  key also has the same operation.

Sets break, trace, snapshot, DMM and timer events in the enabled state.

The  button is displayed in place of the  button if one disabled event or

multiple events including only disabled events are selected.

Sets break, trace, snapshot, DMM and timer events in the disabled state.

The  button is displayed in place of the  button if one enabled event is

selected or multiple events including enabled events are selected.

If an event or an event link only is selected, this button is dimmed and it can no longer be

clicked.

Deletes the event condition selected in the event display area.

When deleting an event or event link, if that event is being used by a break, trace, snapshot,

DMM, timer or event link, it results in an error.  The  DEL  key also has the same operation.
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Delete All Deletes all the events whether they are enabled or disabled.

Opens the Event Info dialog box.

The  button rearranges events in name order and displays them.

The  button rearranges events by kind and displays them.

The  button displays the events in the order in which they were entered without

rearranging them.

The  button sets the display mode to the detailed display mode.

The  button sets the display mode to the list display mode.

The  button or the  ESC  key closes the dialog box.

Closes the Event Manager.
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Software Break Manager

General

This window displays, switches enable/disable, and deletes software breaks.

This window can be used only when the IE-78K0-NS-PA is installed in the IE-78K0-NS or the IE-78K0-NS-A/IE-

78K0S-NS-A is used.

Opening method

This window can be opened by the following methods.

• In the main window

Select [Event] → [Software Break Manager] from the menu bar.

Press the  GRPH  +  N  , and  M  keys in that order.

Window

Figure 6-61.  Software Break Manager

(1) Event name display area
(2) Break mark display area

(3) Break point display area
(4) Address display area

Function

Displays, switches enable/disable, and deletes software breaks. Up to 100 software break events can be valid

simultaneously.

Note that the setting of the software break point is not performed in this window, but in the Source window or

Assemble window.

(1)

(2) (3) (4)
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The software break manager consists of the following areas.

• Event name display area

• Break mark display area

• Break point display area

• Address display area

The function of each area is explained below.

(1) Event name display area

This area consists of check boxes to indicate the registered event name and valid/invalid status of the event.

To change the event name, edit directly after clicking the name to be changed. The name will be determined

by pressing the return key. [Swb + number] is displayed in this area as the default.

To validate the event, check the check box (as the default, the check box is checked for a newly created

event).

Also, double-clicking the event name makes it possible to jump to the window where the event was created

(the Source window/Assemble window).

Remark By clicking Name on the label, character strings of the displayed items are compared and

arranged in alphabetical order (ascending or descending can be switched by clicking).

(2) Break mark display area

This area displays the mark “>” for the software break event set at the current PC area to make it easy to

specify the software break event that has caused the break.
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(3) Break point display area

This area displays the location where the software break event is set in the following format.

File name # line number (when set in the Source window)

Symbol + offset (when set in the Assemble Text window)

Re-evaluating the event when redownloading symbols is performed based on the above.

Remark By clicking File#Line/Symbol+Offset on the label, character strings of the displayed items are

compared and arranged in alphabetical order (ascending or descending can be switched by

clicking).

(4) Address display area

This area displays addresses where software break events are set.

Remark By clicking Address on the label, values of the displayed items are compared and arranged in size

order (ascending or descending can be switched by clicking).  

Function buttons

Validates the event selected.

Invalidates the event selected.

Deletes the event selected.

Delete All Deletes all software break events set.

Closes the Software Break Manager window.
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Event Dialog Box

General

Registers and displays event conditions.

The event conditions created (registered) in this dialog box are automatically registered to the Event Manager.

Opening method

This dialog box can be opened by the following methods.

•  In the main window

Select [Event] → [Event…] from the menu bar.

Press the  GRPH  +  N , and  E  keys in that order.

Click the  button on the toolbar.

• Execute one of the following operations in the Break, Trace, Snap Shot, DMM, Timer or Event Link dialog

boxes.

Click the  button.

Press the shortcut keys  GRPH  +  E .

• Execute one of the following operations in the event setting area or the event manager area of the Break,

Trace, Snap Shot, DMM, Timer or Event Link dialog boxes.
Select the event condition and click .

Select the event condition and press the shortcut keys  GRPH  +  O .

Double-click the event condition.

• In the Event Manager, execute one of the following operations.
Select an event condition and click .

Double-click the event condition.

• Execute one of the following operations in the New Event dialog box or the Set Other dialog box.

Click the  Event…  button.

Press the shortcut keys  GRPH  +  E .
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Window

Figure 6-62.  Event Dialog Box

(1) Event name setting area (5) External sense data setting area

(2) Status select area (6) In-range/out-of-range break select area

(3) Address setting area (7) Event manager area

(4) Data setting area

(1)

(2)

(3)

(4)

(5)

(6)

(7)
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Function

This dialog box registers and displays event conditions.

Up to 256 conditions can be entered for event conditions.  However, the number of event conditions which can be

used simultaneously in enabled break, trace, snapshot, DMM and timer events is 8 execution events (or one event

link) and 4 access events.

When when the IE-78K0-NS-PA is installed in the IE-78K0-NS or the IE-78K0-NS-A/IE-78K0S-NS-A is used, the

number of event conditions that can be used simultaneously will increase by 8 for each.

The number of event conditions that can be used simultaneously is up to the number of event conditions given

above, but a single event condition can be set in multiple break, trace, snapshot, DMM, timer and event link events.

The Event dialog box has two modes, the normal mode and the select mode.

• Normal mode

When the  button from the toolbar or [Event] → [Event…] from the menu bar in the main window is

selected and the Event dialog box is opened, event conditions can be entered without restriction as to purpose.

This is the normal mode.

• Select mode

When the  button in the Break, Trace, Snap Shot, DMM, Timer and Event Link dialog boxes is

clicked and the Event dialog box is opened, the event conditions used by these are selected.  This is the select

mode.

In the select mode, when  is clicked, the event condition selected in the event name setting area of

the Event dialog box is set in the event condition setting area of the setting dialog box that originally called the

Event dialog box.

Even in the select mode, event conditions can be entered and displayed just as in the normal mode.

Depending on the mode, the title bar display on the dialog box will differ.  Refer to the section entitled [Title

Bar] described later on.

The Event dialog box consists of the following areas.

• Event name setting area

• Status select area

• Address setting area

• Data setting area

• External sense data setting area

• In-range/out-of-range break select area

• Event manager area

The function of each area is explained below.
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(1) Event name setting area

This area sets an event name and selects an event condition.

When entering an event condition, it is necessary to set an event name.  An event name may consist of up to

eight alphanumeric characters.

When displaying event conditions which have already been created, either type the name of the already

created event in the text box or select the event condition from the drop-down list in the event name setting

area.

Note that when moving to another event before completing an event setting, the data which was being set is

deleted.

In the select mode, the selected event condition can be set in the event condition setting area of the original

setting dialog box that called the Event dialog box.

The  mark on the left side of the event name setting area shows the use conditions of the event condition.

The relationship between the color of the character in the  mark and the status is shown below.

Color of Character in  Mark Condition

Red That event condition is being used by break, trace, snapshot, DMM,

timer or event link and indicates that it is enabled.

Black Indicates that that event condition has not been enabled.

Gray Indicates that that event condition is currently being edited and that it

has not been entered.

Yellow Indicates that that event is an event which is in the hold state.  An

event in the hold state is in a state where the symbol specified by the

event condition by program download, etc. cannot be referred to.

(2) Status select area

This area sets and selects a status condition.

By specifying the status condition, the distinction between the execution event and access event is decided at

the same time.  If execution event is specified, the access size select area, the mask field of the address

setting area and the data setting area are dimmed and are in a state where input is impossible.

The status conditions that can be specified are shown below.  It is possible to specify a status condition in

abbreviated form.

The input status condition is not case sensitive.
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Status Abbr. Event Type Meaning

Execution EX Program execution

Before Execution EX-B

Execution event

Program execution (break before execution)Note 1

R/W RW Memory read/write

Read R Memory read

Write W Memory write

External Trigger1 Trigger-1 External Trigger (1 bit)

External Trigger2 Trigger-2

Access event

External Trigger (ID78K0-NS: 8 bits,

ID78K0S-NS: 16 bits)Note 2

Notes 1. Valid only for products with new packages (IE-78K0-NS with a control code D or later or the IE-

78K0-NS-A (IE-78K0S-NS-A)).

2. Valid only when the IE-78K0-NS-PA is installed in the IE-78K0-NS or the IE-78K0-NS-A/IE-

78K0S-NS-A is used.

Multiple External Trigger1 or External Trigger2 statuses can be registered but only one can be enabled.

Multiple Before Execution statuses can be registered but up to 16 (15 in flash self mode) statuses can be

enabled.  Also, this status cannot be used as an other event condition.

This area is blank in the case of newly created event conditions.

(3) Address setting area

This area sets an address condition.

The setting range is as shown below.

(When a bank is not used)

Setting range: 0 ≤ Address value ≤ 0xFFFF

0 ≤ Mask value ≤ 0xFFFF

(When a bank is used)

Setting range: 0 ≤ Address value ≤ (nNote << 16) | 0xFFFF

0 ≤ Mask value ≤ (nNote << 16) | 0xFFFF

Note n is the maximum value of the bank number used.

Input the lower and higher addresses in that order.

The following three types of settings can be made when specifying an address condition.

<1> Point setting

Only the lower address or the same address value is set to the lower and higher addresses when a

point is set.  Masks can be set.
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<2> Range setting

A range is specified by the lower and higher addresses.

Note that if the same value is input for the lower address and the higher address, it is not handled as a

range setting.  In this case, it becomes a point setting or a bit setting.  Moreover, if an event condition

is changed during use and if there was a range setting prior to the change, there must be a range

setting after the change.  Similarly, if there was no range setting prior to the change, neither the

address condition nor the range setting can be changed.

<3> Bit setting

For a bit setting, set a value in the lower address only, or set the same value in the lower address and

the higher address.  Specify the value in the address.bit format.  The value of the bit that shows the bit

position must be 0 ≤ bit ≤  7.

For the address, it is possible to specify a symbol or an expression.  The specification method is the

same as in the Address Move dialog box.

The default radix when numerical values are input is hexadecimal.

This area is blank in the case of newly created event conditions.

(4) Data setting area

This area sets a data condition.

The setting range is as follows.

Access Size Condition Setting Range

Byte 0  ≤  Data value  ≤  0xFF

0  ≤  Mask value  ≤  0xFF

Bit Data value = 0, 1

Mask value = Cannot be specified

If the data condition setting has been omitted, data condition detection is not performed.

For a newly created event condition, the address value and the mask value input columns are both blank.

There are two types of data conditions: Data, which sets the data value, and Mask, which inputs the mask

value of the data value.  How to set each of these types is explained below.

(a) Data

Set a data value.

A data value can also be specified by a symbol or expression.  The specification method is the same as

in the case of the Symbol To Address dialog box, but the default radix when numerical values are input is

hexadecimal.
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(b) Mask

Set a mask value for the data value.

When mask setting is made, for a bit with a mask value of 1, it doesn’t matter if the data value is 0 or 1.

Example 1. Data:  0x4000

Mask:  0xFF

In this kind of setting, the conditions match when the data value is 0x4000 to 0x40FF.

2. Data:  0x4000

Mask:  0x101

In this kind of setting, when the data is 0x4000, 0x4001, 0x4100, and 0x4101, the

conditions are matched.

If the mask value setting is omitted, masking is not executed.

The default radix when numerical values are input is hexadecimal.

(5) External sense data setting area

This area sets the external sense data condition.

Setting range: 0 ≤  Data value ≤ 0xFFFF

0 ≤  Mask value ≤ 0xFFFE

The external sense data condition enables the input pin level of the external sense clip attached to the

emulation probe connected to the in-circuit emulator to be a search condition.

The correspondence between the external sense data and the external sense clip is as follows.

External Sense Data Display External Sense Clip Number

bit 15 NO.16

bit 14 NO.15

bit 13 NO.14

bit 12 NO.13

bit 11 NO.12

bit 10 NO.11

bit 9 NO.10

bit 8 NO.9

bit 7 NO.8

bit 6 NO.7

bit 5 NO.6

bit 4 NO.5

bit 3 NO.4

bit 2 NO.3

bit 1 NO.2

bit 0 NO.1



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14910EJ1V0UM00 283

The input pin level of the external sense clip is set to 1 for high level and 0 for low level.

There are two types of external sense data conditions: Ext Probe, which sets the external sense data value,

and Mask, which sets the mask value of the external sense data value.

The setting method is shown below.

(a) Ext Probe

Specify the external sense data value.

The default radix when numerical values are input is hexadecimal.

(b) Mask

Set a mask value for the external sense data value.

When mask setting is made, for a bit with a mask value of 1, it doesn’t matter if the data value is 0 or 1.

Example 1.  Data:  0x8 

Mask:  0x7 

In this kind of setting, the conditions match when the data value is 0x8 to 0xF.

2. Data:  0x8 

Mask:  0x5 

In this kind of setting, when the data is 0x8, 0x9, 0xC, and 0xD, the conditions are

matched.

If the mask value setting is omitted, masking is not executed.

The default radix when numerical values are input is hexadecimal.

When the debugger uses the external sense data condition for event detection of the bank address, those

bits cannot be accessed.

If the number of bits in the bank port is equal to or more than the maximum number of the external sense

data condition, the external sense data condition and mask value are dimmed and cannot be input.

If less than the maximum, the unused bits of the external sense data condition can be set arbitrarily.

At this time, setting bits that are being used by the debugger will cause an error.

If the external sense data condition setting is omitted, the external sense data condition is not detected.

The data value and mask value text boxes are blank in the case of newly created event conditions.

(6) In-range/out-of-range break select area

This area selects the break condition (in-range/out-of-range).

In range: Break within the range (default)

Out range: Break out of the range

This area selects whether the break occurs within the specified address range or not. This can be selected

only when R/W, Read, Write, or Before Execution is specified for the status.
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(7) Event manager area

This area displays a list of each of the entered events, event links, breaks, trace, snapshots, and timer

events.
By selecting an event and clicking , or by double-clicking the event, a setting dialog box opens

corresponding to the selected event and the event setting contents can be displayed.

When the focus is on the event manager area, select the event icon and click , or press the

 DEL  key to delete the selected event.
By clicking , it is possible to select the event manager area display mode or sequencing.

Function buttons

Closes the Event dialog box.

(Normal mode) If there is an event condition that is being edited, it is entered automatically and

the dialog box is closed.

Sets the displayed event as the event condition of the original dialog box that

(Select mode) called the Event dialog box and returns to the original setting dialog box.

If the Event dialog box is already open, the select mode returns to the normal

mode only and the Event dialog box does not close.  In other cases, it closes.

If there is an event condition being edited, enter/select is performed automatically

and the program returns to the original setting dialog box.

Newly creates an event condition.

An event name is generated automatically and a newly created event condition is

prepared.  After it is created, be sure to enter the event condition using the

 or the  button.

Enters an event condition.

When a new event condition has been created or when the contents of an event

condition have been changed, be sure to enter the event condition using this

button.  The entered event condition is reflected in the Event Manager.

If event conditions that have already been entered are displayed, they cannot be

selected.

Clears the contents of an event condition.

If an event condition is entered but not edited, the  button is displayed

in place of this button.
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Returns the contents of an event condition to the original contents.

If an event condition that has not been entered is displayed, all the area is made

blank except the event name, or the settings return to the default settings.

If an event condition is being edited, the  button is displayed in place

of this button.

Closes the Event dialog box.

(Normal mode) If an event condition has been created/changed/deleted, after that, the

 button becomes this button.

Even if there is an event condition that is being edited, the dialog box closes

without the event condition being entered.  The  ESC  key has the same

operation.

Closes the Event dialog box.

(Normal mode) If an event condition is not being created/changed/deleted, the  button

becomes this button.

Even if an event condition is being edited, the dialog box closes without the event

condition being entered.  The  ESC  key has the same operation.

Returns to the original setting dialog box that called the Event dialog box without

(Select mode) an event condition being selected.

If an event condition is not being created/changed/deleted, the 

button becomes this button.

If the Event dialog box is already open, the select mode returns to the normal

mode only, and the Event dialog box does not close.  In other cases, the Event

dialog box closes.

Even if an event condition is being edited, it is not entered.  The  ESC  key has

the same operation.

Returns to the original setting dialog box without selecting the event condition.

(Select mode) If an event condition has been edited/changed/deleted, the  button

becomes this button.

If the Event dialog box is already open, the select mode returns to the normal

mode only, and the Event dialog box does not close.  In other cases, the Event

dialog box closes.

Even if an event condition is being edited, it is not entered.  The  ESC  key has

the same operation.

Opens the help window.

Opens the Event Link dialog box.

Opens the Break dialog box.

Opens the Trace dialog box.

Opens the Snap Shot dialog box.
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Opens the DMM dialog box.

Opens the Timer dialog box.

Opens the Event Manager.

Expand Displays the event manager area.  Expands the size of the dialog box.

When the event manager area is not displayed, this button is displayed in place of

the  button.

Does not display the event manager area.  Shrinks the size of the dialog box.

When the event manager area is displayed, this button is displayed in place of the
Expand  button.

Opens the setting dialog boxes and displays the event, event link, break, trace,

snapshot, DMM or timer conditions selected in the event manager area.

Deletes the event, event link, break, trace, snapshot, DMM or timer conditions

selected in the event manager area.

Opens the Event Info dialog box.

The  button rearranges events in name order and displays them.

The  button rearranges the events in order by kind and displays them.

The  button displays the events in the order in which they were

entered without rearranging them.
The  button changes the event manager area to the detailed display

mode.

The  button changes the event manager area to the list display mode.

The  button or the  ESC  key closes the dialog box.

DMM...
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Title bar

In the normal mode, [Event] is displayed as the title in the title bar.

Title bar

Event

In the select mode, the title in the title bar becomes as follows in accordance with the original setting dialog box

that called the Event dialog box.

Title Bar Original Setting Dialog Box

Event – Break Break dialog box

Event – Trace Trace dialog box

Event – Snap Shot Snap Shot dialog box

Event – DMM DMM dialog box

Event – Timer Timer dialog box

Event – Event Link Event Link dialog box

Event – Event Link – Break Event Link dialog box

(While in the Break dialog box select mode)
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Event Link Dialog Box

General

Registers and displays event link conditions.

The event link conditions created (registered) in this dialog box are automatically registered to the Event Manager.

Opening method

This dialog box can be opened by one of the following methods.

•  In the main window

Select [Event] → [EventLink…] from the menu bar.

Press the  GRPH  +  N , and  L  keys in that order.

• In the Event dialog box

Click the  button.

Press the shortcut keys  GRPH  +  L .

• Execute one of the following operations in the Break dialog box.

Click the  button.

Press the shortcut keys  GRPH  +  L .

• Execute one of the following operations in the event setting area or the event manager area of the Event,

Break, Trace, Snap Shot, DMM, or Timer dialog boxes.

Select the event link condition and click .

Select the event link condition and press the shortcut keys  GRPH  +  O .

Double-click the event link condition.

• In the Event Manager, execute one of the following operations.

Select an event link condition and click .

Double-click the event link condition.

• Execute one of the following operations in the New Event dialog box or the Set Other dialog box.

Click the  button.

Press the shortcut keys  GRPH  +  L .
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Window

Figure 6-63.  Event Link Dialog Box

(1) Event link name setting area

(2) Link condition setting area

(3) Event manager area

Function

Registers and displays event link conditions.

If the event link conditions are satisfied, an event occurs only if the user program is executed in the specified order

of the event conditions that have been set.

Up to 256 event link conditions can be registered.  However, the number of event link conditions which can be

used simultaneously is 1.

The Event Link dialog box has two modes, the normal mode and the select mode.

• Normal mode

When [Event] → [Event Link…] from the menu bar in the main window is selected and the Event Link dialog

box is opened, event link conditions can be entered without restriction as to purpose.  This is the normal mode.

• Select mode

When  in the Break dialog box is clicked and the Event Link dialog box is opened, the event

conditions used by these are selected.  This is the select mode.

In the select mode, when  is clicked, the event link condition selected in the event link name

setting area of the Event Link dialog box is set in the event condition setting area of the setting dialog box that

originally called the Event Link dialog box.

Even in the select mode, event conditions can be entered and displayed just as in the normal mode.

(1)

(2)

(3)
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Depending on the mode, the title bar display on the dialog box will differ.  Refer to the section entitled [Title

Bar] described later.

The Event Link dialog box consists of the following areas.

• Event link name setting area

• Link condition setting area

• Event manager area

The function of each area is explained below.

(1) Event link name setting area

This area sets event link names and selects event link conditions.

When entering an event link condition, it is necessary to set an event link name.

An event link name may consist of up to eight alphanumeric characters.

When displaying event link conditions which have already been created, either type the event link name of

the already created event link condition in the text box or select the event link condition from the drop-down

list in the event link name setting area.

In the select mode, the selected event link condition can be set in the event link condition setting area of the

original setting dialog box that called the Event Link dialog box.

The  mark on the left side of the event link name setting area shows the use conditions of the event link

condition.

The relationship between the color of the character in the  mark and the status is shown below.

Color of Character in  Mark Condition

Red Indicates that that event link condition is being used and that it is

enabled.

Black Indicates that that event link condition has not been enabled.

Gray Indicates that that event link condition is currently being edited and

that it has not been entered.

Yellow Indicates that that event is an event which is in the hold state.  An

event in the hold state is in a state where the symbol specified by the

event condition by program download, etc. cannot be referred to.
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(2) Link condition setting area

This area sets the sequence of event detection as a link condition.

Event conditions are set in four steps, from Phase 1 to Phase 4.  Event conditions need not be set up to

Phase 4.  If Phase 4 is not set, an event occurs when the event condition set to the last Phase is detected.

Event conditions can be set in only Phase 1, and same event conditions can be set in two or more Phases.

The number of event conditions that can be set to each Phase in the link condition setting area is up to 1.

Also, the only type of event condition that can be set to each Phase in the link condition setting area is the

execution event.

To set an event condition, use one of the following methods.

• Click  and open the Event dialog box in the “Select mode”, then select the event conditions to

be set.

• In the event manager area, select one (or more than one) event condition, then click  or set it

by a drag-and-drop operation.

Setting of an event condition by a drag-and-drop operation is possible even from outside the Event Link

dialog box’s event manager area; event conditions can be set from the event manager area of each setting

dialog box and from the Event Manager.

When the focus is on each Phase of the link condition setting area, click  to delete the event

condition selected in the Phase which was focused on.

It can also be deleted by pressing the  DEL  key.

Each Phase of the link condition setting area and the event conditions in the disable condition setting area

can be copied mutually or moved by drag-and-drop.  The contents are shown below.

• If an event condition is dropped only by the mouse, it is moved.

• If it is dropped while pressing the  SHIFT  key, the event condition is moved.

• If it is dropped while pressing the  CTRL  key, the event condition is copied.

Selecting only one event condition in the link condition setting area and clicking  or double-

clicking it opens the Event dialog box and displays the contents of the event condition.
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(3) Event manager area

This area displays a list of each of the entered events, event links, breaks, traces, snapshots, and timer

events.

An event condition that is displayed in the event manager area can be set in the link condition setting area or

disable condition setting area by clicking .

By dragging it from the event manager area in the Event Link dialog box, it can be set in the event setting

area in each setting dialog box for break, trace, snapshot, and timer.

When the focus is on the event manager area, select the event icon and click , or press the

 DEL  key to delete the selected event.

Also, when the focus is on the event manager area, select one event icon, then click , or double-

click the event icon to open the setting dialog box corresponding to the selected event and display the event’s

setting contents.

By clicking , it is possible to select the event manager area display mode or sequencing.

Function buttons

Closes the Event Link dialog box.

(Normal mode) If there is an event link condition that is being edited, it is entered automatically

and the dialog box is closed.

Sets the displayed event as the event link condition in the original dialog box that

(Select mode) called the Event Link dialog box.

If the Event Link dialog box is already open, the select mode returns to the normal

mode only and the Event Link dialog box does not close.  In other cases, it closes.

If there is an event link condition being edited, enter/select is performed

automatically and the program returns to the original setting dialog box.

Newly creates an event link condition.

An event name is generated automatically and a newly created event link

condition is prepared.  After it is created, be sure to enter the event link condition

using the  or the  button.

Enters an event link condition.

When a new event link condition has been created or when the contents of an

event link condition have been changed, be sure to enter the event link condition

using this button.  The entered event link condition is reflected in the Event

Manager.

If event link conditions that have already been entered are displayed, they cannot

be selected.
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Clears the contents of an event link condition.

If an event link condition is entered but not edited, the  button is

displayed in place of this button.

Returns the contents of an event link condition to the original contents.

If an event link condition that has not been entered is displayed, all the area is

made blank except the event link name, or the settings return to the default

settings.

If an event link condition is being edited, the  button is displayed in

place of this button.

Closes the Event Link dialog box.

(Normal mode) If an event link condition has been created/changed/deleted, after that, the

 button becomes this button.

Even if there is an event link condition that is being edited, the dialog box closes

without the event link condition being entered.  The  ESC  key has the same

operation.

Closes the Event Link dialog box.

(Normal mode) If an event link condition is not being created/changed/deleted, this button is

displayed.

Even if an event link condition is being edited, the dialog box closes without the

event link condition being entered.  The  ESC  key has the same operation.

Returns to the original setting dialog box that called the Event Link dialog box

(Select mode) without an event link condition being selected.

If an event link condition is not being created/changed/deleted, the 

button becomes this button.

If the Event Link dialog box is already open, the select mode returns to the normal

mode only, and the Event Link dialog box does not close.  In other cases, the

Event Link dialog box closes.

Even if an event link condition is being edited, it is not entered.  The  ESC  key

has the same operation.

Returns to the original setting dialog box without selecting the event link condition.

(Select mode) If an event link condition has been created/changed/deleted, the 

button becomes this button.

If the Event Link dialog box is already open, the select mode returns to the normal

mode only, and the Event Link dialog box does not close.  In other cases, the

Event Link dialog box closes.

Even if an event link condition is being edited, it is not entered.  The  ESC  key

has the same operation.

Opens the help window.



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14910EJ1V0UM00294

Opens the select mode in the Event dialog box and makes additional settings in

the link condition setting area or disable condition setting area.  The area where

additional settings are made becomes the selected area when  is

clicked.

Opens each setting dialog box for the event selected in the link condition setting

area, disable condition setting area or event manager area and displays the

contents.

If an event is not selected, or if multiple events are selected, selection cannot be

made.

The operation is the same as double-clicking the event icon.

Deletes the event selected in the link condition setting area, disable condition

setting area or event manager area.

The same operation is performed by pressing the  DEL  key.

Expand Displays the event manager area.  Expands the size of the dialog box.

When the event manager area is not displayed, this button is displayed in place of

the  button.

Does not display the event manager area.  Shrinks the size of the dialog box.

When the event manager area is displayed, this button is displayed in place of the
Expand  button.

Adds an event condition or event link condition selected in the event manager

area to the link condition setting area or disable condition setting area and sets it.

The area where it is added becomes the selected area when  is

clicked.

Opens the Event Info dialog box.

The  button rearranges events in name order and displays them.

The  button rearranges the events in order by kind and displays

them.

The  button displays the events in the order in which they were

entered without rearranging them.
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The  button changes the event manager area to the detailed display

mode.

The  button changes the event manager area to the list display

mode.

The  button or the  ESC  key closes the dialog box.

This opens the Set Other dialog box.

Clicking each button opens the Event Manager and the Event, Break, Trace, Snap

Shot, DMM, or Timer dialog box, and closes the dialog box.

Close the dialog box by clicking  or  and return to the

Event Link dialog box.

Title bar

In the normal mode, [Event Link] is displayed as the title in the title bar.

Title bar

Event Link

In the select mode, the title in the title bar becomes as follows in accordance with the original setting dialog box

that called the Event Link dialog box.

Title Bar Original Setting Dialog Box

Event Link – Break Break dialog box
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Break Dialog Box

General

Registers, sets, and displays break event conditions.

The break event conditions registered in this dialog box are automatically registered to the Event Manager.

Opening method

This dialog box can be opened by one of the following methods.

•  In the main window

Select [Event] → [Break…] from the menu bar.

Press the  GRPH  +  N , and  B  keys in that order.

Click the  button on the toolbar.

• In the Event dialog box

Click the  button.

Press the shortcut keys  GRPH  +  B .

• Execute one of the following operations in the event manager area in the Event, Event Link, Trace, Snap Shot,

DMM, or Timer dialog box.

Select the break event condition and click .

Select the break event condition and press the shortcut keys  GRPH  +  O .

Double-click the break event condition.

• In the Event Manager, execute one of the following operations.

Select an break event condition and click .

Double-click the break event condition.

• Execute one of the following operations in the New Event dialog box or the Set Other dialog box.

Click the  button.

Press the shortcut keys  GRPH  +  B .
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Window

Figure 6-64.  Break Dialog Box

When event manager area is displayed

(1) Break event name setting area (3) Event manager area

(2) Break condition setting area

Function

Registers, sets, and displays break event conditions.

Up to 256 break event conditions can be entered.  However, when the IE-78K0-NS is used, the number of break

event conditions that can be used simultaneously is 12, and when the IE-78K0-NS-PA is installed in the IE-78K0-NS

or the IE-78K0-NS-A/IE-78K0S-NS-A is used, this number is 28.

Break event conditions become valid automatically when they are entered.  However, if the number of break event

conditions exceeds the number that can be used simultaneously, or if the number of event conditions or event link

conditions in use exceeds the number that can be used simultaneously, the break event conditions are entered in the

disabled state.  Also, in this case, a break event condition cannot be enabled.

Note that if [Run] → [Ignore Break Point] is selected, the break event condition will not operate even if it is enabled.

The Break dialog box consists of the following areas.

• Break event name setting area

• Break condition setting area

• Event manager area

The function of each area is explained below.

(1)

(2)

(3)
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(1) Break event name setting area

This area sets break event names and selects break event conditions.  When entering an event condition, it is

necessary to set a break event name.  Break event names of up to 8 alphanumeric characters can be set.

When displaying break event conditions which have already been created, either type the break event name

of the already created break event condition in the text box or select the break event condition from the drop-

down list in the break event name setting area.

Clicking the  mark in the break event name setting area switches between enabling or disabling the break

event condition.

The relationship between the color of the character in the  mark and the status is shown below.

Color of Character in  Mark Condition

Red Indicates that the break event condition has been enabled.

A break event occurs if the condition is satisfied.

Black Indicates that the break event condition has not been enabled.

No break event occurs if the condition is satisfied.

Gray Indicates that the break event condition is currently being edited and

that it has not been entered.

Yellow Indicates that the break event is an event which is in the hold state.

An event in the hold state is in a state where the symbol specified by

the event condition by program download, etc. cannot be referred to.

(2) Break condition setting area

This area sets an event condition for a break.

The number of event conditions that can be set in the break condition setting area is 12 when the IE-78K0-NS

is not installed (8 execution events and 4 access events) and 28 when the IE-78K0-NS-PA is installed in the

IE-78K0-NS or the IE-78K0-NS-A/IE-78K0S-NS-A is used (16 execution events and 4 access events).

Also, the number of event link conditions that can be used simultaneously is up to 2, as long as the number of

event conditions in use does not exceed the number of event conditions that can be used simultaneously.

Carry out setting of the disable conditions by one of the following methods.
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• Click  and open the Event dialog box in the select mode, then select the event condition

which is to be set.

• Click  and open the Event Link dialog box in the select mode, then select the event link

condition which is to be set.

• Select an event link condition in the event manager area and click , or make the setting by a

drag-and-drop operation.

When setting the event condition or event link condition by a drag-and-drop operation, besides the event

manager area in the Break dialog box, it is possible to set it from the event manager area and Event Manager

in each setting dialog box.

When the focus is on the break condition setting area, clicking  deletes the selected event

condition or event link condition.

It can also be deleted by  DEL  key.

If only one event condition or event link condition in the break condition setting area is selected and

 is clicked or the item is double-clicked, the Event dialog box or Event Link dialog box is opened

and the event condition or event link condition contents are displayed.

(3) Event manager area

This area displays a list of each of the entered events, event link, break, trace, snapshot, DMM, and timer

events.

An event or event link condition that is displayed in the event manager area can be set in the break condition

setting area by clicking .

Also, event conditions or event link conditions in the event manager area can be dragged directly to the break

condition setting area.

When the focus is on the event manager area, select the event icon and click , or press the

 DEL  key to delete the selected event.

Also, when the focus is on the event manager area, select one event icon, then click , or

double-click the event icon to open the setting dialog box corresponding to the selected event and display the

event’s setting contents.

By clicking , it is possible to select the event manager area display mode or sequencing.
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Function buttons

Closes the Break dialog box.

If there is a break event condition that is being edited, it is entered automatically

and the dialog box is closed.

A break event conditions are enabled as soon as it is entered.

Newly creates a break event condition.

A break event name is generated automatically and a newly created break event

condition is prepared.  After it is created, be sure to enter the break event

condition using the  or the  button.

Enters the break event condition.

This button is displayed when a new break event condition is created or when the

contents of a break event condition have been changed.  In this case, be sure to

enter the break event condition.

If a break event condition that has already been entered is displayed, this button
changes to either the  button or the  button.

A break event condition is enabled as soon as it is entered.

Enables a break event condition.

This button is displayed in cases where a break event condition is in the disabled

state.

It changes to either the  button or the  button.

Disables a break event condition.

This button is displayed in cases where a break event condition is in the enabled

state.

It changes to either the  button or the  button.

Clears the contents of a break event condition.

If a break event condition is entered but not edited, this button is displayed.  It

changes to the  button.

Restores the break event condition to its original contents.

If a break event condition that has not been entered is displayed, the display area

is restored to the blank state except for the break event name.

This button is displayed in the case where a break event condition is being edited.

It changes to the  button.
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Closes this dialog box.

If a break event condition is not being created/changed/deleted, this button is

displayed.

Even if a break event condition is being edited, this dialog box is closed without

entering the condition.  The  ESC  key has the same operation.

Closes this dialog box.

If a break event condition has being created/changed/deleted, the 

button becomes this button.

Even if a break event condition is being edited, this dialog box is closed without

entering the condition.  The  ESC  key has the same operation.

Opens the help window.

Opens the Event dialog box in the select mode and selects the set event

condition.

Opens the Event Link dialog box in the select mode and selects the set event link

condition.

Displays the contents of an event selected in the break condition setting area or

the event manager area by opening each setting dialog box.  Its operation is the

same as double-clicking the event icon.

When the event icon is not selected, or if multiple icons have been selected, this

button is disabled.

Deletes an event selected in the break condition setting area or the event

manager area.

Pressing the  DEL  key performs the same operation.

Expand Displays the event manager area.  Expands the size of the dialog box.

When the event manager area is not displayed, this button is displayed in place of

the  button.

Does not display the event manager area.  Shrinks the size of the dialog box.

When the event manager area is displayed, this button is displayed in place of the
Expand  button.

Adds the event condition or event link condition selected in the event manager

area to the break condition setting area.

An event other than an event condition or an event link condition cannot be added.
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Opens the Event Info dialog box.

The  button rearranges events in name order and displays them.

The  button rearranges the events in order by kind and displays

them.

The  button displays the events in the order in which they were

entered without rearranging them.

The  button changes the event manager area to the detailed display

mode.

The  button changes the event manager area to the list display

mode.

The  button or the  ESC  key closes the dialog box.

Opens the Set Other dialog box.

Clicking each button opens the Event Manager and the Event, Event Link, Trace,

Snap Shot, DMM, or Timer dialog box, and closes the dialog box.

Close the dialog box by clicking  or  and return to the

Break dialog box.
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Trace Dialog Box

General

Registers, sets, and displays trace event conditions.

The trace event conditions registered in this dialog box are automatically registered to the Event Manager.

Opening method

This dialog box can be opened by one of the following methods.

•  In the main window

Select [Event] → [Trace…] from the menu bar.

Press the  GRPH  +  N , and  T  keys in that order.

Click the  button on the toolbar.

•  In the Event dialog box

Click the  button.

Press the shortcut keys  GRPH  +  T .

• Execute one of the following operations in the event manager area in the Event, Event Link, Break, Snap Shot,

DMM, or Timer dialog box.

Select the trace event condition and click the  button.

Select the trace event condition and press the shortcut keys  GRPH  +  O .

Double-click the trace event condition.

• Execute one of the following operations in the Event Manager.

Select the trace event condition and click the  button.

Double-click the trace event condition.

• Execute one of the following operations in the New Event dialog box or Set Other dialog box.

Click the  button.

Press the shortcut keys  GRPH  +  T .
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Window

Figure 6-65.  Trace Dialog Box

(1) Trace event name setting area (4) Qualify trace condition setting area

(2) Trace start condition setting area (5) Event manager area

(3) Trace end condition setting area

Function

Sets various types of trace operations, and registers, sets and displays trace event conditions.

The trace operation settings shown in (1) and (2) below can be executed.

(1) Operation when trace data is written to entire trace memory

The trace frame makes a scan of the trace memory and when it arrives at the oldest frame, it continues the

trace operation and overwrites the oldest trace frame.

(2) Setting trace event conditions

The following 2 types of trace event conditions can be set but only when the IE-78K0-NS-PA is installed in the

IE-78K0-NS or the IE-78K0-NS-A/IE-78K0S-NS-A is used.

• Section trace start event condition

• Section trace end event condition

(1)

(2)

(3)

(5)

(4)
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Up to 256 trace event conditions can be entered.  However, the number of trace event conditions that can be

used simultaneously is 1.

Trace event conditions become valid automatically when they are entered.  However, if an enabled trace

event condition already exists, or if the number of event conditions or event link conditions in use exceeds the

number that can be used simultaneously, the trace event conditions are entered in the disabled state.  Also,

in this case, a trace event condition cannot be enabled.

A trace is performed only when the tracer is in the enabled state.  Set it by the procedure shown below.

• When performing a trace or a qualify trace, select [Run] → [Cond. Trace ON], and in other cases, select

[Run] → [Uncond. Trace ON].

During emulation, in order to stop the currently operating tracer, select [Run] → [Tracer Stop] from the menu

bar.  Also, during emulation, in order to run the currently stopped tracer, select [Run] → [Tracer Start] from

the menu bar.  These two menus toggle and their display changes according to the current tracer state.
Note, however, that this operation is valid only when [Run] → [Ignore Break Point] is selected and executed.

This dialog box consists of the following areas.

• Trace event name setting area

• Trace start condition setting area

• Trace end condition setting area

• Qualify trace condition setting area

• Event manager area

The function of each area is explained below.

(1) Trace event name setting area

This area sets trace event names and selects trace event conditions.

When entering a trace event condition, it is necessary to set a trace event name.

Trace event names that can be set must be of 8 alphanumeric characters or less.

When displaying trace event conditions which have already been created, either type the trace event name of

the already created trace event condition in the text box or select one from the drop-down list in the trace

event name setting area.

Clicking the  mark in the trace event name setting area switches between enabling or disabling the trace

event condition.

The relationship between the color of the character in the  mark and the status is shown below.
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Color of Character in  Mark Condition

Red Indicates that the trace event condition has been enabled.

A trace event occurs if the condition is satisfied.

Black Indicates that the trace event condition has not been enabled.

No trace event occurs if the condition is satisfied.

Gray Indicates that the trace event condition is currently being edited and

that it has not been entered.

Yellow Indicates that the trace event is an event which is in the hold state.

An event in the hold state is in a state where the symbol specified by

the event condition by program download, etc. cannot be referred to.

(2) Trace start condition setting area

This area sets an event condition for starting a trace.

The number of event conditions that can be set in the trace start condition setting area is 16 (8 execution

events and 8 access events).

Also, the number of event link conditions that can be set is 1.

Carry out setting of the trace start conditions by one of the following methods.

• Click  and open the Event dialog box in the select mode, then select the event condition

which is to be set.

• Click  and open the Event Link dialog box in the select mode, then select the event link

condition which is to be set.

• Select one or more event condition or event link condition in the event manager area and click

, or make the setting by drag-and-drop.

When setting the event condition or event link condition by drag-and-drop, besides the event manager area in

the Trace dialog box, it is possible to set it from the event manager area and Event Manager in each setting

dialog box.

When the focus is on the trace start condition setting area, click the  button, or press the

 DEL  key to delete the selected event condition or event link condition.

It is possible to move and copy event conditions and event link conditions in the trace start condition setting

area back and forth among the different setting areas in the Trace dialog box by drag-and-drop operations, as

shown below.

• If an event condition or event link condition is dropped only by the mouse, it is moved.

• If it is dropped while pressing the  SHIFT  key, the event condition or event link condition is moved.

• If it is dropped while pressing the  CTRL  key, the event condition or event link condition is copied.
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Selecting an event condition or event link condition in the trace start condition setting area and clicking

 or double-clicking it opens the Event dialog box or Event Link dialog box and displays the

contents of the event condition or event link condition.

The trace start condition setting area is left blank when there is a newly created trace event condition.

(3) Trace end condition setting area

This sets an event condition for ending a trace.

When Trace Stop is selected in the trace full mode, the trace end condition cannot be set.

The number of event conditions that can be set in the trace end condition setting area is 16 (8 execution

events and 8 access events).

Also, the number of event link conditions that can be set is 1.

Carry out setting of the trace end conditions by one of the following methods.

• Click  and open the Event dialog box in the select mode, then select the event condition

which is to be set.

• Click  and open the Event Link dialog box in the select mode, then select the event link

condition which is to be set.

• Select one or more event condition or event link condition in the event manager area and click

, or make the setting by drag-and-drop.

When setting the event condition or event link condition by drag-and-drop, besides the event manager area in

the Trace dialog box, it is possible to set it from the event manager area and Event Manager in each setting

dialog box.

When the focus is on the trace ending condition setting area, click the  button, or press the

 DEL  key to delete the selected event condition or event link condition.

It is possible to move and copy event conditions and event link conditions in the trace end condition setting

area back and forth among the different setting areas in the Trace dialog box by drag-and-drop operations, as

shown below.

• If an event condition or event link condition is dropped only by the mouse, it is moved.

• If it is dropped while pressing the  SHIFT  key, the event condition or event link condition is moved.

• If it is dropped while pressing the  CTRL  key, the event condition or event link condition is copied.

Selecting an event condition or event link condition in the trace end condition setting area and clicking

 or double-clicking it opens the Event dialog box or Event Link dialog box and displays the

contents of the event condition or event link condition.

The trace end condition setting area is left blank when there is a newly created trace event condition.
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(4) Qualify trace condition setting area

This area sets event conditions for a qualify trace.

A qualify trace is executed only when the trace condition is satisfied.

If two or more event conditions are set, the trace is executed when each event condition is satisfied.

The number of event conditions that can be set in the qualify trace condition setting area is 4 (4 access

events).

The number of event link conditions that can be set is 1.

Carry out setting of the qualify trace condition by either of the following methods.

• Click  and open the Event dialog box in the select mode, then select the event condition

which is to be set.

• Select one or more event condition in the event manager area and click , or make the setting

by drag-and-drop.

When setting the event condition by drag-and-drop, besides the event manager area in the Trace dialog box,

it is possible to set it from the event manager area and Event Manager in each setting dialog box.

When the focus is on the qualify trace condition setting area, click the  button, or press the

 DEL  key to delete the selected event condition.

It is possible to move and copy event conditions in the qualify trace condition setting area back and forth

among the different setting areas in the Trace dialog box by drag-and-drop operations, as shown below.

• If an event condition is dropped only by the mouse, it is moved.

• If it is dropped while pressing the  SHIFT  key, the event condition is moved.

• If it is dropped while pressing the  CTRL  key, the event condition is copied.

The event condition in the qualify trace condition setting area can be moved or copied alternately with other

setting areas in the Trace dialog box by a drag-and-drop operation.

Selecting an event condition in the qualify trace condition setting area and clicking  or double-

clicking it opens the Event dialog box and displays the contents of the event condition.

The qualify trace condition setting area is left blank when there is a newly created trace event condition.

(5) Event manager area
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This area displays list of each event, event link, break, trace, snapshot, DMM, and timer event.

By selecting an event condition or event link condition displayed in the event manager area and clicking

, the event condition or event link condition, etc. can be set in the delay trigger condition setting

area, trace start condition setting area, trace end condition setting area, qualify trace condition setting area

and other setting areas.

Also the event condition or event link condition in the event manager area can be directly dragged to each

event setting area.

When the focus is on the event manager area, select an event icon, and click the  button, or

press the  DEL  key to delete the selected event.

When the focus is on the event manager area, selecting an event icon and clicking  or double-

clicking an event icon opens the setting dialog box corresponding to the selected event, and displays the

contents of the event.

By clicking , it is possible to select the event manager area display mode or sequencing.

Function buttons

Closes the Trace dialog box.

If there is a trace event condition that is being edited, it is entered automatically

and the dialog box is closed.

A trace event condition becomes enabled as soon as it is entered.

Newly creates a trace event condition.

A trace event name is generated automatically and a newly created trace event

condition is prepared.  After it is created, be sure to enter the trace event condition

using the  or the  button.

Enters a trace event condition.

When a new trace event condition has been created or when the contents of a

trace event condition have been changed, be sure to enter the trace event

condition using this button.

If trace event conditions that have already been entered are displayed, it changes

to either the  button or  button.

A trace event condition becomes enabled as soon as it is entered.

Enables a trace event condition.

This button is displayed in cases where a trace event condition is in the disabled

state.

It changes to either the  button or the  button.

Disables a trace event condition.

This button is displayed in cases where a trace event condition is in the enabled

state.

It changes to either the  button or the  button.
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Clears the contents of a trace event condition.

If a trace event condition is entered but not edited, this button is displayed.  It

changes to the  button.

Returns the contents of a trace event condition to the original contents.

If a trace event condition that has not been entered is displayed, all the area is

made blank except the trace event name, or the settings return to the default

settings.

If a trace event condition is being edited, the  button is displayed in

place of this button.

Closes the Trace dialog box.

If a trace event condition is not being created/changed/deleted, this button is

displayed.

Even if a trace event condition is being edited, the dialog box closes without the

trace event condition being entered.  The  ESC  key has the same operation.

Closes the Trace dialog box.

If a trace event condition has been created/changed/deleted, after that, the

 button becomes this button.

Even if there is a trace event condition that is being edited, the dialog box closes

without the trace event condition being entered.  The  ESC  key has the same

operation.

Opens the Help window.

Opens the Event dialog box in the select mode and adds an event condition to the

selected position in the delay trigger condition setting area, trace start condition

setting area, trace end condition setting area or qualify trace condition setting

area.

The area where the event condition is added becomes the selected area when

 is clicked.

Opens the Event Link dialog box in the select mode and adds an event link

condition to the selected position in the trace start condition setting area, trace end

condition setting area or qualify trace condition setting area.

The area where the event link condition is added becomes the selected area when

 is clicked.

Displays the event contents selected in the trace start condition setting area, trace

end condition setting area, qualify trace condition setting area or event manager

area by opening each setting dialog box.

Its operation is the same as double-clicking the event icon.

When the event icon is not selected, or if multiple icons have been selected, this

button is disabled.
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Opens the Event Link dialog box in the select mode and deletes the event

selected in the trace start condition setting area, trace end condition setting area,

qualify trace condition setting area or event manager area.

The  DEL  key has the same operation.

Expand Displays the event manager area.  Expands the size of the dialog box.

When the event manager area is not displayed, this button is displayed in place of

the  button.

Does not display the event manager area.  Shrinks the size of the dialog box.

When the event manager area is displayed, this button is displayed in place of the
Expand  button.

Adds the event condition or event link condition selected in the event manager

area to the selected position in the trace start condition setting area, trace end

condition setting area or qualify trace condition setting area.

The area where the event condition is added becomes the selected area when

 is clicked.

Opens the Event Info dialog box.

The  button rearranges events in name order and displays them.

The  button rearranges the events in order by kind and displays

them.

The  button displays the events in the order in which they were

entered without rearranging them.

The  button changes the event manager area to the detailed display

mode.

The  button changes the event manager area to the list display

mode.

The  button or the  ESC  key closes the dialog box.
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Opens the Set Other dialog box.

Clicking each button opens the Event, Event Link, Break, Snap Shot, DMM or

Timer dialog box and the Event Manager, and closes the Set Other dialog box.

Close the dialog box by clicking  or  and return to the

Trace dialog box.
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Snap Shot Dialog Box

General

Registers, sets, and displays snapshot event conditions.

The snapshot event condition registered in this dialog box is automatically registered to the Event Manager.

This dialog box can be used only when the IE-78K0-NS-PA is installed in the IE-78K0-NS or the IE-78K0-NS-A/IE-

78K0S-NS-A is used.

Opening method

This dialog box can be opened by one of the following methods.

•  In the main window

Select [Event] → [Snap Shot…] from the menu bar.

Press the  GRPH  +  N , and  S  keys in that order.

•  In the Event dialog box

Click the  button.

Press the shortcut keys  GRPH  +  S .

• Execute one of the following operations in the event manager area in the Event, Event Link, Break, Trace,

DMM, or Timer dialog box.

Select the snapshot event condition and click the  button.

Select the snapshot event condition and press the shortcut keys  GRPH  +  O .

Double-click the snapshot event condition.

• Execute one of the following operations in the Event Manager.

Select the snapshot event condition and click the  button.

Double-click the snapshot event condition.

• Execute one of the following operations in the New Event dialog box or Set Other dialog box.

Click the  button.

Press the shortcut keys  GRPH  +  S .
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Window

Figure 6-66.  Snap Shot Dialog Box (1/2)

Selection of register snap data

Selection of SFR snap data

(1) Snapshot event name setting area (5) SFR snap data setting area

(2) Snapshot condition setting area (6) There is no relevant area in this state

(3) Snap data select area (7) Snap data display area

(4) Register snap data setting area (8) Event manager area

(1)

(4)

(2)

(7)

(3)

(8)

(1)

(2)

(7)

(3)

(8)

(5)
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Figure 6-66.  Snap Shot Dialog Box (2/2)

Selection of memory snap data

(1) Snapshot event name setting area (5) There is no relevant area in this state

(2) Snapshot condition setting area (6) Memory snap data setting area

(3) Snap data select area (7) Snap data display area

(4) There is no relevant area this state (8) Event manager area

Function

Registers, sets, and displays snapshot event conditions.

Snapshot is for saving the contents of the registers, memory and SFRs when the program is executed in the trace

buffer.  The timing at which snapshot is to be performed is specified by a snapshot event condition.

Up to 256 snapshot event conditions can be set.  However, the number of snapshot event conditions that can be

used simultaneously is 1.

Snapshot event conditions become valid automatically when they are entered.  However, if the number of snapshot

event conditions exceeds the number that can be used simultaneously, or if the number of event conditions or event

link conditions in use exceeds the number that can be used simultaneously, the snapshot event conditions are

entered in the disabled state.  Also, in this case, a snapshot event condition cannot be enabled.

Up to 16 items of snap data can be set for each of the registers, SFRs, and memory, for a total of up to 48 items.

(7)

(6)

(2)

(1)

(3)

(8)
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This dialog box consists of the following areas.

• Snapshot event name setting area

• Snapshot condition setting area

• Snap data select area

• Register snap data setting area

• SFR snap data setting area

• Memory snap data setting area

• Snap data display area

• Event manager area

The function of each area is explained below.

(1) Snapshot event name setting area

This area sets a snapshot event name and displays a snapshot event condition.

When entering a snapshot event condition, it is necessary to set a snapshot event name.  A snapshot event

name may consist of up to eight alphanumeric characters.

When displaying snapshot event conditions which have already been created, either type the name of the

already created snapshot event condition in the text box or select the snapshot event condition from the drop-

down list in the snapshot event name setting area.

Clicking the  mark in the snapshot event name setting area switches between enabling or disabling the

snapshot event condition.

The relationship between the color of the character in the  mark and the status is shown below.

Color of Character in  Mark Condition

Red Indicates that the snapshot event condition has been enabled.

A snapshot event occurs if the condition is satisfied.

Black Indicates that the snapshot event condition has not been enabled.

No snapshot event occurs even if the condition is satisfied.

Gray Indicates that the snapshot event condition is currently being edited

and that it has not been entered.

Yellow Indicates that the snapshot event is an event which is in the hold

state.  An event in the hold state is in a state where the symbol

specified by the event condition by program download, etc. cannot

be referred to.
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(2) Snapshot condition setting area

This area sets a snapshot event condition.

Only one event condition or event link condition can be set in the snapshot condition setting area.

Carry out setting of the snapshot condition by either of the following methods.

• Click  and open the Event dialog box in the select mode, then select the event condition

which is to be set.

• Click  and open the Event Link dialog box in the select mode, then select the event link

condition which is to be set.

• Select an event condition or event link condition in the event manager area and click , or

make the setting by a drag-and-drop operation.

If an event condition or event link condition is already set in the snapshot condition setting area, it is replaced

by the newly set event condition or event link condition.

When setting the event condition or event link condition by drag-and-drop, besides the event manager area in

the Snap Shot dialog box, it is possible to set it from the event manager area and Event Manager in each

setting dialog box.

When the focus is on the snapshot condition setting area, click the  button, or press the

 DEL  key to delete the selected event condition or event link condition.

Selecting an event condition or event link condition in the snapshot condition setting area and clicking

 or double-clicking it opens the Event dialog box or Event Link dialog box and displays the

contents of the event condition or event link condition.

The snapshot condition setting area is left blank when there is a newly created snapshot event condition.

(3) Snap data select area

This area selects the type of snap data.

The following three types of snap data are available.

Item Contents

Register A register can be registered.

Sfr An SFR can be registered.

Memory Memory can be registered.
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The following displays are switched by selection in the snap data select area.

• Register snap data setting area

• SFR snap data setting area

• Memory snap data setting area

Also, if snap data is selected in the snap data display area, the selection items in the snap data select area

change in accordance with the type of snap data selected.

(4) Register snap data setting area

Enter, change or delete register snap data in this area.

This area is displayed by selecting Register in the snap data select area.

Snap data which is entered/changed/deleted here is reflected in the snap data display area.  If register snap

data is selected in the snap data display area, the contents of the selected register snap data are displayed.

Up to 16 items of register snap data can be entered.

The register snap data setting area consists of the following items.

(a) Register name setting area

This specifies the register name.

Specification of a register name is accomplished by selecting the register name from a drop-down list.

A general-purpose register or control register can be specified.  Uppercase and lowercase characters are

not distinguished (in the Trace View window, all the characters are standardized to uppercase characters

and displayed).

Names that can be specified are function names and absolute names.  Note, however, that the snap data

displayed in the Trace View window is always displayed as an absolute name.

To specify all the registers, select All from the drop-down list or specify directly in the text box.

For a newly created snapshot event condition, this area is blank.

When entering register snap data, it is necessary to specify a register name.
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(b) Register bank setting area

This area specifies the register bank.

To specify the register bank, enter the value directly in the text box or select from the drop-down list. The

setting range is as follows.

Setting range:  0 ≤ Register bank ≤ 3

To specify the current bank, select “Current” from the drop-down list or enter “Current” or “C”

(abbreviation) directly in the text box.

If the register bank specification is omitted, the current bank will be specified.

For a newly created snapshot event condition, this area is blank.

(c)  button

Enters register snap data.

Entered snap data is inserted in the snap data display area’s select position and displayed.

(d)  button

Changes the contents of snap data selected in the snap data display area to the specified register snap

data.

(e)  button

Deletes the snap data selected in the snap data display area.

If the focus is on the snap data display area, the same kind of operation can be performed using the

 DEL  key.

(f)  button

Restores the contents of the snap data display area to the original contents.

(5) SFR snap data setting area

Enter, change or delete SFR snap data in this area.

This area is displayed by selecting Sfr in the snap data select area.

Snap data which is entered/changed/deleted here is reflected in the snap data display area.  If SFR snap

data is selected in the snap data display area, the contents of the selected SFR snap data are displayed.

Up to 16 items of SFR snap data can be entered.

The SFR snap data setting area consists of the following items.
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(a) SFR name setting area

This area specifies the SFR name.  Only SFR names that are possible to read can be specified.

Also, SFR bit names and I/O port names entered in the Add I/O Port dialog box cannot be specified.

The SFR name can be set by typing the SFR name directly in the text box or by selecting the SFR name

from the drop-down list.

SFR names are not case sensitive (in the Trace View window, all the characters are standardized to

uppercase characters and displayed).

For a newly created snapshot event condition, this area is blank.

When entering SFR snap data, it is necessary to specify an SFR name.

(b)  button

Enters SFR snap data.

Entered snap data is inserted in the snap data display area’s select position and displayed.

(c)  button

Changes the contents of snap data selected in the snap data display area to the specified SFR snap

data.

(d)  button

Deletes the snap data selected in the snap data display area.

If the focus is on the snap data display area, the same kind of operation can be performed using the

 DEL  key.

(e)  button

Restores the contents of the snap data display area to the original contents.

(6) Memory snap data setting area

This area specifies the range of the memory data for the snapshot and access size.

This area is displayed only when Memory is selected in the snap data select area.

Snap data which is entered/changed/deleted here is reflected in the snap data display area.  If memory snap

data is selected in the snap data display area, the contents of the selected memory snap data are displayed.

Up to 16 items of memory snap data can be entered.

The memory snap data setting area consists of the following items.
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(a) Memory address setting area

This area specifies the memory address range.

Input the start address and end address, in that order.

The setting range is as shown below.

Setting range:  0 ≤  Address ≤ 0xffff

If a value is input for the start address only and the end address is omitted, it is regarded as if the value

specified for the end address was the same as that specified for the start address.

If the specified address range cannot be divided by the access size, the address range is rounded up

and corrected to a range that can be divided by the access size.

For the address range specification, it is possible to specify by a symbol or an expression.  The

specification method is the same as in the Address Move dialog box.  The default radix when numerical

values are input is hexadecimal.

If an expression or symbol is specified in the memory address setting area and then entered and

changed, the converted address value is displayed together with the specified expression or symbol in

the snap data display area.

Only the converted address value is displayed for snap data displayed in the Trace View window.

For a newly created snapshot event condition, this area is blank.

When entering memory snap data, it is necessary to specify a starting address.

(b) Memory display size setting area

This area specifies the memory snap data access size.

The access size can be specified by typing the value directly in the text box or by selecting it from the

drop-down list.

The following can be specified.

Access Size Abbreviated Form Contents

Byte B Memory snapshot is executed in 8-bit units.

Word W Memory snapshot is executed in 16-bit units.

Double word DW Memory snapshot is executed in 32-bit units.

Remark The specified characters are not case sensitive.

For a newly created snapshot event condition, this area is blank.

When entering memory snap data, it is necessary to specify the access size.

(c)  button

Enters memory snap data.

Entered snap data is inserted in the snap data display area’s select position and displayed.
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(d)  button

Changes the contents of snap data selected in the snap data display area to the specified memory snap

data.

(e)  button

Deletes the snap data selected in the snap data display area.

If the focus is on the snap data display area, the same kind of operation can be performed using the

 DEL  key.

(f)  button

Restores the contents of the snap data display area to the original contents.

(7) Snap data display area

This area lists the registered snap data.

Snap data, including registers, SFRs, and memory data, can be registered.

The registered snap data is written to the tracer when a snapshot event occurs.

If snap data is selected in the snap data list, the contents of the selected snap data are displayed in the

setting areas for the register, the SFR, and memory.

Each type of snap data is displayed as follows.

(a) Register snap data

Register name

Example

RP0[0]

RP1[Current]

All[2]

(b) SFR snap data

SFR name

Example

PM0

PM1
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(c) Memory snap data

Starting address <Symbol, expression> – End address <Symbol, expression>, Access size

Example

0xFE20<byVar >, B

0xFE22<wVar >, W

0xFE30<szVar >–0xFE2F<szVar+0x10 >, B

Remark Symbols or expressions specified in the address are enclosed by “< >”.

(8) Event manager area

This area displays a list of each of the entered event and event link conditions, and break, trace, snapshot,

DMM, and timer events.

An event or event link condition that is displayed in the event manager area can be set in the snapshot

condition setting area by clicking the  button.

Also, event conditions or event link conditions in the event manager area can be dragged directly to the

snapshot condition setting area.

When the focus is on the event manager area, select an event icon and click the  button, or

press the  DEL  key to delete the selected event.

When the focus is on the event manager area, selecting an event icon and clicking  or double-

clicking an event icon opens the setting dialog box corresponding to the selected event and displays the

contents of the event.

By clicking , it is possible to select the event manager area display mode or sequencing.

Function buttons

Closes the Snap Shot dialog box.

If there is a snapshot event condition that is being edited, it is entered

automatically and the dialog box is closed.

A snapshot event condition becomes enabled as soon as it is entered.

Newly creates a snapshot event condition.

A snapshot event name is generated automatically and a newly created snapshot

event condition is prepared.  After it is created, be sure to enter the snapshot

event condition using the  or the  button.
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Enters a snapshot event condition.

When a new snapshot event condition has been created or when the contents of a

snapshot event condition have been changed, be sure to enter the snapshot event

condition using this button.

If snapshot event conditions that have already been entered are displayed, it

changes to either the  button or  button.

A snapshot event condition becomes enabled as soon as it is entered.

Enables a snapshot event condition.

This button is displayed in cases where a snapshot event condition is in the

disabled state.

It changes to either the  button or the  button.

Disables a snapshot event condition.

This button is displayed in cases where a snapshot event condition is in the

enabled state.

It changes to either the  button or the  button.

Clears the contents of a snapshot event condition.

If a snapshot event condition is entered but not edited, this button is displayed.  It

changes to the  button.

Returns the contents of a snapshot event condition to the original contents.

If a snapshot event condition that has not been entered is displayed, all the area

except the snapshot event name is made blank.

If a snapshot event condition is being edited, the  button is displayed

in place of this button.

Closes the Snap Shot dialog box.

If a snapshot event condition is not being created/changed/deleted, this button is

displayed.

Even if a snapshot event condition is being edited, the dialog box closes without

the snapshot event condition being entered.  The  ESC  key has the same

operation.

Closes the Snap Shot dialog box.

If a snapshot event condition has been created/changed/deleted, after that, the

 button becomes this button.

Even if there is a snapshot event condition that is being edited, the dialog box

closes without the snapshot event condition being entered.  The  ESC  key has

the same operation.

Opens the help window.

Opens the Event dialog box in the select mode and selects the event condition to

be set.
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Opens the Event Link dialog box in the select mode and selects the event link

condition to be set.

Displays the event contents selected in the snapshot condition setting area or

event manager area by opening the corresponding setting dialog box.

The  button is enabled only when the focus is on the snapshot

condition setting area or the event manager area, and when a single event is

selected.  In cases other than that, it is dimmed and cannot be clicked.

Deletes an event selected in the snapshot condition setting area or event manager

area.

The  button is enabled only when the focus is on the snapshot

condition setting area or the event manager area, and when an event is selected.

In cases other than that, it is dimmed and cannot be clicked.

The  DEL  key has the same operation.

Expand Displays the event manager area.  Expands the size of the dialog box.

When the event manager area is not displayed, this button is displayed in place of

the  button.

Does not display the event manager area.  Shrinks the size of the dialog box.

When the event manager area is displayed, this button is displayed in place of the
Expand  button.

Adds the event condition or event link condition selected in the event manager

area to the selected position in the snapshot event condition setting area.

Events other than the event condition or event link condition cannot be added.

Opens the Event Info dialog box.

The  button rearranges events in name order and displays them.

The  button rearranges the events in order by kind and displays

them.

The  button displays the events in the order in which they were

entered without rearranging them.
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The  button changes the event manager area to the detailed display

mode.

The  button changes the event manager area to the list display

mode.

The  button or the  ESC  key closes the dialog box.

Opens the Set Other dialog box.

Clicking each button opens the Event Manager and the Event, Event Link, Break,

Trace, DMM or Timer dialog box, and closes the Set Other dialog box.

Close the dialog box by clicking the  or  and return to

the Snap Shot dialog box.
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Timer Dialog Box

General

Displays the result of measuring execution time, and registers and sets timer event conditions.

The timer event condition registered in this dialog box is automatically registered to the Event Manager.

Opening method

This dialog box can be opened by the following methods.

•  In the main window

Select [Event] → [Timer…] from the menu bar.

Press the  GRPH  +  N , and  I  keys in that order.

Click the  button on the toolbar.

•  In the Event dialog box

Click the  button.

Press the shortcut keys  GRPH  +  I .

• Execute one of the following operations in the event manager area in the Event, Event Link, Break, Trace,

Snap Shot, or DMM dialog box.

Select the timer event condition and click the  button.

Select the timer event condition and press the shortcut keys  GRPH  +  O .

Double-click the timer event condition.

• Execute one of the following operations in the Event Manager.

Select the timer event condition and click the  button.

Double-click the timer event condition.

• Execute one of the following operations in the New Event dialog box or Set Other dialog box.

Click the  button.

Press the shortcut keys  GRPH  +  I .



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14910EJ1V0UM00328

Window

Figure 6-67.  Timer Dialog Box

In the case of display of the event manager area

(1) Timer event name setting area (5) Timer rate setting area

(2) Timer condition setting area (6) Timer out time setting area

(3) Timer display unit select area (7) Event manager area

(4) Execution time display area

Function

Displays the result of measuring execution time, and registers and sets timer event conditions.

The result of measuring execution time is displayed by selecting the set timer event condition.

Up to 256 timer event conditions can be entered.  However, the number of timer event conditions that can be used

simultaneously is 16.

Timer event conditions become valid automatically when they are entered.  However, if the number of timer event

conditions exceeds the number that can be used simultaneously, or if the number of event conditions or event link

conditions in use exceeds the number that can be used simultaneously, the timer event conditions are entered in the

disabled state.  Also, in this case, a timer event condition cannot be enabled.

The execution time from the start of the program to occurrence of a break can be displayed.  It can be displayed by

selecting “Run-Break” in the timer event name setting area.

A timer event condition is set only when the timer is in the enabled state.

(1)

(2)

(3)

(5)

(4)

(6)

(7)
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If the timer is disabled without checking [Option] → [Timer ON] on the menu bar in the main window, the timer will

not be executed.  However, “Run-Break” is not affected by the timer’s on/off status.  “Run-Break” is included in the

number of timer events that can be enabled simultaneously.  If there is a vacancy in the setting numbers, “Run-Break”

is always enabled and can be used.

During emulation, in order to stop the currently operating timer, select [Run] → [Timer Stop] from the menu bar.

Also, during emulation, in order to run the currently stopped timer, select [Run] → [Timer Start] from the menu bar.

These two menus toggle and their display changes according to the current timer state.

This dialog box consists of the following areas.

• Timer event name setting area

• Timer condition setting area

• Timer display unit select area

• Execution time display area

• Timer rate setting area

• Timer out time setting area

• Event manager area

The function of each area is explained below.

(1) Timer event name setting area

This area sets a timer event name and selects a timer event condition.

When entering a timer event condition, it is necessary to set a timer event name.

Timer event names of up to 8 alphanumeric characters can be set.

The timer event name “Run-Break”, which displays the execution time from the start of execution to

occurrence of a break, is registered from the beginning (this timer event name, however, is not displayed in

the Event Manager).

When displaying timer event conditions which have already been created, either type the timer event name of

the already created timer event condition in the text box or select from the drop-down list in the timer event

name setting area.

Clicking the  mark in the timer event name setting area switches between enabling or disabling the timer

event condition.

The relationship between the color of the character in the  mark and the status is shown below.
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Color of Character in  Mark Condition

Red Indicates that the timer event condition has been enabled.

A timer event occurs if the condition is satisfied.

Black Indicates that the timer event condition has not been enabled.

No timer event occurs even if the condition is satisfied.

Gray Indicates that the timer event condition is currently being edited and

that it has not been entered.

Yellow Indicates that the timer event is an event which is in the hold state.

An event in the hold state is in a state where the symbol specified by

the event condition by program download, etc. cannot be referred to.

(2) Timer condition setting area (only when the IE-78K0-NS-PA is installed in the IE-78K0-NS or the IE-

78K0-NS-A/IE-78K0S-NS-A is used)

This area sets an event condition for the timer.

Start Event: Sets event condition or event link condition to start time measurement.

End Event: Sets event condition or event link condition to end time measurement.

The number of event conditions and event link conditions that can be entered in the timer condition setting

area is one condition for each of the start and end conditions.

Carry out setting of the timer condition by either of the following methods.

• Click  and open the Event dialog box in the select mode, then select the event condition

which is to be set.

• Click  and open the Event Link dialog box in the select mode, then select the event link

condition to be set.

• Select an event condition in the event manager area and click , or make the setting by drag-

and-drop.

If an event condition or an event link condition is already set in the timer condition setting area, it is replaced

with the newly set event condition or event link condition.

When setting the event condition or event link condition by drag-and-drop, besides the event manager area in

the Timer dialog box, it is possible to set it from the event manager area and Event Manager in each setting

dialog box.

When the focus is on the timer condition setting area, click the  button, or press the

 DEL  key to delete the event condition selected in [Start Event:] or [End Event:].

It is possible to move the event condition or event link condition in [Start Event:] and [End Event:] in the timer

condition setting area by a drag-and-drop operation.

Selecting an event condition or event link condition selected in [Start Event:] or [End Event:] in the timer

condition setting area and clicking  or double-clicking it opens the Event dialog box and displays

the contents of the event condition or event link condition.

The timer condition setting area is left blank when there is a newly created timer event condition.
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(3) Timer display unit select area

This area selects the timer measurement results display unit.

The unit can be selected from the following five types.

nsec: Measurement results are displayed in nanosecond units.

usec: Measurement results are displayed in microsecond units.

msec: Measurement results are displayed in millisecond units.

sec: Measurement results are displayed in second units.

min: Measurement results are displayed in minute units.

nsec is selected for a newly created timer event condition.

(4) Execution time display area

This area displays the execution time and execution count of the program.

Execution time can be measured up to 14 minutes (in 0.08 µs units from 0.16 to 204 µs of the resolution).

The execution count can be measured up to 65,535 counts.

If measurement is not conducted or if the measurement results are cleared, it is shown as a blank.

If the measurement results overflow, the message “Timer measurement overflowed!” is displayed.

The following functions can be used by operating each button.

• By clicking , the measurement results can be cleared.

• “Run-Break” measurement results cannot be cleared.  They are cleared automatically when execution

starts.

• By clicking , the measurement results can be copied to the clipboard in text format.

• By clicking , the Timer Result dialog box, which displays the selected timer event conditions

or the “Run-Break” measurement results, is displayed.
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(5) Timer rate setting area

This area sets the timer rate value to measure the execution time. The minimum rate value is 160 nsec

(default) which can be increased in 80 nsec units.

(6) Time out time setting area

When the Timer Out Break is on, time out time can be set, but not when the Timer Out Break is off.

When the measurement time of a period (from timer start event generation to timer end event generation)

exceeds the time out time, execution ends. Up to 24 hours can be set.

(7) Event manager area

This displays a list of each of the entered event and event link conditions, and break, trace, snapshot, DMM,

and timer events.

An event condition or event link condition displayed in the event manager area can be set in the timer

condition setting area by clicking .

Also, an event condition or event link condition in the event manager area can be dragged directly to the timer

condition setting area.

When the focus is on the event manager area, select the event icon and click  or press the

 DEL  key to delete the selected event.

When the focus is on the event manager area, selecting an event icon and clicking  or double-

clicking an event icon opens the setting dialog box corresponding to the selected event and displays the

contents of the event.

By clicking , it is possible to select the event manager area display mode or sequencing.



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14910EJ1V0UM00 333

Function buttons

Closes the Timer dialog box.

If there is a timer event condition that is being edited, it is entered automatically

and the dialog box is closed.

A timer event condition becomes enabled as soon as it is entered.

Newly creates a timer event condition.

A timer event name is generated automatically and a newly created timer event

condition is prepared.  After it is created, be sure to enter the timer event condition

using the  or the  button.

Enters a timer event condition.

When a new timer event condition has been created or when the contents of a

timer event condition have been changed, be sure to enter the timer event

condition using this button.

If timer event conditions that have already been entered are displayed, it changes

to either the  button or  button.

A timer event condition becomes enabled as soon as it is entered.

Enables a timer event condition.

This button is displayed in cases where a timer event condition is in the disabled

state.

It changes to either the  button or the  button.

Disables a timer event condition.

This button is displayed in cases where a timer event condition is in the enabled

state.

It changes to either the  button or the  button.

Clears the contents of a timer event condition.

If a timer event condition is entered but not edited, this button is displayed.  It

changes to the  button.

Returns the contents of a timer event condition to the original contents.

If a timer event condition that has not been entered is displayed, all the area is

made blank except the timer event name, or the settings return to the default

settings.

If a timer event condition is being edited, this button is displayed.  It changes to

the  button.

Closes the Timer dialog box.

If a timer event condition has not been created/changed/deleted, this button is

displayed.

Even if a timer event condition is being edited, the dialog box closes without the

timer event condition being entered.  The  ESC  key has the same operation.
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Closes the Timer dialog box.

If a timer event condition has been created/changed/deleted, after that, the

 button becomes this button.

Even if there is a timer event condition that is being edited, the dialog box closes

without the timer event condition being entered.  The  ESC  key has the same

operation.

Opens the Help window.

Opens the Event dialog box in the select mode and adds to set the event condition

either in [Start Event:] or in [End Event:] in the timer condition setting area.

The area where the event condition is added becomes the selected area when

 is clicked.

Opens the Event Link dialog box in the select mode and adds to set the event link

condition either in [Start Event:] or in [End Event:] in the timer condition setting

area.

The area where the event condition is added becomes the selected area when

 is clicked.

Displays the event contents selected in [Start Event:] or in [End Event:] in the

timer condition setting area or event manager area by opening the corresponding

setting dialog box.

Operation is the same as double-clicking the event icon.

If an event icon is not selected, or if multiple events are selected, selection cannot

be made.

Deletes an event selected in [Start Event:] or in [End Event:] in the timer condition

setting area or event manager area.

The  DEL  key has the same operation.

Expand Displays the event manager area.  Expands the size of the dialog box.

When the event manager area is not displayed, this button is displayed in place of

the  button.

Does not display the event manager area.  Shrinks the size of the dialog box.

When the event manager area is displayed, this button is displayed in place of the
Expand  button.

Adds the event condition or event link condition selected in the event manager

area to the selected position in [Start Event:] or in [End Event:] in the timer

condition setting area.

The area where the event condition is added becomes the selected area when

 is clicked.
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Opens the Event Info dialog box.

The  button rearranges events in name order and displays them.

The  button rearranges the events in order by kind and displays

them.

The  button displays the events in the order in which they were

entered without rearranging them.

The  button changes the event manager area to the detailed display

mode.

The  button changes the event manager area to the list display

mode.

The  button or the  ESC  key closes the dialog box.

Opens the Set Other dialog box.

Clicking each button opens the Event Manager and the Event, Event Link, Break,

Trace, Snap Shot, or DMM dialog box, and closes the Set Other dialog box.

Close the dialog box by clicking  or  and return to the

Timer dialog box.
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This button clears the measurement results.

When measurement is not being performed, it is dimmed and cannot be clicked.

It is also dimmed and cannot be clicked when a user program is being executed.

Copies measurement results to the clipboard in text format.

Displays the Timer Result dialog box, which displays the selected timer event

condition or “Run-Break” measurement results.



CHAPTER  6    WINDOW  REFERENCE

User’s Manual  U14910EJ1V0UM00 337

Timer Result Dialog Box

General

Displays the execution time measurement results.

Opening method

This dialog box can be opened by the following methods.

• Select a timer event condition or “Run-Break” in the Timer dialog box and execute one of the following

operations.

Click the  button.

Press the shortcut keys  GRPH  +  V .

Window

Figure 6-68.  Timer Result Dialog Box

Function

Displays the execution time measurement results.

This displays the execution time measurement results for the timer event condition or “Run-Break” set in the Timer

dialog box.

The Timer Result dialog box corresponds 1 to 1 with a timer event condition or “Run-Break” and multiple dialog

boxes can be opened simultaneously.  The number that can be opened simultaneously is 256 for timer event

conditions and 1 corresponding to “Run-Break”, for a total of 257.  However, the number of measurements that can be

taken simultaneously for both timer event conditions and “Run-Break” is 17.

The Timer Result dialog box consists of the following area.

• Execution time display area

The function of this area is explained below.
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(1) Execution time display area

This area displays the measurement results of the execution time and execution count of the program.

Execution time and execution count display the cumulative execution time, pass count, and average

execution time of the measurement period specified by the start event and end event conditions.

Also, the execution time is displayed in the unit set for the timer event condition.

Measurement Result Contents Remark

Pass Displays the pass count. Not measured during "Run-Break".

Total Displays the cumulative execution time.

Average Displays the average execution time. Not measured during "Run-Break".

MaxNote Displays the maximum execution time. Not measured during "Run-Break".

MinNote Displays the minimum execution time. Not measured during "Run-Break".

Note  ID78K0-NS only.

If measurement is not conducted or if the measurement results are cleared, it is shown as a blank.

If the measurement results overflow, the message “Timer measurement overflowed!” is displayed.

Function buttons

Clears the timer measurement results.

When timer measurement is not being performed, it is dimmed and cannot be

clicked.

It is also dimmed and cannot be clicked when a user program is being executed.

A “Run-Break” cannot be cleared.  It is cleared automatically when program

execution starts.

Copies timer measurement results to the clipboard in text format.

Closes the Timer Result dialog box.  It becomes the default button.  The  ESC  key

has the same operation.

Opens the help window.
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DMM Dialog Box

General

Sets dynamic memory modification (DMM).

This dialog box is only valid when the IE-78K0-NS-PA is installed in the IE-78K0-NS or the IE-78K0-NS-A/IE-

78K0S-NS-A is used.

Opening method

This dialog box can be opened by the following methods.

• In the main window

Select [Event] Æ [DMM] from the menu bar.

Press the  GRPH  +  N  and  D  keys in that order.

Window

Figure 6-69.  DMM Dialog Box

(1) Event name setting area (4) Data setting area

(2) DMM event name setting area (5) Data size setting area

(3) Address setting area (6) Event manager area

(1)

(2)

(3)

(4)

(5) (6)
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Function

Registers and displays DMM event conditions.

DMM is used to write arbitrary data to a specified address when a specified event occurs during emulation.

This dialog box consists of the following areas.

• Event name setting area

• DMM event name setting area

• Address setting area

• Data setting area

• Data size setting area

• Event manager area

The function of each area is explained below.

(1) Event name setting area

This area sets an event name and selects an event condition.

When entering an event condition, it is necessary to set an event name. An event name may consist of up to

eight alphanumeric characters.

When displaying event conditions which have already been created, either type the event name of the

already created event name in the text box or select the event condition from the drop-down list in the event

name setting area.

In the select mode, the selected event condition can be set in the event condition setting area of the original

setting dialog box that called the Event dialog box.

The mark  M.  on the left side of the event name setting area shows the use conditions of the event condition.

If the character in the mark  M.  is red, it indicates that that DMM event condition is valid.

If the character in the mark  M.  is black, it indicates that that DMM event condition is invalid.

If the character in the mark  M.  is yellow, it indicates that that DMM event condition is in the hold state.  An

event in the hold state is in a state where the symbol specified by the event condition by program download,

etc. cannot be referred to.

(2) DMM event name setting area

This area sets event conditions for DMM.

Up to 16 DMM event conditions can be set (8 execution events and 8 access events).
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(3) Address setting area

This area sets the address to which data is written after the event has occurred.

(4) Data setting area

This area sets the data to be written after the event has occurred.

(5) Data size setting area

This area sets the size of the data to be written after the event has occurred.

The size can be selected from “Byte” or “Word”.

Example In the case of writing 0xff to 0xFBoo: 0xff is written to 0xFBoo when Byte is specified, and 0xff is

written to 0xFBoo and 0x00 to 0xFBo1 when Word is specified.

(6) Event manager area

This area displays a list of each of the entered event and event link conditions, and break, trace, snapshot,

DMM and timer events.

An event condition or event link condition displayed in the event manager area can be set in the delay trigger

condition setting area, trace start condition setting area, trace end setting condition area, qualify trace

condition area, etc. by clicking  Add .

Also, an event condition or event link condition in the event manager area can be dragged directly to the each

event condition setting area.

When the focus is on the event manager area, select the event icon and click  or press the  DEL

key to delete the selected event.

When the focus is on the event manager area, selecting an event icon and clicking  or double-

clicking an event icon opens the setting dialog box corresponding to the selected event and displays the

contents of the event.

By clicking , it is possible to select the event manager area display mode or sequencing.
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Function buttons

Closes the DMM dialog box.

If there is a DMM event condition that is being edited, it is entered automatically

and the dialog box is closed.

This is the default button.

Newly creates a DMM event condition.

A DMM event name is generated automatically and a newly created DMM event

condition is prepared.  After it is created, be sure to enter the DMM event

condition using the  or the  button.

Enters a DMM event condition.

When a new DMM event condition has been created or when the contents of a

DMM event condition have been changed, be sure to enter the DMM event

condition using this button.

If DMM event conditions that have already been entered are displayed, it changes

to either the  button or  button.

A DMM event condition becomes enabled as soon as it is entered.

Enables a DMM event condition.

This button is displayed in cases where a DMM event condition is in the disabled

state.

It changes to either the  button or the  button.

Disables a DMM event condition.

This button is displayed in cases where a DMM event condition is in the enabled

state.

It changes to either the  button or the  button.

Clears the contents of a DMM event condition.

If a DMM event condition is entered but not edited, this button is displayed.  It

changes to the  button.

Returns the contents of a DMM event condition to the original contents.

If a DMM event condition that has not been entered is displayed, all the area is

made blank except the DMM event name.

If a DMM event condition is being edited, this button is displayed.  It changes to

the  button.

Closes the DMM dialog box.

If a DMM event condition has not been created/changed/deleted, this button is

displayed.

Even if a DMM event condition is being edited, the dialog box closes without the

DMM event condition being entered.  The  ESC  key has the same operation.
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Closes the DMM dialog box.

If a DMM event condition has been created/changed/deleted, after that, the

 button becomes this button.

Even if there is a DMM event condition that is being edited, the dialog box closes

without the DMM event condition being entered.  The  ESC  key has the same

operation.

Opens the help window.

Opens the DMM dialog box in the select mode and adds the event condition

specified in the DMM condition setting area.  The area to which the event

condition is added is the area selected when the  button is clicked.

Opens the DMM dialog box in the select mode and adds the event link condition

specified in the DMM condition setting area.  The area to which the event link

condition is added is the area selected when the  button is clicked.

Displays the event contents selected in the DMM condition setting area or event

manager area by opening the corresponding setting dialog box.

The  button is only valid when the focus is on the DMM event setting

area or event manager area and when one event has been selected.  In all other

cases, the button is dimmed and items cannot be selected.

Opens the DMM dialog box in the select mode and deletes an event selected in

the DMM condition setting area or event manager area.

The  button is only valid when the focus is on the DMM event setting

area or event manager area and when an event has been selected.  In all other

cases, the button is dimmed and items cannot be selected.

The  DEL  key has the same operation.

Expand Displays the event manager area.  Expands the size of the dialog box.

When the event manager area is not displayed, this button is displayed in place of

the  button.

Does not display the event manager area.  Shrinks the size of the dialog box.

When the event manager area is displayed, this button is displayed in place of the
Expand  button.
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Opens the Event Info dialog box.

The  button rearranges events in name order and displays them.

The  button rearranges the events in order by kind and displays

them.

The  button displays the events in the order in which they were

entered without rearranging them.

The  button changes the event manager area to the detailed display

mode.

The  button changes the event manager area to the list display

mode.

The  button or the  ESC  key closes the dialog box.
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Pass Count Dialog Box

General

Sets the pass count.

Opening method

This dialog box can be opened by the following methods.

• In the main window

Select [Event] Æ [Pass Count…] from the menu bar

Press the shortcut keys  GRPH  +  N  and  P .

Window

Figure 6-70.  Pass Count Dialog Box

Function

Sets and displays the pass count.

The pass count setting is used to stop execution of the program and tracer after a specified number of events have

occurred.

The Pass Count dialog box consists of the following area.

• Pass count setting area

The function of this area is explained below.

(1) Pass count setting area

This area sets and displays the pass count.

The settable range is from 1 (default) to 255.
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Function buttons

Closes the Pass Count dialog box after setting the edited pass count.

This is the default button.

Returns the pass count to the previous value.

Closes the Pass Count dialog box without setting any changes made to the pass

count value.

The  ESC  key has the same operation.

Opens the help window.
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Delay Count Dialog Box

General

Sets the delay count.

Opening method

This dialog box can be opened by the following methods.

• In the main window

Select [Event] Æ [Delay Count...] from the menu bar

Press the shortcut keys  GRPH  +  N  and  D .

Window

Figure 6-71.  Delay Count Dialog Box

Function

Sets and displays the delay count.

The delay count setting is used to stop execution of the program and tracer after a stop condition event is satisfied

and a trace is performed for a specified count value.

The Delay Count dialog box consists of the following area.

• Delay count setting area
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The function of this area is explained below.

(1) Delay count setting area

This area sets and displays the delay count.

Select from the following three settings.

| FIRST: The trigger pointer is placed at the start of the trace data, and tracing stops after

about 8000 frames have been traced.

| MIDDLE: The trigger pointer is placed in the middle of the trace data, and tracing stops after

about 4,000 frames have been traced.

|#LAST: The trigger pointer is placed at the end of the trace data, and tracing stops

immediately.

Function buttons

Closes the Delay Count dialog box after setting the edited delay count.

This is the default button.

Returns the delay count to the previous value.

Closes the Delay Count dialog box without setting any changes made to the delay

count value.

The  ESC  key has the same operation.

Opens the help window.
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Reset Debugger Dialog Box

General

Initializes the debugger, emulation CPU, and symbol information.

Opening method

This dialog box can be opened by the following methods.

•  In the main window

Select [File] → [Debugger Reset…] from the menu bar.

Press the  GRPH  +  F , and  R  keys in that order.

Window

Figure 6-72.  Reset Debugger Dialog Box

Function

Specifies, by using a check box, whether the debugger, emulation CPU, or symbol information is initialized.  As the

default, only the debugger is initialized.

The Reset Debugger dialog box consists of the following area.

• Reset subject select area

The function of this area is explained below.

(1) Reset subject select area

This area selects the subject to be reset from the following.
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Selected Item Description

Debugger Initializes and restarts the debugger (default).

Symbol Resets symbol information.

Target CPU Resets emulation CPU.

Function buttons

Initializes the selected subject.

Ignores the setting and closes this dialog box.

Opens the help window.
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About Dialog Box

General

Displays the version information of the debugger.

Opening method

This dialog box can be opened by the following methods.

•  In the main window

Select [Help] → [About…] from the menu bar.

Press the  GRPH  +  H , and  A  keys in that order.

Window

Figure 6-73.  About Dialog Box

Function

Displays the version of the debugger and that of the device files, GUI, debugger DLLs, assembler DLLs, executor,

and packet DLLs.

Function button

Closes this dialog box.
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Exit Debugger Dialog Box

General

Terminates the debugger.

When terminating the debugger, the debugging environments can be saved in a project file.

Opening method

This dialog box can be opened by the following methods.

•  In the main window

Select [File] → [Exit] from the menu bar.

Press the  GRPH  +  F , and  X  keys in that order.

Also, the Exit Debugger dialog box opens when a compulsory close is executed, such as when Windows is closed

or when an application is closed in the task list.

Window

Figure 6-74.  Exit Debugger Dialog Box

Function

Specifies, by using a check box, whether the current debugging environments are saved in a project file or not

when the debugger is terminated.  As the default, the debugging environments are not saved in a project file.  If the

project file has been saved or loaded during a debugging operation, the default is to save the debugging

environments.

When the check box is checked and the  button is clicked, the Project File Save dialog box is opened,

the current debugging environments are saved in the project file, and all the windows are closed.  The debugger is

then terminated.

If the project file has been saved or loaded during a debugging operation, however, the Project File Save dialog

box is not opened, and the debugging environments are saved in the project file.

If the  button is clicked without checking the check box, all the windows are closed, and the debugger is

terminated.

Note that the Exit Debugger dialog box can be set not to open in the Debugger Option dialog box.
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Function buttons

When the check box is checked, the Project File Save dialog box is opened, the

current debugging environments are saved in the project file, and all the windows

are closed.  The debugger is then terminated.  When the check box is not

checked, all the windows are closed, and the debugger is terminated.

Closes this dialog box without performing anything.

Opens the help window.
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Error/Warning Dialog Box

General

Opens if an error or a warning occurs, to inform the user to check the message.

Window

Figure 6-75.  Error/Warning Dialog Box

Function

Displays the contents of the error or warning in the message display area.

Refer to APPENDIX C  ERROR MESSAGE LIST  if an error occurs.

Function button

Closes this dialog box.
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APPENDIX  A    DEBUGGING  WITH  ID78K0-NS  AND ID78K0S-NS

This appendix explains the basic debugging operation using the ID78K0-NS and ID78K0S-NS.

For the details of each window and dialog box mentioned in this section, refer to CHAPTER 6  WINDOW

REFERENCE.

(1) Setting debug environment

Set the operating environment of debugger.

If a previous debug environment has been saved to a project file, the debug environment can be restored by

loading that file.  The procedure differs as follows depending on whether a project file is used or not.

(a) When project file is not used

<1> Set all the items in the Configuration dialog box.

<2> Set the extended options in the Extended Option dialog box.

<3> Set the debug options in the Debugger Option dialog box.

(Caution Always specify the startup symbol.)

(b) When project file is used

•••• When project file is used at startup
<1> Click  Project…  in the Configuration dialog box.

→ The Project File Load dialog box will open.

<2> Specify the project file name and click  OK .

→ The project file will be loaded.

The following procedure can also be used.

<1> Select [Run] from the Start menu in Windows.

<2> Use the  Browse  button to specify the file to be executed, IDK032A.EXE (“IDK0S32A.EXE” for the

ID78K0S-NS).

<3> After IDK032A.EXE (“IDK0S32A.EXE” for the ID78K0S-NS), specify the name of the project file to

be used

(eg. A:\nectools32\bin\IDK032A.EXE∆B:\Test\Test1.prj (∆ = space)).

(A:\nectools32\bin\IDK0S32A.EXE∆B:\Test\Test1.prj (∆ = space) for the ID78K0S-NS.).

<4> Click  OK .

•••• When project file is used during debugging

<1> Select [File] → [Project] → [Open] in the main window, or click the        button.

→ The Project File Load dialog box will open.

<2> Specify the project file name and click  OK .

→ The project file will be loaded.

(2) Download load module file

(a) Download the load module file to be debugged.

→ Download dialog box

(b) Confirming loaded files

→ Load Module List dialog box
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(3) Display disassemble result

Display the result of disassembling the downloaded user program.

→ Assemble window

The method of displaying the disassemble display label column and mnemonic column can be changed.

→ Debugger Option dialog box

(4) Display source program

Display the source program.  A program whose source can be debugged must have debug information

compiled with the -g option specified.

→ Source window

(a) Setting source path information, display font, and source file extension

→ Debugger Option dialog box

(b) Selecting source file

→ Browse dialog box

(c) Source file and disassemble

→ Select [View] → [Mix] when the source text file is the current window.

(5) Setting of event

(a) Registering event conditions and event link conditions

→ Event dialog box

Event Link dialog box

(b) Setting of event conditions

Set event conditions by using the event icons in the Event Manager or in the event manager area of

various event setting dialog boxes (however, breakpoints can be set in the Source window/Assemble

window).

• Trace event condition

→ Trace dialog box

• Break event condition

→ Break dialog box

• Timer event condition

→ Timer dialog box

• Snap event condition

→ Snap Shot dialog box

• DMM event condition

→ DMM dialog box

(c) Checking setting of event conditions

→ Event Manager, the event manager area in each event setting dialog box
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(6) Executing user program

By executing the user program, the value of the PC advances to the set breakpoint, break event or forced

break.

• Types of execution

→ Execution control buttons on the toolbar in the main window, or [Run] menu

(7) Checking trace data

→ Trace View window

(8) Editing, checking, and changing contents of memory

→ Memory window

Memory Copy dialog box

Memory Fill dialog box

Memory Compare dialog box

Memory Compare Result dialog box

(9) Registering, checking, and changing variable values

→ Quick Watch dialog box

Add Watch dialog box

Watch window

Local Variable window

(10) Checking contents of stack

→ Stack window

(11) Checking and changing registered contents of register value

→ Register window

SFR window

The PC register value can also be checked in the Source and Assemble windows.

(12) Checking and changing contents of SFR

→ SFR window

SFR Select dialog box

(13) Registering, checking, and changing user-defined I/O port value

→ Add I/O Port dialog box

SFR window

(14) Changing mnemonics and executing on-line assemble

→ Assemble window

Source window

(15) Checking execution time of user program

→ Timer dialog box

Timer Result dialog box

Trace View window
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(16) Checking coverage measurement result

→ Coverage window

Coverage-Clear dialog box

Coverage-Condition Setting dialog box

Coverage-Efficiency View dialog box

(17) Searching character string in each window

→ Source Search dialog box

Assemble Search dialog box

Memory Search dialog box

Trace Search dialog box

Coverage Search dialog box

(18) Referencing “display file” saved in previous debugging process

→ View File Load dialog box

(19) Saving screen contents to “display file” during debugging

→ View File Save dialog box

(20) Uploading memory contents and coverage results

→ Upload dialog box

(21) Saving debug environment to project file

→ Project File Save dialog box

(22) Terminating ID78K0-NS or ID78K0S-NS

→ Exit Debugger dialog box
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APPENDIX  B    TERMINOLOGY

Words and window types (refer to CHAPTER 6  WINDOW REFERENCE) used in this document are described

below.

B.1  Terminology

The following words are described in this document.

• Debugging mode

• Current window

• Delimiter symbol (separator)

• Program

• Current program

• File

• Current file

• Function

• Current function

• Structure

• Stack frame number

• Line

• Register name

• Numeric value

• Address

• Symbol

• Expression and operator

• Character set

Each word and the input conventions are explained below.
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(1) Debugging mode

Execution of the user program can be controlled in the following three debugging modes.

• Source mode

Step execution is performed in units of one line of a source text.

• Instruction mode

Step execution is performed in instruction units.

• Automatic mode

This mode automatically switches between source mode and instruction mode.

In this mode, when the Source window is active, step execution is performed in units of 1 line of source

text (instruction units for mixed display), and when the Assemble window is active, step execution is

performed in instruction units.  When neither window is active, this mode becomes instruction mode.

These three debugging modes are selected from the “Option menu” of the main window.  When starting the

debugger, the automatic mode is selected as the default.

(2) Current window

The current window is the window in which an operation is currently being performed.  In this window,

information can be input from the keyboard and menus can be selected.

(3) Delimiter symbol (separator)

A file, function, variable, or line can be specified by using the delimiter symbols listed in Table B-1.

Table B-1.  Delimiter Symbols

Symbol Specification

# Used as a separator between file names and variable/function names and line numbers.

$ Used as a separator between load module names and file, variable, and function names.

(4) Program

A program is the executable unit that is subject to debugging.  The ID78K0-NS or ID78K0S-NS deals with

each load module file specified when downloading as one program.  The name of a program is specified by

using the name of the load module file that is downloaded.

(5) Current program

The current program is the program that contains the instruction for a break currently taking place (i.e., the

instruction indicated by the program counter (PC)).

When specifying a file in the current program, specifying the program name may be omitted.

(6) File

The allowable number of characters in a file name is up to 127 characters in a full path.

Depending on the file type, it may be possible to specify a file name with more than 127 characters.
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(7) Current file

The current file is the source file that has the instruction for a break currently taking place (i.e., the instruction

indicated by the program counter (PC)).

When specifying a line or function in the current file by using a command, the file name can be omitted.

(8) Function

Functions constitute a C source program.

(9) Current function

The current function is the function that has the instruction for a break currently taking place (i.e., the

instruction indicated by the program counter (PC)).  When accessing a local variable in the current function,

specifying the function name can be omitted.

(10) Structure

Structures and unions of the C language are generically referred to as “structures”.  When a structure or

union variable is used without explicitly specifying a member, the term “structure” is used.

(11) Stack frame number

A stack frame number is a decimal number starting from 1.  The stack contents are displayed numbered.  The

shallower the nesting of the stack, the higher the number.  Therefore, a function having a stack number 1 less

than the stack number of another function calls that function.

(12) Line

A line is specified to identify a certain line in the source file.

Line numbers are specified by an integer constant that starts from 1.

(13) Register name

A register name is specified by the absolute name of a system register or general-purpose register of the

78K/0 and 78K/0S Series microprocessors listed in Table B-2, or by the alias of a register.
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Table B-2.  Register Set of 78K/0 and 78K/0S Series

Register NameRegister Type

Absolute Name Alias

PC

PSW

System registers

SP

r0 zero

r1

r2

r3 sp

r4 gp

r5 tp

r6

General-purpose

registers

r7

(14)Numeric value

The following four types of numeric values can be used.

• Binary Input format: nY

n…nY (n = 0, 1)

• Octal Input format: nO

n…nO (n = 0 to 7)

nQ

n…nQ (n = 0 to 7)

• Decimal Input format: n

n…n

nT

n…nT (n = 0 to 9)

• Hexadecimal Input format: n

n…n

nH

n…nH

0xn

0xn…n (n = 0 to F)

Cautions 1. Suffixes (Y, O, Q, T, H, 0x) and the alphabetical characters in hexadecimal numbers are

not case sensitive.

2. If the first character is one of A to F, a 0 must be affixed in front.

3. The radix in the input column switches between decimal and hexadecimal in

accordance with the default radix.
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(15) Address

• An address is specified by directly specifying a numeric value.

• An address can also be specified by using a symbol or expression.

• When specifying an address by using a numeric value, hexadecimal, decimal, octal, or binary numbers

can be used.

(16) Symbol

• A symbol consists of characters A to Z, a to z, @, _ (underline), and 0 to 9.

• A symbol must begin with a character other than numerals 0 through 9.

• This software distinguishes between uppercase (A to Z) and lowercase (a to z) characters.

• A symbol name can consist of up to 256 characters.

• If a symbol exceeding 256 characters is specified, the first 256 characters are valid.

• A symbol is defined by loading a load module file.

• Symbols can be classified into the following types by the valid range.

(a) Global symbols (assembly language, C language)

(b) Static symbols (C language)

Static symbols in files

Static symbols in functions

(c) Local symbols (C language)

Local symbols in files

Local symbols in functions

Local symbols in blocks

• The following symbols exist in each of the languages used.

(a) Assembly language

Label names

(b) C language

Variable names (including pointer function names, enumerate type variable names, array names,

structure name, and union names)

Function names, label names

Array elements, structure elements, union elements (if the symbol is an array, structure, or union)

• A symbol can be described instead of an address and numeric value.

• The valid range of symbols is determined based on the source debugging information when the source file

is assembled or compiled.

• A global symbol only describes a symbol name.

• A local symbol is expressed as a pair with a file name.
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(17) Expression and operator

<Expression>

• An expression consists of constants, register names, SFR names, and symbols combined by operators.

• If an SFR name, label name, function name, or variable name is described as a symbol, an address is

calculated as the value of the symbol.

• Elements constituting an expression, other than operators, are called terms (constants and labels).  Terms

are called the first term, second term, and so on, in the sequence they are described, starting from the one

on the left.

<Operator>

• The following operators of C language can be used.

Arithmetic operators

Symbol Meaning Remark

+ Addition Returns sum of values of first and second terms

− Subtraction Returns difference in value between first and second terms

* Multiplication Returns product of values of first and second terms

/ Division Divides value of first term by value of second term, and returns integer of

result

MOD, % Remainder Divides value of first term by value of second term, and returns remainder

of result

− sign Unary operation (negative) Returns two’s complement of value of term

+ sign Unary operation (positive) Returns two’s complement of value of term

Logical operators

Symbol Meaning Remark

NOT

~

Negation NOTs each bit of term, and returns result.

AND

&

Logical product ANDs each bit of values of first and second terms, and returns result

OR

|

Logical sum ORs each bit of values of first and second terms, and returns result

XOR

^

Exclusive logical sum Exclusive-ORs each bit of values of first and second terms, and returns result

Shift operators

Symbol Meaning Remark

SHR

>>

Right shift Right shifts the first term the amount of the value (bit number) expressed by

the second term and returns the result.  The number of higher bits shifted are

replaced with 0.

SHL

<<

Left shift Left shifts the first term the amount of the value (bit number) expressed by

the second term and returns the result.  The number of lower bits shifted are

replaced with 0.
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Byte resolution operators

Symbol Meaning Remark

HIGH Higher byte The higher 8 bits of the term’s lower 16 bits are returned.

LOW Lower byte The lower 8 bits of the term’s lower 16 bits are returned.

Word resolution operators

Symbol Meaning Remark

HIGHW Higher word The higher 16 bits of the term’s 32 bits are returned.

LOWW Lower word The lower 16 bits of the term’s 32 bits are returned.

Others

Symbol Meaning Remark

( Left parenthesis

) Right parenthesis

Executes operation in (  ) before operations outside (  )

Cautions 1. Parentheses “(” and “)” must always be used in pairs.

2. Operations are performed in compliance with the following rules.

• The operation sequence is in accordance with the priority of the operator.

• When the priority of operators is the same, the operation sequence is from left to

right.

• The operation within parentheses is executed before the operations outside the

parentheses.

• Each term of an operation is treated as unsigned 32-bit data.

• All the operation results are treated as unsigned 32-bit data.

• If an overflow occurs during operation, the lower 32 bits are treated as valid, and the

overflow is not detected.

3. The priority of the operator is as follows.

Priority Operator

1 ↑ (, )

2 Higher + sign, – sign, NOT, ~, HIGH, LOW, HIGHW, LOWW

3 *, /, MOD, %, SHR, >>, SHL, <<

4 +, –

5 Lower AND, &

6 ↓ OR, I, XOR, ^
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<Term>

• The following numeric values can be described when a constant is described as a term.

(a) Binary

0Y ≤ numeric value ≤ 11111111111111111111111111111111Y (32 digits)

(b) Octal

0O ≤ numeric value ≤ 37777777777O

(c) Decimal

−2147483648 ≤ numeric value ≤ 4294967295

A negative decimal number is internally converted into two’s complement.

(d) Hexadecimal

0H ≤ numeric value ≤ 0FFFFFFFFH

(18)Character set

With the ID78K0-NS and ID78K0S-NS, the following character set can be used.

Character set

Symbol Description

Uppercase characters A B C D E F G H I J K L M N O P Q R S T U V W X Y ZAlphabet

character Lowercase characters a b c d e f g h i j k l m n o p q r s t u v w x y z

Numerals 0 1 2 3 4 5 6 7 8 9

Alphabet equivalent characters @ _

Special characters . , : ; * / % + − ’ ” < > ( ) ! [ ] & \ ^ | ~ # = $ ? ‘ { }
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Other character set

Character Name Main Usage

. Period Direct member operator, bit position specifier

, Comma Delimiter of operands

* Asterisk Multiplication operator or indirect reference operator

/ Slash Division operator

% Percent Remainder operator

+ Plus Positive sign or addition operator

− Minus Negative sign or subtraction operator

( Left parenthesis Changes operation sequence

) Right parenthesis Changes operation sequence

[ Left bracket Base register specification symbol, array subscript operator

] Right bracket Base register specification symbol, array subscript operator

& Ampersand Address operator or bit AND operator

^ Control Bit XOR operator

| Vertical line Bit OR operator

~ Tilde Complement operator
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B.2  Window Types and Configuration

The ID78K0-NS and ID78K0S-NS debuggers consist of windows and dialog boxes.

Basically, a window can be opened by using an icon, while a dialog box cannot.

B.2.1  Windows

Windows are broadly divided into the following two types.

• Main windows

• MDI child windows

MDI child windows cannot be displayed outside of the main window frame.

B.2.2  Dialog boxes

Dialog boxes can be classified into the following two types.

• Modal dialog boxes

• Modeless dialog boxes

(1) Modal dialog boxes

When this type of dialog box is open, the user cannot access other windows or dialog boxes until the dialog

box is exited.

When the dialog box is closed after the operation in the dialog box has been completed or by selecting the

 Cancel  button of the dialog box, other windows and dialog boxes can be accessed.

(2) Modeless dialog boxes

Unlike a modal dialog box, the user can access other windows and dialog boxes even if the operation in the

dialog box has not been completed.
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APPENDIX  C    ERROR  MESSAGE  LIST

The error messages displayed in the ID78K0-NS and ID78K0S-NS consist of  Error No.  +  Type  +  Message .

Figure C-1.  Display Format of Error Message

When the  OK  button is clicked, the Error Message window is closed, and the operation is performed in

accordance with the message.

The error type is identified by the following three uppercase characters.

Table C-1.  Error Message Type

Type Meaning

A Fatal error (Abort Error).

The processing is aborted and the debugger is terminated.  If this error occurs, the

debugging work cannot be continued.

F Syntax error (Fatal Error).

The processing is aborted, and all open windows and dialog boxes are closed.

W Warning.

The processing is aborted.  Open windows and dialog boxes are not closed.

Table C-2 lists the error messages.

Error number Type Message
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Table C-2.  Error Message List (1/21)

Error No. Type Error Message/Meaning

0002 F This feature is not supported.

This function is not supported.

0100 A Can not communicate with ICE.  Please confirm the installation of the device driver for the PC

interface board.

Communication with the in-circuit emulator cannot be established.  Check that the device driver

for the interface board has been correctly installed.

0101 A Can not find initialization file (expc.ini).

An initialization file (EXPC.INI) cannot be found.

0102 A Host name not found.

No host name is found.

0103 A Data transfer to ICE is timed out.  Please confirm the power of ICE, connection of the interface

cable, or I/O address of the PC interface board.

Data could not be transmitted to the in-circuit emulator.  Check the in-circuit emulator’s power

supply, cable connection, I/O address settings, etc.

0104 A Data receive from ICE is timed out.  Please confirm the power of ICE, connection of the interface

cable, or I/O address of the PC interface board.

The in-circuit emulator returns no response.  Check the in-circuit emulator’s power supply, cable

connection, I/O address settings, etc.

0105 A Failed in reading device file (d0xxx.78k).

The device file (d0xxx.78k) could not be correctly read.

0106 A Illegal data received.

Received data is abnormal.

01a0 A No response from the evachip.  Please confirm the signal of the CLOCK or RESET, WAIT,

HLDRQ and so on.

There was no response from the evaluation chip.  Check that the RESET, WAIT, HLDRQ (etc)

signals or the clock signal are not abnormal.

01a1 A Failed in reading ie703000.ie.

ie703000.ie could not be correctly read.

01a2 A Break board is not connected.

The BK board is not connected.

01a3 A Emulation board is not connected.

The emulation board is not connected.

01a4 A Board configuration of ICE is not consistent.

The board configuration in the in-circuit emulator is not consistent.

01a5 A POD/EM1 board is not connected.

The POD/EM1 board is not connected.

01a6 A Executor is running.

The executor is running.

01a8 A Failed in reading initialization file (expc.ini).

The initialization file (EXPC.INI) has not been correctly read.

01d0 A Failed in starting simulator.

Simulator startup has failed.

01d1 A Not enough memory in starting simulator.

The memory at simulator startup is insufficient.
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Table C-2.  Error Message List (2/21)

Error No. Type Error Message/Meaning

0200 F Verification error.

A verify error.

02a0 F Bus hold error.

The bus is in the hold status.

02d2 F Not enough memory for trace-buffer.

Memory for trace frame cannot be allocated.

0300 F User program is running.

The user program is being executed.

0301 F User program is being breaked.

The user program is undergoing a break.

0302 F User program is being traced.

The user program is being traced.

0303 F Not traced.

Tracer measurement is not performed.

0304 F Trace memory is not set.

The tracer is off.

0306 F No trace block exists.

There is no trace block.

0307 F No event condition exists.

There is no event condition.

0308 F No timer measurement is done.

Timer measurement is not performed.

0309 F No trigger frame exists.

There is no trigger frame.

030a F Tracer is being stopped.

The tracer is stopped.

030b F Specified snap-event has not been registered.

The snap event to be referenced/deleted is not registered.

030d F Timer is running.

The timer is operating.

030e F Memory copy area is overlapped.

The memory copy range has been overlapped.

030f F Trace has been already set.

Trace is already in the ON status.

0310 F Event condition is not set.

No event condition is set.

0311 F Too many valid timer event conditions.

The number of valid timer event conditions exceeds the maximum settable number.

0312 F Specified timer event is not set.

This timer event is not set.

0313 F Illegal map range.

The map setting is wrong.
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Table C-2.  Error Message List (3/21)

Error No. Type Error Message/Meaning

03a0 W Target is not turned on.

Power is not supplied to the target device.

03a1 F Step execution is being done.

This command is under step execution.

03a2 F Timer and Tracer are running.

The timer and tracer are operating.

03d0 A Backtrace is being executed.

Back trace is under execution.

03d1 A Backtrace is being stopped.

Back trace is stopped.

03d2 A Backtrace execution point overrun oldest frame.

The back trace execution stop position exceeds the oldest frame.

03d3 A Illegal AND condition.

AND condition is illegal.

03d4 A No backtrace information exists.

The back trace information does not exist.

03d5 A Last command can not be backstepped.

Back step of the last instruction could not be performed.

0400 F Illegal condition.

The specified condition is illegal.

0401 F Result of timer measurement overflowed.

The timer measurement result has overflow.

0402 F Too many event conditions with path count.

Too many event conditions that set path count have been used.

0403 F Too many address range conditions.

The maximum value of the address range specification condition is exceeded.

0404 F Too many simultaneously-usable-event conditions.

The maximum number of event conditions that can be used simultaneously is exceeded.

0405 F Too many snap-events.

The maximum number of snap events that can be set is exceeded.

0407 F Too many initialization data.

The number of initialized data exceeds the initialization area.

0408 F Too large search data (> 16 byte).

The searched data exceed 16 bytes.

0409 F Too large search data (> search range).

The size of the searched data exceeds the size of the search range.

040a F Too many Linking-event conditions.

The maximum number of integrated events that can be set is exceeded.

04a0 F Too many software breaks (> 100).

The number of software breaks exceeds 100.

04a1 F Not enough memory for emulation.

The memory for emulation is insufficient.
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Table C-2.  Error Message List (4/21)

Error No. Type Error Message/Meaning

04a2 F Too many partition of bus size.

The maximum number of delimiters of bus size has been exceeded.

04a3 F Too many execution-event conditions.

The maximum number of execution event conditions has been exceeded.

04a4 F Too many bus-event conditions.

The maximum number of bus event conditions has been exceeded.

0600 A Can not allocate buffer.

A buffer could not be allocated.

0c00 F Monitor file read error.

The monitor file could not be read.

0c20 F Guarded area can not be accessed.

There was an attempt to access a guarded area.

0c40 F Different address condition is specified in re-registering event.

The address condition when the event was reregistered was different to the previous one.

0c41 F Coverage test is being executed.

A coverage test is under execution.

0c60 F Event number with different condition exits.

An event number with a different condition exists.

0c61 F Can not register event numbers which can not be used for hardware break.

It is impossible to register event numbers that cannot be used for hardware breaks.

0c62 F Event numbers reserved for hardware breaks can not be used.

It is impossible to use event numbers that are used for hardware breaks.

0ca0 F Can not communicate with ICE.  Please confirm the power of ICE, connection of the interface

cable, or I/O address of the PC interface board.

Communication with the in-circuit emulator could not be established.  Check the in-circuit

emulator’s power supply, cable connection, I/O address settings, etc.

0ca1 F Monitor file not found.

The monitor file could not be found.

1000 A Failed in initializing ICE.

Initializing the in-circuit emulator has failed.

1001 A No entry exists for specified number.

The entry of the specified number does not exist.

1002 A Can not relocate internal RAM.

The internal RAM cannot be relocated.

1003 F Illegal relocation address.

The relocation address is illegal.

1004 F Illegal condition.

The specified condition is illegal.

1005 A Invalid attribute.

The attribute is invalid.

1006 F Illegal address.

The address is illegal.

1007 A Not enough memory on ICE.

In-circuit emulator alternate memory is short.
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Table C-2.  Error Message List (5/21)

Error No. Type Error Message/Meaning

1008 A Can not allocate memory for tables.

Memory for tables cannot be allocated.

1009 A Already initialized.

Already initialized.

100a A Not initialized.

Not initialized yet.

100b F User program is running.

The user program is being executed.

100c F Different bus size has been already specified.

An attempt was made to set in duplicate an area with different bus size.

100d F Too large bus size.

The bus size exceeds the maximum value able to be defined.

100e F Too large bus partition size.

The delimiter of bus size has exceeded the maximum value.

100f W Target is not turned on.

The power supply of the target is off.

1010 A Illegal map range.

An illegal map range specification was made.

1011 F Failed in setting internal ROM and RAM.

Setting the internal ROM and RAM has failed.

1012 F This feature is not supported.

This function is not supported.

1013 F No terminal name.

This pin name does not exist.

10ff A Can not communicate with ICE.

A communication error has occurred.  Communication with the in-circuit emulator cannot be

performed.

1dbe A Internal error.

Internal error of the debugger.

2000 F Illegal I/O register name.

The I/O register name is illegal.

2001 A Illegal address.

The address is illegal.

2002 F User program is running.

The user program is being executed.

2003 F Illegal I/O register number.

An illegal number of I/O registers were specified.

2004 F Illegal bit number.

The bit position is illegal.

2005 W Redraw I/O register name.

An I/O register that must not be redrawn is specified.

2006 F This I/O register is hidden I/O register.

An I/O register with a hidden attribute was specified.
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Table C-2.  Error Message List (6/21)

Error No. Type Error Message/Meaning

2007 F Can’t read/write.

A read/write disabled I/O register was specified.

2008 F Too big number.

The specified I/O register does not exist.

2009 A Error in device file.

A device file error.

200a F Illegal value specified for I/O register.

An illegal value was specified for the I/O register.

200b A Can not copy.

Copying has failed.

200c A Can not allocate memory.

Memory allocation has failed.

20ff A Can not communicate with ICE.

A communication error has occurred.  Communication with in-circuit emulator cannot be

established.

2222 A Illegal condition.

The specified condition is illegal.

3000 F Illegal address.

The address is illegal.

3001 F Memory has different value.

The memory contents do not match.

3002 F Illegal source address.

The source address is illegal.

3003 F Illegal destination address.

The destination address is illegal.

3004 F Illegal address (source & destination).

Both source address and destination address are illegal.

3005 F Illegal condition.

The specified condition is illegal.

3006 F User program is running.

The user program is being executed.

3007 A Verification error.

Verify error.

3008 F No condition specified.

A condition has not been specified.

3009 F Parameter size does not align with access size alignment.

The size of the parameter is not access size aligned.

300a F Specified address does not align with access size alignment.

The specified address is not access size aligned.

300b F Source address does not align with access size alignment.

The specified address (Source) is not access size aligned.

300c F Destination address does not align with access size alignment.

The specified address (Destination) is not access size aligned.
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Table C-2.  Error Message List (7/21)

Error No. Type Error Message/Meaning

300d F Illegal end address.

The end address is illegal.

300e F Different access size in specified area.

The access size differs in the specified range.

300f F Different access size both in source and destination areas.

The access size differs in the specified range (Source).

3010 F Different access size in destination area.

The access size differs in the specified range (Destination).

3011 F Different access size, source & destination.

The access size differs between the specified Source range and the specified Destination range.

3012 A Can not allocate memory.

Memory allocation has failed.

3013 A Failed in writing DMM.

Writing DMM has failed.

3014 F Overflowed mapping area.

The mapping area is exceeded.

3015 A Interrupted.

Processing is aborted.

3016 F This feature is not supported.

This function is not supported.

30ff A Can not communicate with ICE.

A communication error has occurred.  Communication with the in-circuit emulator cannot be

established.

4000 F Can not delete specified event number.

The specified event number cannot be deleted.

4001 F Illegal table number.

The specified table number is illegal.

4002 F Illegal start address.

The start address is illegal.

4003 F Illegal end address.

The end address is illegal.

4004 F Illegal status.

The status is illegal.

4005 F Illegal data.

The data is illegal.

4006 F Specified event number has been already used.

An attempt was made to specify an event number that has already been used.

4007 F Too many same events are registered.

The maximum of the number of registered events of the same type is exceeded.

4008 F Specified event has not been registered.

The specified event is not registered.

4009 F Illegal data size.

The data size is illegal.
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Table C-2.  Error Message List (8/21)

Error No. Type Error Message/Meaning

400a F Illegal mode.

The mode is illegal.

400b F Illegal condition.

The specified condition is illegal.

400c F Illegal type.

The type is illegal.

400d F Too many identical events are registered (>= 32767).

An attempt was made to make registration exceeding 32,767 of the same registered events.

400e F Specified event condition does not exist.

The specified event condition does not exist.

400f F Illegal event link condition.

An event link condition is illegal.

4010 F Function not found.

The specified function was not found.

4011 F Not enough memory.

Application has run out of memory.

4012 F Timer is being disabled.

The timer is invalid.

4013 W Access size is different from its mapped bus size.

The access size and mapped bus size differ.

4014 F Can not use software break.

Software break cannot be used.

4015 F Can not use event condition specifying address range.

An  event condition with a range specified cannot be used for an address condition.

4016 F Can not change event condition.

The event condition cannot be changed.

4017 F Can not access word at odd address.

Word access to an odd address cannot be performed.

4018 A Not enough memory.

Application has run out of memory.

4019 F Not support.

This function is not supported.

401a F No Event.

There is no event.

401b F Can not use tag-event.

A tag event cannot be used.

4318 F Illegal memory bank setting.

The setting of the memory bank is illegal.

5000 A Illegal type.

The type is illegal.

5001 A Can not allocate memory.

Memory allocation has failed.
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Table C-2.  Error Message List (9/21)

Error No. Type Error Message/Meaning

5002 A Can not open device file.

Opening the device file has failed.

5003 A Can not seek device file.

Seeking the device file has failed.

5004 A Can not close device file.

Closing the device file has failed.

5005 A Illegal device file format.

The format of the device file is wrong.

5006 A Failed in initializing ICE.

Initializing the in-circuit emulator has failed.

5007 A Device information does not exist.

Device information is missing.

5008 F Can not open device file.

The specified device file cannot be opened.

5009 F Can not open ie703000.ie.

ie703000.ie cannot be opened.

500a F Specified device file is illegal version.

The version of the device file is illegal.

500b W Specified device file does not relocate IRAM.

This device file does not relocate IRAM.

500c A Failed in reading expc.ini.

The initialization file (EXPC.INI) cannot be correctly read.

500d A Not enough memory.

The memory has run short.

5300 A Illegal type.

The type is illegal.

5301 A Can not allocate memory.

Memory allocation has failed.

5302 A Can not open database file.

The database file could not be opened.

5303 A Can not seek database file.

The database file could not be searched.

5304 A Can not close database file.

The database file could not be closed.

5305 A Illegal device format.

The format of the database file is illegal.

5306 A Database information has been already initialized.

Initialization of the database information is already finished.

5307 A Database information does not exist.

There is no database information.

5308 F Can not open specified database file.

The specified database file could not be opened.
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Table C-2.  Error Message List (10/21)

Error No. Type Error Message/Meaning

5309 F Specified database file is illegal version.

The version of the database file is illegal.

6000 F Current function does not exist.

The current function does not exist.

6001 F Illegal symbol name.

The symbol name is illegal.

6002 F Illegal condition.

The specified condition is illegal.

6003 F Illegal function name.

The function name is illegal.

6004 F Overflowed output buffer size.

The data size exceeds that of the output buffer.

6005 F Illegal expression.

The expression is illegal.

7000 F Illegal mode.

The specified mode is wrong.

7001 F User program is running.

The user program is being executed.

7002 F User program has been stopped.

The user program is being stopped.

7003 F Trace enabled.

Trace is being executed.

7004 F Trace memory is not set.

The trace memory is OFF.

7005 F Function return address does not exist, can not do step execution.

The return address of the function does not exist.  Step execution is not performed.

7010 W No source information exists.

The source information is missing.

7011 W Unknown result of step execution.

The result of step execution is unknown.

7012 A Not enough memory.

Application has run out of memory.

70fe A Bus hold error.

The bus is in the hold status.

70ff A Can not communicate with ICE.

A communication error has occurred.  Communication with the in-circuit emulator cannot be

established.

7801 F Canceled step wait.

The wait status following completion of step execution has been canceled.

7802 F Interrupted step execution.

Step execution processing was aborted.

7f00 F Aborted step execution.

Step execution processing was forcibly terminated.
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Table C-2.  Error Message List (11/21)

Error No. Type Error Message/Meaning

7f02 F Suspended step execution.

Step execution was aborted.

7f03 A Failed in canceling RUN/STEP.

Canceling RUN/STEP has failed.

7f04 F Can not execute non-mapped area.

An attempt is made to execute from an area not mapped.

7f05 F This feature is not supported.

This function is not supported.

8000 F File not found.

The specified file is not found.

8001 F Illegal line number.

The line number is illegal.

8002 F Current information is not set.

The current information is not set.

8003 F Illegal address.

The address is illegal.

8004 F This feature is not supported.

This function is not supported.

9000 A Specified register symbol does not exist.

The specified register symbol does not exist.

9001 A Specified register symbol ID does not exist.

The specified register symbol ID does not exist.

9002 F Illegal value.

The specified value is illegal.

9003 A Illegal condition.

The specified condition is illegal.

9004 A Too large register size.

The register size is too big.

9005 F This feature is not supported.

This function is not supported.

a001 F Illegal expression.

The expression is illegal.

a002 F Start address is bigger than the end address.

The start and end address specifications have been reversed.

a003 F Illegal source path.

The specified source path information is illegal.

a004 F Too long expression.

The expression is too long.

a005 A Not enough memory.

Application has run out of memory.

a006 F Illegal argument.

The argument is illegal.
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Table C-2.  Error Message List (12/21)

Error No. Type Error Message/Meaning

a007 A Illegal program number.

The program number is wrong.

a008 F Source path is not set.

The source path is not set.

a009 F File not found.

The file is not found.

a00a F Can not open file.

Opening the file has failed.

a00b A Can not close file.

Closing the file has failed.

a00c A Failed in reading file.

Reading the file has failed.

a00d F Not source file of load module.

This is not the load module’s source file.

a00e F Illegal line number.

The line number is illegal.

a00f F Variable does not exist.

The variable does not exist.

a010 A Can not communicate with ICE.

A communication error has occurred.  Communication with the in-circuit emulator cannot be

established.

a011 F Can not access register.

The register cannot be accessed.

a012 F Can not access memory.

The memory (variable) cannot be accessed.

a013 F Can not seek file.

Seeking a file has failed.

a014 F This is binary file.

This is a binary file.

a015 F Can not get temporary path.

A temporary path could not be allocated.

a016 F Can not create temporary file.

A temporary file could not be created.

a017 F Can not remove temporary file.

A temporary file could not be deleted.

a020 F This feature is not supported.

This function is not supported.

a021 F Specified symbol is assigned to register.

The specified symbol has already been assigned to a register.

b000 F Illegal command line.

The command line is illegal.

b001 F Program information does not exist in specified load module file.

The load module file does not have program information.
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Table C-2.  Error Message List (13/21)

Error No. Type Error Message/Meaning

b002 F File not found.

The file is not found.

b003 F Function not found.

The function is not found.

b004 F Illegal magic number.

The magic number is illegal.

b005 F Symbol not found.

The symbol is not found.

b008 F Illegal expression.

The expression is illegal.

b009 A Not enough memory.

Application has run out of memory.

b00a F Illegal symbol in load module file.

An illegal symbol exists in the load module file.

b00b F Current program does not exist.

The current program does not exist.

b00c F Current file does not exist.

The current file does not exist.

b00d A Current function does not exist.

A current function does not exist.

b00e A Current line does not exist.

A current line does not exist.

b00f A Tag not found.

No tag is found.

b010 A Failed in loading symbol table.

Loading the symbol table has failed.

b011 A Illegal line number.

The line number is illegal.

b012 F Too large line number.

The line number is too large.

b015 A Failed in reading file.

Reading the file has failed.

b016 A Can not open file.

Opening the file has failed.

b017 A Failed in writing file.

Writing the file has failed.

b019 A Can not seek file.

Seeking the file has failed.

b01a A Can not close file.

Closing the file has failed.

b01b A Too long load module file name.

The file name of the load module is too long.
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Table C-2.  Error Message List (14/21)

Error No. Type Error Message/Meaning

b01c A Too many entries of the task kind.

There are too many task classification entries.

b01d F Address not found.

The address does not exist.

b01e W No line information (not compile with -g).

There is no line information (it was not compiled using -g).

b01f F Can not find structure member.

The member of the structure cannot be found.

b020 F Can not find value.

The value could not be found.

b021 F No symbol information exists in load module file.

The load module file does not have symbol information.

b022 F Illegal line number.

The line number is illegal.

b023 A Current stack frame is not active.

The current stack frame is not active.

b024 A Different section.

The section is wrong.

b026 F Too many array dimensions (> 4).

The displayed array exceeds the fourth dimension.

b027 F Found end of file.

The file ends in the middle.

b028 F This feature is not supported.

This function is not supported.

b029 F Illegal address.

The address is illegal.

b02a A Can not communicate with ICE.

A communication error has occurred.  Communication between in-circuit emulator cannot be

established.

b02b F Can not stack trace with current PC value.

Stack trace cannot be executed with the current PC value.

b02c F Too many blocks for one function.

The maximum number of blocks allowable in 1 function has been exceeded.

b02d F Illegal argument.

The argument passed to the function is illegal.

b02e A Path not found.

The specified path is not found.

b02f A Information has been deleted because of optimization.

Information has been deleted as a result of optimization.

b030 A Monitor timed out.

Timeout for the monitor.

b031 A Already set in memory.

Already set on the memory.
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Table C-2.  Error Message List (15/21)

Error No. Type Error Message/Meaning

b032 A Out of scope.

Out of scope.

b033 A LP is not stored.

LP has not been stored.

b034 A Inside of prologue or epilogue.

Within the prologue or epilogue.

b036 W Out of variable region.

The specified variable cannot be referenced by the current PC.

b037 F Too Many Line-Numbers Information.

There is too much line information.

b038 F Compiler version missmatch.

Because this compiler version is not supported, the debug information could not be loaded.

b039 A Failed in loading debug information.

The debug information could not be loaded.

b03a A No more section information.

There is no section information.

b040 A Specified file is not load module.

The specified file is not in a load module format.

b041 A Too many files in load module to download.

The number of files in the load module exceeds the maximum number the debugger can handle.

b042 W Symbol module is not initialized.

The SYM module has not been initialized.

b32e F Illegal port number.

An illegal port number.

b32f F Illegal port name.

An illegal port name.

b330 F Illegal port position.

The bit position of the specified port is illegal.

b331 F Illegal increment number.

The specified increment count is illegal.

b332 F Port for memory bank is not set.

The port for memory bank is not set.

b333 F Illegal bank number.

An illegal bank number is specified.

b334 F Area for memory bank is not set.

An area for memory bank is not set.

b335 W Too long symbol name.

The symbol name is longer than the maximum allowable length.

c001 F Can not open file.

Opening the file has failed.

c002 A Can not close file.

Closing the file has failed.
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Table C-2.  Error Message List (16/21)

Error No. Type Error Message/Meaning

c003 A Failed in reading file.

Reading the file has failed.

c004 A Can not seek file.

Seeking the file has failed.

c005 F Illegal file type.

A non-existent file type has been specified.

c006 F Illegal magic number.

The magic number is illegal.

c007 F Specified file is not load module.

The specified file is not in a load module format.

c008 F Specified load module file (ELF) is old version.

The version of the load module file (ELF) is old.

c009 F Not enough memory.

Application has run out of memory.

c00a F Illegal address.

The address is illegal.

c00b F Load module is not loaded.

The load module is not loaded.

c00c F Illegal argument.

The argument is illegal.

c00d F User program is being emulated.

The user program is being emulated.

c00e F User program is being traced.

The user program is being traced.

c00f A Interrupted.

Under processing.

c010 A Can not communicate with ICE.

A communication error has occurred.  Communication between the in-circuit emulator cannot be

established.

c011 F Illegal load module file format.

The format of the load module file is wrong.

c012 F Check sum error.

A check sum error has occurred.

c013 F Too wide address range to upload (> 1M byte)

The address range to be uploaded exceeds 1 MB.

c014 F Failed in writing file.

Writing the file has failed.

c015 F Illegal program number.

The program number is illegal.

c016 F Load information is full.

The load information is full.

c017 W Symbol information is duplicated, please reset symbols.

The symbol information overlaps.  Reset the symbol.
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Table C-2.  Error Message List (17/21)

Error No. Type Error Message/Meaning

c018 F Specified file is not load module.

The specified file is not in a load module format.

c019 F Failed in writing memory.

Memory could not be written to.

c100 F This feature is not supported.

This function is not supported.

d000 A Internal error.

An error occurs inside the debugger.

d001 F Not enough memory.

Application has run out of memory.

d002 A Failed in reading initialization file (expc.ini).

The initialization file (EXPC.INI) cannot be read correctly.

d003 A ICE is not connected.

The in-circuit emulator is not connected.

d004 A Can not find Dynamic Link Library.

The dynamic link library could not be found.

e000 F Illegal argument.

The argument is illegal.

e001 F Illegal start address.

The start address is illegal.

e002 F Illegal end address.

The end address is illegal.

e003 F Too large size.

The address size is too large.

e004 F Can not open file.

Opening the file has failed.

e005 F Failed in reading file.

Reading the file has failed.

e006 F Can not seek file.

Seeking the file has failed.

e007 F Failed in writing file.

Writing the file has failed.

e008 F Not enough memory.

Application has run out of memory.

e009 F Illegal file format.

The file format is wrong.

e00a F Verification error.

Verify error.

e010 F This feature is not supported.

This function is not supported.

f000 F Not enough memory.

Application has run out of memory.
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Table C-2.  Error Message List (18/21)

Error No. Type Error Message/Meaning

f001 F XXX not found.

XXX could not be found.

f002 F not found XXX.  Search from the beginning?

XXX could not be found.  Do you want to search from the beginning?

f003 W Already exceed search region

The search range has already been exceeded.

f004 F Missing parameter.

The parameter is illegal.

f005 F Illegal name.

The name is illegal.

f006 F Illegal number.

The number is illegal.

f007 F Start address is bigger than end address.

Start address is bigger than end address.

f008 F Illegal expression

The expression is illegal.

f009 F XXX This file is illegal type.

XXX This file is an illegal type.

f100 F Disk cannot write or full.

Either the disk could not be written to or it is full.

f101 F File not found.

This file could not be found.

f102 F File not Create.

This file could not be created.

f103 F Old file version.

This file is an old version.

f104 F Illegal file type.

The file format is illegal.

f105 F This file is a project file for XXXX  Please select a correct file.

This project file is a file for XXX.  Specify a correct file.

f200 W No differences encountered.

There were no differences found.

f201 F Memory mapping error.

The memory could not be mapped.

f202 F Verify error.

Verify error.

f300 F Would you like to save the changes made in XXX?

Do you want the changes made in XXX to be saved?

f301 F The symbol being used on the event condition can’t be evaluated.

The symbol being used in the event condition could not be evaluated.

f302 F Delete XXX?

Do you want XXX to be deleted?
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Table C-2.  Error Message List (19/21)

Error No. Type Error Message/Meaning

f303 F XXX is edited.  Delete YYY?

XXX is being edited; do you want YYY to be deleted?

f304 F XXX is edited.  Save YYY?

XXX is being edited; do you want YYY to be saved?

f305 F XXX is already exist.  Do you replace it?

Do you want to replace the existing XXX?

f306 F This name is too long.

This name is too long.

f307 F There is the same name in other kinds.

The same name is being used in other conditions.

f308 F An address can’t be omitted.

An address cannot be omitted.

f309 F Illegal address mask.

The address mask is illegal.

f30a F Illegal data mask.

The data mask is illegal.

f30b F Illegal ext probe mask.

The external probe mask is illegal.

f30c F Illegal ext probe data.

The external probe data is illegal.

f30d F Illegal pass count.

The pass count is illegal.

f30e F Illegal register name.

The register name is illegal.

f30f F Illegal register bank.

The register bank is illegal.

f310 F Illegal delay count.

The delay count is illegal.

f311 F Only one XXX can be enabled.  Do you make this YYY to enable?

Only one XXX can be enabled; do you want to enable YYY?

f312 F XXX is already there.

XXX already exists.

f313 F Event number already exist.

This event number already exists.

f314 F Event name is not set.

The event name has not been set.

f315 F XXX is already there.

XXX already exists.

f316 F Max number of XXX enabled event is over.  Please disable other enabled event.

The maximum allowable number of valid event conditions has been exceeded.  Disable other

event conditions.

f317 F Max number of set event is over.

The maximum number of settable event conditions has been exceeded.
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Table C-2.  Error Message List (20/21)

Error No. Type Error Message/Meaning

f318 F Max number of set event link is over.

The maximum number of settable event link conditions has been exceeded.

f319 F Max number of set break event is over.

The maximum number of settable break conditions has been exceeded.

f31a F Max number of set trace event is over.

The maximum number of settable trace conditions has been exceeded.

f31b F Max number of set snap event is over.

The maximum number of settable snap conditions has been exceeded.

f31d F Max number of set timer event is over.

The maximum number of settable timer conditions has been exceeded.

f31e F Illegal start address.

The start address is illegal.

f31f F Illegal end address.

The end address is illegal.

f320 F Illegal bit address.

The bit address is illegal.

f321 F Specified read-protect I/O register.

A read-protected I/O register has been specified.

f350 F There is a phase which event are not in the middle.

An event condition setting is missing from the middle of a phase.

f351 F The same event is contained in Link and Disable.

The same event condition is already being used.

f352 F An event isn’t specified.

An event condition has not been set.

f353 F Incompatible event is specified in phase 1.

An incompatible event condition has been set in Phase 1.

f354 F AND event is in Phase 1.  Can’t specify event with exception of phase 1.

An AND condition event has already been set in Phase 1.  Event conditions cannot be set

anywhere except in Phase 1.

f355 F REG/MEM event in Disable.

The REG/MEM status event has been set to Disable.

f356 F AND event is in Disable.

The AND condition event has been set to Disable.

f400 F Coverage mapping error.

Coverage mapping could not be performed.

f401 F Clear coverage?

Do you want to clear the coverage?

f500 F Illegal symbol.

The symbol is illegal.

f501 F Illegal value.

The value is illegal.

f502 F Illegal parameter.

The parameter is illegal.
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Table C-2.  Error Message List (21/21)

Error No. Type Error Message/Meaning

f600 F Save project file?

Do you want to save the project file?

f601 W When connecting the target system, please turn on the target system.

When connecting the target system, be sure to turn its power supply on.

f700 F Download failed.

Data could not be downloaded.

f800 F Configuration of Memory Bank is not set.

The memory bank setting has not been made.

f801 F BANK address must be in target memory.

The address of the memory bank must be inside the target memory.

f802 F All events are deleted because the use of external probe was changed.

All event conditions have been deleted because the external probe has changed.

f803 F This event address is invalid on current configuration.

The address of this event condition is illegal.

f804 F Invalid PC value.

The PC value is illegal.

f805 F Cannot set temporary break on this address.

A temporary break cannot be set to this address.

f806 F External data is being used by Debugger.

External data is being used by the debugger.

f900 F Missing parameter.

The name is illegal.

f901 F Memory mapping error.

There is a fault with the memory mapping.

f902 F Illegal access size.

The access size is illegal.

f903 F Illegal access type.

The access type is illegal.

f904 F There is the same name.

The same name cannot be registered.

f905 W XXX is already exist.  Do you replace it?

Do you want to replace the existing XXX?

f906 W Would you like to register the change made in XXX?

Do you want to register the changes made to XXX?

fa00 F The “main(  )” function of current program on PC position not found.

The function “main(  )” of the PC position program could not be found.

fa01 F The line information on PC position not found.

The line information of the PC position could not be found.
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APPENDIX  D    KEY  FUNCTION  LIST

Efficient debugging can be realized by performing operations using the special function keys.

Note that because the key explanations differ depending on the type of keyboard in IBM PC/AT and compatible

machines, the key inscriptions employed here are general or generic key inscriptions.

D.1  Special Function Key Function List

A list of the special function key functions of the PC-9821 series and IBM PC/AT and compatibles is shown in the

table below.

Table D-1.  Special Function Key Function List (1/2)

Key Type

PC-9821 Series IBM PC/AT

Compatibles

Function

  BS  .   BackSpace  . Deletes a character preceding the cursor and moves the cursor to the position of the

deleted character.  At this time, the string of characters following the cursor moves

forward one space.

  DEL  .   Delete  . • Deletes a character at the cursor position and moves the following characters

forward one space.

• Deletes the event conditions selected in the Event Manager and each event dialog

box.

• Deletes the data selected in the Watch window.

  INS  .   Insert  . Switches the modes between insert mode and overwrite mode in the Source and

Assemble windows.  However, this key is disabled in the Memory, Register, and SFR

windows, where the input mode is overwrite mode only.

  COPY  .   PrintScreen  . Places the entire screen display on the clipboard as a bitmap image (Windows

function).

  ESC  .   Esc  . • Closes a pull-down menu.

• Closes a modal dialog box.

• Restores input data.

  GRPH  .   Alt  . Moves the cursor on the menu bar.

  HELP  .   End  . Moves the cursor to the end of the line.

  HOME CLR  .   Home  . Moves the cursor to the start of the line.

  ROLL DOWN  .   PageUp  . Scrolls the screen up one screen.

Simultaneously moves the cursor to the top of the screen.

  ROLL UP  .   PageDown  . Scrolls the screen down one screen.

Simultaneously moves the cursor to the top of the screen.

  SPACE  .   Space  . Inserts a 1-character space.

  TAB  .   Tab  . Moves the cursor to the next item.

  ↑  .   ↑  . Moves the cursor up.

When the cursor is at the top of the screen, the screen is scrolled down one line at a

time.
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Table D-1.  Special Function Key Function List (2/2)

Key Type

PC-9821 Series IBM PC/AT

Compatibles

Function

  ↓  .   ↓  . Moves the cursor down.

When the cursor is at the bottom of the screen, the screen is scrolled up one line at a

time.

  ←  .   ←  . Moves the cursor to the left.

When the cursor is on the far left of the screen, the screen is scrolled to the right one

item at a time.

  →  .   →  . Moves the cursor to the right.

When the cursor is on the far right of the screen, the screen is scrolled to the left one

item at a time.

  ↵  .   ↵  . •  Sets the input data.

•  Presses the default push button.

D.2  Function Key Function List

A list of the function key functions of the PC-9821 series and IBM PC/AT and compatibles is shown in the table

below.

Table D-2.  Function Key Function List (1/2)

Key Type

PC-9821 Series IBM PC/AT

Compatibles

Function

  f·1  .   F1  . Opens the Help window.

  f·2  .   F2  . Forcibly stops program execution.

The same function as [Run] → [Stop] on the menu bar.

  f·3  .   F3  . Resets the emulation CPU.

The same function as [Run] → [CPU Reset] on the menu bar.

  f·4  .   F4  . Executes the program after resetting the emulation CPU.

The same function as [Run] → [Restart] on the menu bar.

  f·5  .   F5  . Executes the program.

The same function as [Run] → [Go & Go] on the menu bar.

  f·6  .   F6  . Executes the program as far as the cursor position in the Source or Assemble window.

The same function as [Run] → [Come Here] on the menu bar.

  f·7  .   F7  . Executes the program in real-time until execution returns to the calling origin.

The same function as [Run] → [Return Out] on the menu bar.

  f·8  .   F8  . Performs step execution.

The same function as [Run] → [Step In] on the menu bar.

  f·9  .   F9  . Sets/cancels a breakpoint at the cursor position in the Source or Assemble window.

The same function as [Run] → [Break Point] on the menu bar.
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Table D-2.  Function Key Function List (2/2)

Key Type

PC-9821 Series IBM PC/AT

Compatibles

Function

  f·10  .   F10  . Performs next step execution.

The same function as [Run] → [Next Over] on the menu bar.

  vf·1  .   F11  . Sets/cancels a software breakpoint.

The same function as [Run] → [Software Break Point] on the menu bar.

  vf·2  .   F12  . Enables/disables a breakpoint.

The same function as [Run] → [Ignore Break Point] on the menu bar.

D.3  Special Function Key Function List (  SHIFT   + Key)

A list of the special function key functions (  SHIFT   + key) of the PC-9821 series and IBM PC/AT and compatibles

is shown in the table below.

Table D-3.  Special Function Key Function List (  SHIFT   + Key)

Key Type

PC-9821 Series IBM PC/AT

Compatibles

Function

  HELP  .   End  . Extends the selected range to the end of the line.

  HOME CLR  .   Home  . Extends the selected range to the start of the line.

  ←  .   ←  . Extends the selected range one character to the left.

  →  .   →  . Extends the selected range one character to the right.

D.4  Function Key Function List (  SHIFT   + Key)

A list of the function key functions (  SHIFT   + key) of the PC-9821 series and IBM PC/AT and compatibles is

shown in the table below.

Table D-4.  Function Key Function List (  SHIFT   + Key)

Key Type

PC-9821 Series IBM PC/AT

Compatibles

Function

  f·6  .   F6  . Executes the program from the cursor position in the Source or Assemble window.

The same function as [Run] → [Start From Here] on the menu bar.
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D.5  Special Function Key Function List (  CTRL   + Key)

A list of the special function key functions (  CTRL   + key) of the PC-9821 series and IBM PC/AT and compatibles

is shown in the table below.

Table D-5.  Special Function Key Function List (  CTRL   + Key)

Key Type

PC-9821 Series IBM PC/AT

Compatibles

Function

  HELP  .   End  . Displays the last line.  Simultaneously moves the cursor to the start of the last line.

  HOME CLR  .   Home  . Displays the first line.  Simultaneously moves the cursor to the start of the first line.

  ←  .   ←  . Moves the cursor one word to the left.  When the cursor is on the far left of the screen,

the screen is scrolled one item to the right.

  →  .   →  . Moves the cursor one word to the right.  When the cursor is on the far right of the

screen, the screen is scrolled one item to the left.

D.6  Function Key Function List (  CTRL   + Key)

A list of the function key functions (  CTRL   + key) of the PC-9821 series and IBM PC/AT and compatibles is

shown in the table below.

Table D-6.  Function Key Function List (  CTRL   + Key)

Key Type

PC-9821 Series IBM PC/AT

Compatibles

Function

  f·9  .   F9  . Sets the address of the cursor position in the Source or Assemble window in the PC.

The same function as [Run] → [Change PC] on the menu bar.

D.7  Control Key Function List (  CTRL   + Key)

A list of the control key functions (  CTRL   + key) of the PC-9821 series and IBM PC/AT and compatibles is shown

in the table below.

Table D-7.  Control Key Function List (  CTRL   + Key) (1/2)

Key Type

PC-9821 Series

IBM PC/AT Compatibles

Function

  D  . Shows a disassemble display from the jump destination address of the data value selected in the

current window.  Opens the Assemble window.

The same function as [Jump] → [Assemble] on the menu bar.

  C  . Copies the selected character string and places it in the clipboard buffer.

The same function as [Edit] → [Copy] on the menu bar.
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Table D-7.  Control Key Function List (  CTRL   + Key) (2/2)

Key Type

PC-9821 Series

IBM PC/AT Compatibles

Function

  G  . Performs a search.  Opens the search dialog box appropriate to the current window.

The same function as [View] → [Search…] on the menu bar.

  I  . Displays the memory contents from the jump destination address of the data value selected in the

current window.  Opens the Coverage window.

The same function as [Jump] → [Coverage] on the menu bar.

  J  . Moves the display position.  Opens the Source Move, Address Move, and Trace Move dialog box

appropriate to the current window.

The same function as [View] → [Move…] on the menu bar.

  M  . Displays the memory contents from the jump destination address of the data value selected in the

current window.  Opens the Memory window.

The same function as [Jump] → [Memory] on the menu bar.

  O  . Loads a display, source, or text file.

Opens the View File Load dialog box.  Operations differ depending on the file extension.

For display files: Displayed in corresponding window.

For other files: Displayed in Source window.

The same function as [File] → [Open…] on the menu bar.

  U  . Displays the corresponding source text and source line from the jump destination address of the

data value selected in the current window.  Opens the Source window.

The same function as [Jump] → [Source] on the menu bar.

  V  . Pastes the contents of the clipboard buffer at the cursor position.

The same function as [Edit] → [Paste] on the menu bar.

  W  . Temporarily displays the contents of the specified data.  Opens the Quick Watch dialog box.

The same function as [View] → [Quick Watch…] on the menu bar.

  X  . Removes the selected character string and places it on the clipboard buffer.

The same function as [Edit] → [Cut] on the menu bar.

D.8  Special Function Key Function List (  CTRL   +   SHIFT   Key)

A list of the special function key functions (  CTRL   +   SHIFT   key) of the PC-9821 series and IBM PC/AT and

compatibles is shown in the table below.

Table D-8.  Special Function Key Function List (  CTRL   +   SHIFT   Key)

Key Type

PC-9821 Series IBM PC/AT

Compatibles

Function

  ←  .   ←  . Extends the selected range one word to the left.

  →  .   →  . Extends the selected range one word to the right.



User’s Manual  U14910EJ1V0UM00396

[MEMO]



User’s Manual  U14910EJ1V0UM00 397

APPENDIX  E    INDEX

[A]

About dialog box.................................................... 351

Add I/O Port dialog box.......................................... 218

Add Watch dialog box............................................ 204

Address ................................................................. 363

Address Move dialog box ...................................... 140

All trace.................................................................... 47

Assemble Search dialog box ................................. 176

Assemble window.................................................. 165

Automatic mode................................................60, 360

[B]

Bank Set dialog box................................................. 91

Break by Come function .......................................... 45

Break dialog box.................................................... 296

Break function.......................................................... 45

Break on satisfaction of condition during step

execution.............................................................. 45

Breakpoint setting function .............................157, 172

Browse dialog box ................................................. 135

[C]

Character set ......................................................... 366

Clearing coverage result........................................ 256

Come function ................................................157, 171

Conditional trace...................................................... 47

Configuration dialog box .......................................... 86

Coverage-Clear dialog box .................................... 256

Coverage-Condition Setting dialog box ................. 258

Coverage-Efficiency View dialog box..................... 261

Coverage measurement function............................. 50

Coverage Search dialog box ................................. 252

Coverage window .................................................. 247

Current file ............................................................. 361

Current function ..................................................... 361

Current program .................................................... 360

Current window...................................................... 360

[D]

Debugger Option dialog box .................................. 101

Debugging environment..................................112, 115

Debugging with ID78K0-NS and ID78K0S-NS ...... 355

Delay Count dialog box.......................................... 347

Delimiter symbol .................................................... 360

Detailed display mode............................................266

Dialog box ..............................................................368

Disassemble display ..............................................165

Display file................................................................51

Displaying PC register value ..........................153, 168

Displaying stack contents.......................................235

DMM dialog box .....................................................339

Download dialog box..............................................128

Drag-and-drop function ..................................159, 174

[E]

Emulation board .......................................................21

Emulation execution functions..................................40

Emulation RAM ........................................................39

Emulation ROM........................................................39

Error message list ..................................................370

Error/Warning dialog box........................................354

Event condition.........................................................43

Event detection break...............................................45

Event dialog box.....................................................276

Event function ..........................................................42

Event link condition ................................................288

Event Link dialog box .............................................288

Event Manager.......................................................264

Execution event......................................................279

Exit Debugger dialog box .......................................352

Exiting ......................................................................37

Explanation of windows............................................59

Expression and operator ........................................364

Extended Option dialog box .....................................97

Extended Tektronix HEX format.....................128, 132

External sense clip .................................................282

[F]

Fail-safe break .........................................................46

File ...................................................................51, 360

Font dialog box.......................................................109

Forced break ............................................................46

Function .................................................................361

[H]

Host machine ...........................................................21

IBM PC/AT or compatibles ...................................21

PC-9821 series.....................................................21



APPENDIX  E    INDEX

User’s Manual  U14910EJ1V0UM00398

PC98-NX series.................................................... 21

[I]

In-circuit emulator .................................................... 21

IE-78K0-NS .......................................................... 21

IE-78K0-NS-A....................................................... 21

IE-78K0-NS-A....................................................... 21

IE-78K0S-NS........................................................ 21

IE-78K0S-NS-A .................................................... 21

In-circuit emulator optional board

IE-780xxx-NS-EM1............................................... 21

IE-780xxx-NS-EM4............................................... 21

IE-78K0-NS-P0x................................................... 21

IE-78K0-NS-PA .................................................... 21

Information file ......................................................... 51

Instruction mode .............................................. 60, 360

Intel HEX format............................................. 128, 132

Interface board......................................................... 21

IE-70000-98-IF-C ................................................. 21

IE-70000-CD-IF-A ................................................ 21

IE-70000-PC-IF-C ................................................ 21

IE-70000-PCI-IF(-A) ............................................. 21

Internal RAM............................................................ 39

Internal ROM............................................................ 39

I/O protect area ........................................................ 39

[J]

Jump function................. 158, 172, 182, 225, 233, 250

[L]

Line ........................................................................ 361

List display mode ................................................... 266

Load/save function................................................... 51

Local Variable window ........................................... 221

[M]

Main window ............................................................ 60

Mapping function...................................................... 39

Mask Option dialog box ........................................... 95

Measuring execution time ...................................... 327

Memory Compare dialog box................................. 191

Memory Compare Result dialog box...................... 193

Memory Copy dialog box ....................................... 189

Memory Fill dialog box ........................................... 187

Memory manipulation............................................... 52

Memory Search dialog box .................................... 184

Memory window..................................................... 179

Mixed display mode ............................... 150, 155, 232

Motorola HEX format ............................................. 128

MS-DOS ...................................................................53

[N]

NEC load module ...................................................128

Next step execution............................................41, 62

Non-map break.........................................................46

Non real-time execution function ..............................41

Normal display mode......................150, 155, 232, 289

Numeric value ........................................................362

[O]

Operating environment .............................................21

Operation of trace.....................................................47

Operator .................................................................364

OS

Windows 95, 98, 2000, NT4.0...............................21

[P]

Pass Count dialog box............................................345

Performance board...................................................21

Point mark display area ..........................151, 166, 228

Program..................................................................360

Program counter setting function....................158, 172

Project file...........................................51, 86, 113, 116

Project File Load dialog box ...................................112

Project File Save dialog box ...................................115

Project Manager .......................................................53

[Q]

Qualify trace ...........................................................308

Quick Watch dialog box..........................................200

Quick watch function ......................................159, 173

[R]

Real-time execution function ....................................40

Real-time RAM sampling function ............................52

Register manipulation...............................................52

Register name ........................................................361

Register window .....................................................207

Registering link condition........................................288

Reset Debugger dialog box ....................................349

[S]

Select mode ...........................................................289

Setting external sense data condition.....................282

Setting operating environment..................................86

SFR illegal access break ..........................................46

SFR select dialog box.............................................215

SFR window ...........................................................211



APPENDIX  E    INDEX

User’s Manual  U14910EJ1V0UM00 399

Snap Shot dialog box............................................. 313

Snapshot function.................................................... 50

Software break ........................................................ 45

Software Break Manager ....................................... 273

Source mode ....................................................60, 360

Source Move dialog box ........................................ 137

Source Search dialog box...................................... 162

Source window ...................................................... 149

Specifying address ................................................ 141

Stack frame number .......................................224, 361

Stack window......................................................... 223

Start function ..................................................157, 171

Starting .................................................................... 35

Status condition ..................................................... 279

Status display area .................................................. 64

Step execution................................................... 41, 61

Structure ................................................................ 361

Symbol................................................................... 363

Symbol To Address dialog box .............................. 146

System register........................................................ 52

[T]

Term ...................................................................... 366

Time measurement function .................................... 52

Time tag display .................................................... 230

Timer dialog box .................................................... 327

Timer Result dialog box ......................................... 337

Toolbar .................................................................... 61

Trace condition setting function ............................... 48

Trace Data Select dialog box................................. 244

Trace dialog box .................................................... 303

Trace function.......................................................... 47

Trace mode ............................................................. 47

Trace Move dialog box .......................................... 143

Trace result display function .................................... 49

Trace Search dialog box........................................ 236

Trace View window................................................ 227

[U]

Upload dialog box.................................................. 132

User area mapping .................................................. 39

[V]

View File Load dialog box...................................... 119

View File Save dialog box...................................... 122

[W]

Watch function................................................159, 173

Watch window ....................................................... 195

Window link function ...................... 155, 182, 234, 250

Window list ...............................................................57

Window types and configuration ............................368

Windows...................................................................19

Write-protect break.............................................39, 46



User’s Manual  U14910EJ1V0UM00400

[MEMO]



Although NEC has taken all possible steps
to ensure that the documentation supplied
to our customers is complete, bug free
and up-to-date, we readily accept that
errors may occur.  Despite all the care and
precautions we've taken, you may
encounter problems in the documentation.
Please complete this form whenever
you'd like to report errors or suggest
improvements to us.

Hong Kong, Philippines, Oceania
NEC Electronics Hong Kong Ltd.
Fax:  +852-2886-9022/9044

Korea
NEC Electronics Hong Kong Ltd.
Seoul Branch
Fax:  02-528-4411

Taiwan
NEC Electronics Taiwan Ltd.
Fax:  02-2719-5951

Address

North America
NEC Electronics Inc.
Corporate Communications Dept.
Fax: 1-800-729-9288

1-408-588-6130

Europe
NEC Electronics (Europe) GmbH
Technical Documentation Dept.
Fax:  +49-211-6503-274

South America
NEC do Brasil S.A.
Fax:  +55-11-6462-6829

Asian Nations except Philippines
NEC Electronics Singapore Pte. Ltd.
Fax:  +65-250-3583

Japan
NEC Semiconductor Technical Hotline
Fax:  044-435-9608

I would like to report the following error/make the following suggestion:

Document title:

Document number: Page number:

Thank you for your kind support.

If possible, please fax the referenced page or drawing.

Excellent Good Acceptable PoorDocument Rating

Clarity

Technical Accuracy

Organization

CS  00.6

Name

Company

From:

Tel. FAX

Facsimile  Message


